summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-07-19 09:35:19 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-07-19 09:35:19 +0000
commit9f828f76ce7aaac6514751b63cddb9e97e3cb0b3 (patch)
tree0289098a6401deba854b8d0f61f3656743d456f3 /net-mail/imapsync/imapsync-1.255-r1.ebuild
parentRevert to ~arch since it breaks impasync, bug #232277 (diff)
downloadgentoo-2-9f828f76ce7aaac6514751b63cddb9e97e3cb0b3.tar.gz
gentoo-2-9f828f76ce7aaac6514751b63cddb9e97e3cb0b3.tar.bz2
gentoo-2-9f828f76ce7aaac6514751b63cddb9e97e3cb0b3.zip
Fix dep on Mail-IMAPClient as per #232277
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'net-mail/imapsync/imapsync-1.255-r1.ebuild')
-rw-r--r--net-mail/imapsync/imapsync-1.255-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/imapsync/imapsync-1.255-r1.ebuild b/net-mail/imapsync/imapsync-1.255-r1.ebuild
new file mode 100644
index 000000000000..cd3cb0356f72
--- /dev/null
+++ b/net-mail/imapsync/imapsync-1.255-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/imapsync-1.255-r1.ebuild,v 1.1 2008/07/19 09:35:19 dertobi123 Exp $
+
+inherit eutils
+
+DESCRIPTION="A tool allowing incremental and recursive imap transfer from one mailbox to another."
+HOMEPAGE="http://www.linux-france.org/prj/"
+SRC_URI="http://www.linux-france.org/prj/imapsync/dist/${P}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ virtual/perl-Digest-MD5
+ dev-perl/Net-SSLeay
+ virtual/perl-MIME-Base64
+ dev-perl/TermReadKey
+ dev-perl/IO-Socket-SSL
+ dev-perl/Digest-HMAC
+ =dev-perl/Mail-IMAPClient-2.2.9"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s/^install: testp/install:/" \
+ -e "s/^\(all: ChangeLog README\) VERSION/\1/" "${S}"/Makefile || die
+}
+
+src_compile() {
+ emake all || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make failed"
+ dodoc CREDITS ChangeLog FAQ README TODO || die "dodoc failed"
+}