summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-12-24 02:43:57 +0000
committerDonny Davies <woodchip@gentoo.org>2001-12-24 02:43:57 +0000
commit4bb7e1f641f1443bec97abfbc62397429622a7d2 (patch)
treed1c5ad49cf48398b9408d4e9d9f04c15f0e71c33 /net-mail/fetchmail
parentAdded tech preview 2. (diff)
downloadgentoo-2-4bb7e1f641f1443bec97abfbc62397429622a7d2.tar.gz
gentoo-2-4bb7e1f641f1443bec97abfbc62397429622a7d2.tar.bz2
gentoo-2-4bb7e1f641f1443bec97abfbc62397429622a7d2.zip
Newest version, bumps us from -5.9.0 to -5.9.6. Purged some
older -5.8.* ebuilds and digests. Some general housecleaning fixes.
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/fetchmail-5.9.6.ebuild41
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-5.9.61
2 files changed, 42 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-5.9.6.ebuild b/net-mail/fetchmail/fetchmail-5.9.6.ebuild
new file mode 100644
index 000000000000..bca871eb5277
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-5.9.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Parag Mehta <pm@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-5.9.6.ebuild,v 1.1 2001/12/24 02:43:57 woodchip Exp $
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+DEPEND="virtual/glibc ssl? ( >=dev-libs/openssl-0.9.6 ) nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+ use nls || myconf="${myconf} --disable-nls"
+ # This needs inet6-apps, which we don't have
+ #use ipv6 && myconf="{myconf} --enable-inet6"
+
+ ./configure \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} ${myconf} || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README
+ dodoc README.NTLM README.SSL TODO COPYING MANIFEST
+ docinto html ; dodoc *.html
+ docinto contrib ; dodoc contrib/*
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-5.9.6 b/net-mail/fetchmail/files/digest-fetchmail-5.9.6
new file mode 100644
index 000000000000..3bf30cee41ce
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-5.9.6
@@ -0,0 +1 @@
+MD5 8a97f627da2f09c536b3ba86e2ae8919 fetchmail-5.9.6.tar.gz 868352