summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2002-12-17 09:13:07 +0000
committerStefan Jones <cretin@gentoo.org>2002-12-17 09:13:07 +0000
commit1fa13532bdb5290503488c1502c00aa44ce72384 (patch)
treed719b84f5f09ed8d9ba9e35cfcb43834c25beed0 /net-mail/evolution
parentNew version for evolution (diff)
downloadgentoo-2-1fa13532bdb5290503488c1502c00aa44ce72384.tar.gz
gentoo-2-1fa13532bdb5290503488c1502c00aa44ce72384.tar.bz2
gentoo-2-1fa13532bdb5290503488c1502c00aa44ce72384.zip
New evolution bugfix version
Diffstat (limited to 'net-mail/evolution')
-rw-r--r--net-mail/evolution/ChangeLog9
-rw-r--r--net-mail/evolution/evolution-1.2.1.ebuild211
-rw-r--r--net-mail/evolution/files/digest-evolution-1.2.12
3 files changed, 220 insertions, 2 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index f668ac460213..a7250b2f554e 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for net-mail/evolution
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.36 2002/12/13 11:00:07 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.37 2002/12/17 09:13:07 cretin Exp $
10 Dec 2002; foser <foser@gentoo.org> evolution-1.0.7.ebuild evolution-1.0.8-r2.ebuild evolution-1.2.0.ebuild evolution-1.2.0-r1.ebuild :
Fixed gob deps (bug #11633)
-
+
+*evolution-1.2.1 (17 Dec 2002)
+
+ 17 Dec 2002; Stefan Jones <cretin@gentoo.org> :
+ New version, removed old patches and updated deps.
+
*evolution-1.2.0-r1 (09 Dec 2002)
09 Dec 2002; Martin Schlemmer <azarah@gentoo.org> evolution-1.2.0-r1.ebuild :
diff --git a/net-mail/evolution/evolution-1.2.1.ebuild b/net-mail/evolution/evolution-1.2.1.ebuild
new file mode 100644
index 000000000000..6e9b013692ce
--- /dev/null
+++ b/net-mail/evolution/evolution-1.2.1.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.2.1.ebuild,v 1.1 2002/12/17 09:13:07 cretin Exp $
+
+IUSE="ssl nls mozilla ldap doc spell pda ipv6"
+
+#provide Xmake and Xemake
+
+inherit eutils gnome.org virtualx libtool
+
+DB3="db-3.1.17"
+S="${WORKDIR}/${P}"
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="${SRC_URI}
+ http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+RDEPEND="app-text/scrollkeeper
+ >=gnome-extra/bonobo-conf-0.16
+ >=gnome-base/bonobo-1.0.21
+ >=gnome-base/gnome-common-1.2
+ >=gnome-extra/gal-0.22
+ =gnome-base/gconf-1.0*
+ >=gnome-extra/gtkhtml-1.1.7
+ >=gnome-base/oaf-0.6.10
+ >=gnome-base/ORBit-0.5.12
+ ( >=gnome-base/libglade-0.17-r1
+ <gnome-base/libglade-2.0 )
+ >=media-libs/gdk-pixbuf-0.18.0
+ >=dev-libs/libxml-1.8.17
+ =gnome-base/gnome-vfs-1.0*
+ >=gnome-base/gnome-print-0.35
+ =dev-util/gob-1*
+ >=net-libs/soup-0.7.4-r1
+ doc? ( >=app-text/scrollkeeper-0.3.10-r1 )
+ ssl? ( >=net-www/mozilla-0.9.9 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ ldap? ( >=net-nds/openldap-2.0 )
+ mozilla? ( >=net-www/mozilla-0.9.9 )
+ pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2
+ >=dev-libs/pilot-link-0.11.5 )
+ spell? ( >=app-text/gnome-spell-0.5 )"
+
+# the pilot-link dep is normally covered by gnome-pilot, but evo
+# requires an higher version then gnome-pilot (bug #10307)
+
+# ssl? ( mozilla? ( >=net-www/mozilla-0.9.9 ) )
+# ssl? ( !mozilla? ( >=dev-libs/openssl-0.9.5 ) )
+# This is how the deps should be, but portage cannot handle it
+
+# Added dependency on "dev-util/gob" this should fix a configure bug
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4.1-r1
+ doc? ( dev-util/gtk-doc )
+ nls? ( >=dev-util/intltool-0.20
+ sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S};
+ # Mandrake patches
+ epatch ${FILESDIR}/${PN}-1.1.90-kde.patch
+ epatch ${FILESDIR}/${PN}-1.1.90-subversion.patch
+ epatch ${FILESDIR}/${PN}-1.1.90-sharedldap.patch
+
+ # libtoolize to fix not all libs installing, and buggy .la files.
+ # also add the gnome-pilot.m4 to the macros directory to fix
+ # problems with the pilot conduct
+ cd ${S}; cp -f ltmain.sh ${S}/libical/
+ elibtoolize --reverse-deps
+ aclocal -I macros -I /usr/share/aclocal/gnome-macros
+ autoconf
+ automake --add-missing
+
+ (cd libical ; aclocal -I /usr/share/aclocal/gnome-macros ; autoconf)
+
+ # Fix sandbox errors
+ cd ${S}/default_user
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:-mkdir $(defaultdir:-mkdir $(DESTDIR)$(defaultdir:g' \
+ Makefile.in.orig > Makefile.in
+}
+
+src_compile() {
+
+ # *************************************************************
+ #
+ # DB3 compile...
+ #
+ # *************************************************************
+
+ einfo "Compiling DB3..."
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+
+ make || die
+ make prefix=${WORKDIR}/db3 install || die
+
+ # *************************************************************
+ #
+ # Evolution compile...
+ #
+ # *************************************************************
+
+ einfo "Compiling Evolution..."
+ cd ${S}
+
+ local myconf=""
+ local MOZILLA="${MOZILLA_FIVE_HOME}"
+
+ if [ -n "`use pda`" ] ; then
+ myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
+ else
+ myconf="${myconf} --enable-pilot-conduits=no"
+ fi
+
+ if [ -n "`use ldap`" ] ; then
+ myconf="${myconf} --with-openldap=yes --with-static-ldap=no"
+ else
+ myconf="${myconf} --with-openldap=no"
+ fi
+
+ # Use Mozilla NSS libs if 'mozilla' *and* 'ssl' in USE
+ if [ -n "`use ssl`" -a -n "`use mozilla`" ] ; then
+ myconf="${myconf} --enable-nss=yes \
+ --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA} \
+ --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ # Else use OpenSSL if 'mozilla' not in USE ...
+ if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
+ myconf="${myconf} --enable-openssl=yes"
+ fi
+
+ if [ -n "`use doc`" ] ; then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6=yes"
+ else
+ myconf="${myconf} --enable-ipv6=no"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} -I/usr/include/libpisock"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-db3=${WORKDIR}/db3 \
+ --disable-python-bindings \
+ ${myconf} || die
+
+ #needs to be able to connect to X display to build.
+ Xemake || Xmake || die
+}
+
+src_install() {
+ cd omf-install
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ # Install with $DESTDIR, as in some rare cases $D gets hardcoded
+ # into the binaries (seems like a ccache problem at present),
+ # because everything is recompiled with the "new" PREFIX, if
+ # $DESTDIR is _not_ used.
+ make DESTDIR=${D} \
+ prefix=/usr \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ datadir=/usr/share \
+ sysconfdir=/etc \
+ localstatedir=/var/lib \
+ KDE_APPLNK_DIR=/usr/share/applnk \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
diff --git a/net-mail/evolution/files/digest-evolution-1.2.1 b/net-mail/evolution/files/digest-evolution-1.2.1
new file mode 100644
index 000000000000..545f4b73f891
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.2.1
@@ -0,0 +1,2 @@
+MD5 51ce3295f280c6533ecbcd9df45c6691 evolution-1.2.1.tar.bz2 12218363
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117