summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2007-05-29 17:39:30 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2007-05-29 17:39:30 +0000
commit9659fca29f58b2d1086ecd40dcc7a3b6d77f16ab (patch)
tree9b9b24cb92f73c229956ef80ea0ea36fcf8e78d5 /net-mail/dbmail
parentalpha/x86 stable wrt #174413 (diff)
downloadgentoo-2-9659fca29f58b2d1086ecd40dcc7a3b6d77f16ab.tar.gz
gentoo-2-9659fca29f58b2d1086ecd40dcc7a3b6d77f16ab.tar.bz2
gentoo-2-9659fca29f58b2d1086ecd40dcc7a3b6d77f16ab.zip
added 2.2.5 rc3
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-mail/dbmail')
-rw-r--r--net-mail/dbmail/ChangeLog8
-rw-r--r--net-mail/dbmail/dbmail-2.2.5_rc3.ebuild101
-rw-r--r--net-mail/dbmail/files/digest-dbmail-2.2.5_rc33
3 files changed, 111 insertions, 1 deletions
diff --git a/net-mail/dbmail/ChangeLog b/net-mail/dbmail/ChangeLog
index 3791b3f46b4f..4c30506af3a8 100644
--- a/net-mail/dbmail/ChangeLog
+++ b/net-mail/dbmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/dbmail
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.3 2007/05/15 11:44:12 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.4 2007/05/29 17:39:30 lordvan Exp $
+
+*dbmail-2.2.5_rc3 (29 May 2007)
+
+ 29 May 2007; Thomas Raschbacher <lordvan@gentoo.org>
+ +dbmail-2.2.5_rc3.ebuild:
+ added 2.2.5 rc3
*dbmail-2.2.5_rc2 (15 May 2007)
diff --git a/net-mail/dbmail/dbmail-2.2.5_rc3.ebuild b/net-mail/dbmail/dbmail-2.2.5_rc3.ebuild
new file mode 100644
index 000000000000..9420ce301bca
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.5_rc3.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.5_rc3.ebuild,v 1.1 2007/05/29 17:39:30 lordvan Exp $
+
+inherit eutils
+
+MY_P="${P/_/}" # for rcX
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=dev-db/postgresql-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8"
+
+S=${WORKDIR}/${P/_/}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ cp dbmail.conf.dist dbmail.conf
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+}
diff --git a/net-mail/dbmail/files/digest-dbmail-2.2.5_rc3 b/net-mail/dbmail/files/digest-dbmail-2.2.5_rc3
new file mode 100644
index 000000000000..29658cf0109b
--- /dev/null
+++ b/net-mail/dbmail/files/digest-dbmail-2.2.5_rc3
@@ -0,0 +1,3 @@
+MD5 aa645b04fed7c0d851d9019f3e82bf2a dbmail-2.2.5rc3.tar.gz 883343
+RMD160 9a38733e8e56b28c49e8203bb31a03e62956b315 dbmail-2.2.5rc3.tar.gz 883343
+SHA256 5f6eb25cb71c7ef61d1a66df44ef5e6fdbb562e78be1caa76cc09bb99f8c9f3e dbmail-2.2.5rc3.tar.gz 883343