summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-27 10:11:06 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-27 10:11:06 +0000
commite715b72c3c67868a090af6d5a49e452c27de25b9 (patch)
treef3a3fc67bf2f60e02c41c3b2db957001ee783e10 /net-libs
parentBump, fixes bug #222153 and through it, bug #220309. (diff)
downloadgentoo-2-e715b72c3c67868a090af6d5a49e452c27de25b9.tar.gz
gentoo-2-e715b72c3c67868a090af6d5a49e452c27de25b9.tar.bz2
gentoo-2-e715b72c3c67868a090af6d5a49e452c27de25b9.zip
Fix bug #218774 by using --enable-debug, since otherwise your CFLAGS get sedded to kill the make. Fix bug #225387 wrt gcc-4.3 compat. Thanks to Marek Miller <mlm@ngc17.pl> for the patch. Drop old.
(Portage version: 2.2_rc3/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libicq2000/ChangeLog11
-rw-r--r--net-libs/libicq2000/files/libicq2000-0.3.2-gcc43.patch34
-rw-r--r--net-libs/libicq2000/libicq2000-0.3.1.ebuild30
-rw-r--r--net-libs/libicq2000/libicq2000-0.3.2.ebuild15
4 files changed, 50 insertions, 40 deletions
diff --git a/net-libs/libicq2000/ChangeLog b/net-libs/libicq2000/ChangeLog
index df793f77fa46..f40626e95b41 100644
--- a/net-libs/libicq2000/ChangeLog
+++ b/net-libs/libicq2000/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libicq2000
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libicq2000/ChangeLog,v 1.10 2007/02/22 01:30:40 peper Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libicq2000/ChangeLog,v 1.11 2008/07/27 10:11:05 loki_val Exp $
+
+ 27 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/libicq2000-0.3.2-gcc43.patch, -libicq2000-0.3.1.ebuild,
+ libicq2000-0.3.2.ebuild:
+ Fix bug #218774 by using --enable-debug, since otherwise your CFLAGS get
+ sedded to kill the make. Fix bug #225387 wrt gcc-4.3 compat. Thanks to
+ Marek Miller <mlm@ngc17.pl> for the patch. Drop old.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/net-libs/libicq2000/files/libicq2000-0.3.2-gcc43.patch b/net-libs/libicq2000/files/libicq2000-0.3.2-gcc43.patch
new file mode 100644
index 000000000000..12fa524192fc
--- /dev/null
+++ b/net-libs/libicq2000/files/libicq2000-0.3.2-gcc43.patch
@@ -0,0 +1,34 @@
+--- src/userinfohelpers.cpp~ 2007-04-02 11:01:38.000000000 +0000
++++ src/userinfohelpers.cpp 2007-04-02 11:01:45.000000000 +0000
+@@ -23,6 +23,8 @@
+
+ #include "sstream_fix.h"
+
++#include <cstdlib>
++
+ using std::vector;
+ using std::string;
+ using std::ostringstream;
+
+
+--- src/socket.cpp.orig 2008-06-08 17:55:26.000000000 +0200
++++ src/socket.cpp 2008-06-08 17:55:57.000000000 +0200
+@@ -19,6 +19,7 @@
+ *
+ */
+
++#include <cstring>
+ #include "sstream_fix.h"
+ #include <algorithm>
+
+
+--- src/Capabilities.cpp.orig 2008-06-08 18:04:34.000000000 +0200
++++ src/Capabilities.cpp 2008-06-08 18:05:15.000000000 +0200
+@@ -19,6 +19,7 @@
+ *
+ */
+
++#include <cstring>
+ #include <libicq2000/Capabilities.h>
+
+ using std::set;
diff --git a/net-libs/libicq2000/libicq2000-0.3.1.ebuild b/net-libs/libicq2000/libicq2000-0.3.1.ebuild
deleted file mode 100644
index ab251d170a24..000000000000
--- a/net-libs/libicq2000/libicq2000-0.3.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libicq2000/libicq2000-0.3.1.ebuild,v 1.10 2004/07/15 00:54:29 agriffis Exp $
-
-DESCRIPTION="ICQ 200x compatible ICQ libraries."
-SRC_URI="mirror://sourceforge/libicq2000/${P}.tar.gz"
-HOMEPAGE="http://ickle.sf.net"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="x86 sparc "
-IUSE=""
-
-DEPEND="=dev-libs/libsigc++-1.0*"
-
-src_compile() {
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --infodir=/usr/share/info \
- --localstatedir=/var/lib \
- --mandir=/usr/share/man || die "./configure failed"
- emake || die
-
-}
-
-src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
-}
diff --git a/net-libs/libicq2000/libicq2000-0.3.2.ebuild b/net-libs/libicq2000/libicq2000-0.3.2.ebuild
index 8e87122cacf1..e37e5a264451 100644
--- a/net-libs/libicq2000/libicq2000-0.3.2.ebuild
+++ b/net-libs/libicq2000/libicq2000-0.3.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libicq2000/libicq2000-0.3.2.ebuild,v 1.6 2004/07/15 00:54:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libicq2000/libicq2000-0.3.2.ebuild,v 1.7 2008/07/27 10:11:05 loki_val Exp $
+
+inherit base autotools
DESCRIPTION="ICQ 200x compatible ICQ libraries."
SRC_URI="mirror://sourceforge/libicq2000/${P}.tar.gz"
@@ -13,13 +15,10 @@ IUSE=""
DEPEND="=dev-libs/libsigc++-1.0*"
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+
src_compile() {
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --infodir=/usr/share/info \
- --localstatedir=/var/lib \
- --mandir=/usr/share/man || die "./configure failed"
+ econf --enable-debug || die "econf failed"
emake || die "emake failed"
}