summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-02 19:50:45 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-02 19:50:45 +0000
commit9abe79ebc5e861311320db910a9f6d13b1c6fc2b (patch)
tree2f6c6e09b4c7f5501826e9bc8c1f47b2eb0cec84 /net-libs
parentebuild cleanup (diff)
downloadgentoo-2-9abe79ebc5e861311320db910a9f6d13b1c6fc2b.tar.gz
gentoo-2-9abe79ebc5e861311320db910a9f6d13b1c6fc2b.tar.bz2
gentoo-2-9abe79ebc5e861311320db910a9f6d13b1c6fc2b.zip
Use static-libs use flag instead of static. Fixes bug #322493 thanks to Kacper Kowalik (Xarthisius)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-qt4/ChangeLog9
-rw-r--r--net-libs/telepathy-qt4/telepathy-qt4-0.3.4-r1.ebuild (renamed from net-libs/telepathy-qt4/telepathy-qt4-0.3.4.ebuild)13
2 files changed, 15 insertions, 7 deletions
diff --git a/net-libs/telepathy-qt4/ChangeLog b/net-libs/telepathy-qt4/ChangeLog
index c6b0e18d15a4..e6c8a8ebf213 100644
--- a/net-libs/telepathy-qt4/ChangeLog
+++ b/net-libs/telepathy-qt4/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/telepathy-qt4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/ChangeLog,v 1.1 2010/05/30 10:05:10 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/ChangeLog,v 1.2 2010/06/02 19:50:45 hwoarang Exp $
+
+*telepathy-qt4-0.3.4-r1 (02 Jun 2010)
+
+ 02 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ -telepathy-qt4-0.3.4.ebuild, +telepathy-qt4-0.3.4-r1.ebuild:
+ Use static-libs use flag instead of static. Fixes bug #322493 thanks to
+ Kacper Kowalik (Xarthisius)
*telepathy-qt4-0.3.4 (30 May 2010)
diff --git a/net-libs/telepathy-qt4/telepathy-qt4-0.3.4.ebuild b/net-libs/telepathy-qt4/telepathy-qt4-0.3.4-r1.ebuild
index b743c63d94a5..80dcc6dbb4c1 100644
--- a/net-libs/telepathy-qt4/telepathy-qt4-0.3.4.ebuild
+++ b/net-libs/telepathy-qt4/telepathy-qt4-0.3.4-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/telepathy-qt4-0.3.4.ebuild,v 1.1 2010/05/30 10:05:10 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/telepathy-qt4-0.3.4-r1.ebuild,v 1.1 2010/06/02 19:50:45 hwoarang Exp $
PYTHON_DEPEND="2"
EAPI="2"
-inherit versionator python base
+inherit base multilib python versionator
DESCRIPTION="Qt4 bindings for the Telepathy D-Bus protocol"
HOMEPAGE="http://telepathy.freedesktop.org/"
@@ -14,10 +14,11 @@ SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug static"
+IUSE="debug static-libs"
RDEPEND="x11-libs/qt-core:4
- x11-libs/qt-dbus:4"
+ x11-libs/qt-dbus:4
+ x11-libs/qt-test:4"
DEPEND="${RDEPEND}
dev-libs/libxslt
dev-util/pkgconfig
@@ -29,7 +30,7 @@ pkg_setup() {
}
src_configure() {
- econf $(use_enable debug) $(use_enable static)
+ econf $(use_enable debug) $(use_enable static-libs static)
}
src_test() {
@@ -38,5 +39,5 @@ src_test() {
src_install() {
base_src_install
- ! use static && rm "${D}"/usr/$(get_libdir)/lib${PN}.la
+ ! use static-libs && rm "${D}"/usr/$(get_libdir)/lib${PN}.la
}