summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-23 21:38:02 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-23 21:38:02 +0000
commit3592ae36ed2fde44505c27218515518809fc75e2 (patch)
treecacf94d110174830098816982f9d120cc887f41f /net-libs
parentamd64/x86 stable, bug #243132 (diff)
downloadgentoo-2-3592ae36ed2fde44505c27218515518809fc75e2.tar.gz
gentoo-2-3592ae36ed2fde44505c27218515518809fc75e2.tar.bz2
gentoo-2-3592ae36ed2fde44505c27218515518809fc75e2.zip
Bump to 2.24.1. Fix various nasty bugs.
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsoup/ChangeLog8
-rw-r--r--net-libs/libsoup/libsoup-2.24.1.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index c736e21a2c3c..d962f719994e 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libsoup
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.159 2008/09/30 06:43:23 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.160 2008/10/23 21:38:02 eva Exp $
+
+*libsoup-2.24.1 (23 Oct 2008)
+
+ 23 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +libsoup-2.24.1.ebuild:
+ Bump to 2.24.1. Fix various nasty bugs.
*libsoup-2.24.0.1 (30 Sep 2008)
diff --git a/net-libs/libsoup/libsoup-2.24.1.ebuild b/net-libs/libsoup/libsoup-2.24.1.ebuild
new file mode 100644
index 000000000000..7cd306ee26cc
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.24.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.24.1.ebuild,v 1.1 2008/10/23 21:38:02 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc ssl"
+
+RDEPEND=">=dev-libs/glib-2.15.3
+ >=dev-libs/libxml2-2
+ ssl? ( >=net-libs/gnutls-1 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ # Do NOT build with --disable-debug/--enable-debug=no
+ if use debug ; then
+ G2CONF="${G2CONF} --enable-debug=yes"
+ fi
+
+ G2CONF="${G2CONF} $(use_enable ssl)"
+}