summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2006-02-02 01:45:17 +0000
committerStefan Knoblich <stkn@gentoo.org>2006-02-02 01:45:17 +0000
commit9c7e973565fc87376100ab5e12e187818aed493c (patch)
treef85a2ffe0267a5539c89535d61fd1fd0f930f392 /net-libs/osptoolkit
parentclean out old files and uncompress stuff #120672 by Simon Stelling (diff)
downloadgentoo-2-9c7e973565fc87376100ab5e12e187818aed493c.tar.gz
gentoo-2-9c7e973565fc87376100ab5e12e187818aed493c.tar.bz2
gentoo-2-9c7e973565fc87376100ab5e12e187818aed493c.zip
Version bump.
(Portage version: 2.0.53)
Diffstat (limited to 'net-libs/osptoolkit')
-rw-r--r--net-libs/osptoolkit/ChangeLog9
-rw-r--r--net-libs/osptoolkit/Manifest6
-rw-r--r--net-libs/osptoolkit/files/digest-osptoolkit-3.3.41
-rw-r--r--net-libs/osptoolkit/osptoolkit-3.3.4.ebuild65
4 files changed, 77 insertions, 4 deletions
diff --git a/net-libs/osptoolkit/ChangeLog b/net-libs/osptoolkit/ChangeLog
index 388e0019c686..8d1dfb420a90 100644
--- a/net-libs/osptoolkit/ChangeLog
+++ b/net-libs/osptoolkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/osptoolkit
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/osptoolkit/ChangeLog,v 1.2 2005/08/28 20:19:52 stkn Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/osptoolkit/ChangeLog,v 1.3 2006/02/02 01:45:17 stkn Exp $
+
+*osptoolkit-3.3.4 (02 Feb 2006)
+
+ 02 Feb 2006; Stefan Knoblich <stkn@gentoo.org> +osptoolkit-3.3.4.ebuild:
+ Version bump.
28 Aug 2005; Stefan Knoblich <stkn@gentoo.org> osptoolkit-3.3.1.ebuild:
Added multilib support for amd64.
diff --git a/net-libs/osptoolkit/Manifest b/net-libs/osptoolkit/Manifest
index 5d8a9a201c33..0f63fcd44786 100644
--- a/net-libs/osptoolkit/Manifest
+++ b/net-libs/osptoolkit/Manifest
@@ -1,4 +1,6 @@
-MD5 138e65c1c5a4271d2732a841525b0149 osptoolkit-3.3.1.ebuild 1470
-MD5 44cf247f04cc83413fcb40ed59d0847a metadata.xml 248
MD5 66554f0f4bfa5c050d3eb480a826e218 ChangeLog 482
MD5 0e71c85746f397e8f45ea39c28533814 files/digest-osptoolkit-3.3.1 68
+MD5 555152f5492321083bfe8944797c1322 files/digest-osptoolkit-3.3.4 68
+MD5 44cf247f04cc83413fcb40ed59d0847a metadata.xml 248
+MD5 138e65c1c5a4271d2732a841525b0149 osptoolkit-3.3.1.ebuild 1470
+MD5 e89c64984467e00d8dcf685103be5435 osptoolkit-3.3.4.ebuild 1490
diff --git a/net-libs/osptoolkit/files/digest-osptoolkit-3.3.4 b/net-libs/osptoolkit/files/digest-osptoolkit-3.3.4
new file mode 100644
index 000000000000..37e849037094
--- /dev/null
+++ b/net-libs/osptoolkit/files/digest-osptoolkit-3.3.4
@@ -0,0 +1 @@
+MD5 beb85d6df71d83c6eb92b7317fccaa03 OSPToolkit-3.3.4.tar.gz 411548
diff --git a/net-libs/osptoolkit/osptoolkit-3.3.4.ebuild b/net-libs/osptoolkit/osptoolkit-3.3.4.ebuild
new file mode 100644
index 000000000000..e76dad81fa73
--- /dev/null
+++ b/net-libs/osptoolkit/osptoolkit-3.3.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/osptoolkit/osptoolkit-3.3.4.ebuild,v 1.1 2006/02/02 01:45:17 stkn Exp $
+
+DESCRIPTION="OSP (Open Settlement Protocol) library"
+HOMEPAGE="http://www.transnexus.com/"
+SRC_URI="http://www.transnexus.com/OSP%20Toolkit/Toolkits%20for%20Download/OSPToolkit-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+RDEPEND="virtual/libc
+ dev-libs/openssl"
+
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/TK-${PV//./_}-20051103
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ sed -i -e "s:\$(INSTALL_PATH)/lib:\$(INSTALL_PATH)/\$(LIBDIR):" \
+ src/Makefile
+}
+
+src_compile() {
+ cd ${S}/src
+ emake build || die "emake libosp failed"
+
+ cd ${S}/enroll
+ emake linux || die "emake enroll failed"
+
+ cd ${S}/test
+ emake linux || die "emake test failed"
+}
+
+src_install() {
+ dodir /usr/include /usr/$(get_libdir)
+
+ cd ${S}/src
+ make INSTALL_PATH=${D}/usr LIBDIR=$(get_libdir) \
+ install || die "make install failed"
+
+ sed -i -e "s:^\(OPENSSL_CONF\).*:\1=/etc/ssl/openssl.cnf:" \
+ -e "s:^\(RANDFILE\).*:\1=/etc/ssl/.rnd:" \
+ ${S}/bin/enroll.sh
+
+ dosbin ${S}/bin/enroll*
+ newbin ${S}/bin/test_app osp_test_app
+
+ cd ${S}
+ dodoc *.txt
+
+ insinto /usr/share/doc/${PF}
+ doins bin/test.cfg
+}
+
+pkg_postinst() {
+ einfo "The OSP test application is located in ${ROOT}usr/bin/osp_test_app"
+ einfo "See ${ROOT}usr/share/doc/${PF}/test.cfg for a sample test.cfg for osp_test_app"
+}