summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-01-04 02:40:15 +0000
committerTim Harder <radhermit@gentoo.org>2012-01-04 02:40:15 +0000
commit5782af25bc3bbc93781597cc54380eff828d9fa0 (patch)
tree74eac28c0a604999ad08297db8d175ccca252d58 /net-libs/libpcap
parentdev-vcs/svneverever: 1.2.1 (diff)
downloadgentoo-2-5782af25bc3bbc93781597cc54380eff828d9fa0.tar.gz
gentoo-2-5782af25bc3bbc93781597cc54380eff828d9fa0.tar.bz2
gentoo-2-5782af25bc3bbc93781597cc54380eff828d9fa0.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libpcap')
-rw-r--r--net-libs/libpcap/ChangeLog9
-rw-r--r--net-libs/libpcap/libpcap-1.2.1.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index cf3068d80f40..d2e8eeb69e2e 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libpcap
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.161 2011/12/17 12:32:14 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.162 2012/01/04 02:40:15 radhermit Exp $
+
+*libpcap-1.2.1 (04 Jan 2012)
+
+ 04 Jan 2012; Tim Harder <radhermit@gentoo.org> +libpcap-1.2.1.ebuild:
+ Version bump.
17 Dec 2011; Jeroen Roovers <jer@gentoo.org> libpcap-1.1.1-r1.ebuild:
Restore old version (bug #395033).
diff --git a/net-libs/libpcap/libpcap-1.2.1.ebuild b/net-libs/libpcap/libpcap-1.2.1.ebuild
new file mode 100644
index 000000000000..3b4cced5183f
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.2.1.ebuild,v 1.1 2012/01/04 02:40:15 radhermit Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth ipv6 libnl static-libs"
+
+RDEPEND="bluetooth? ( net-wireless/bluez )
+ libnl? ( dev-libs/libnl:1.1 )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+DOCS=( CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel} )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_with libnl) \
+ $(use_enable bluetooth)
+}
+
+src_compile() {
+ emake all shared
+}
+
+src_install() {
+ default
+
+ # remove static libraries (--disable-static does not work)
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -exec rm {} + || die
+ fi
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h
+ fi
+}