summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-09-16 17:03:24 +0000
committerJohannes Huber <johu@gentoo.org>2014-09-16 17:03:24 +0000
commit29231a2549b1d8e3c7717de7bb19b80fe2497494 (patch)
tree14993e82a221108daa23693a4511e0e2f90a54ad /net-libs/libkpeople
parentRestrict to <net-libs/telepathy-qt-0.9.5, bug #522928. (diff)
downloadgentoo-2-29231a2549b1d8e3c7717de7bb19b80fe2497494.tar.gz
gentoo-2-29231a2549b1d8e3c7717de7bb19b80fe2497494.tar.bz2
gentoo-2-29231a2549b1d8e3c7717de7bb19b80fe2497494.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'net-libs/libkpeople')
-rw-r--r--net-libs/libkpeople/ChangeLog7
-rw-r--r--net-libs/libkpeople/libkpeople-0.3.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-libs/libkpeople/ChangeLog b/net-libs/libkpeople/ChangeLog
index ea4697e08f62..7f6cf8bc7843 100644
--- a/net-libs/libkpeople/ChangeLog
+++ b/net-libs/libkpeople/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libkpeople
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/ChangeLog,v 1.7 2014/04/26 11:09:01 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/ChangeLog,v 1.8 2014/09/16 17:03:24 johu Exp $
+
+*libkpeople-0.3.0 (16 Sep 2014)
+
+ 16 Sep 2014; Johannes Huber <johu@gentoo.org> +libkpeople-0.3.0.ebuild:
+ Version bump.
26 Apr 2014; Johannes Huber <johu@gentoo.org> -libkpeople-0.1.0.ebuild,
-libkpeople-0.2.1.ebuild:
diff --git a/net-libs/libkpeople/libkpeople-0.3.0.ebuild b/net-libs/libkpeople/libkpeople-0.3.0.ebuild
new file mode 100644
index 000000000000..3193635b9f8b
--- /dev/null
+++ b/net-libs/libkpeople/libkpeople-0.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/libkpeople-0.3.0.ebuild,v 1.1 2014/09/16 17:03:24 johu Exp $
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+KDE_LINGUAS="bs cs da de el fi fr hu ja lt nl pl pt pt_BR ro ru sk sl sv uk"
+inherit kde4-base
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+else
+ KEYWORDS=""
+fi
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://projects.kde.org/projects/playground/network/libkpeople"
+
+LICENSE="LGPL-2.1"
+SLOT="4/4"
+IUSE="debug examples semantic-desktop test"
+
+RDEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ semantic-desktop? ( $(add_kdebase_dep baloo) )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with examples)
+ $(cmake-utils_use_find_package semantic-desktop Baloo)
+ )
+
+ kde4-base_src_configure
+}