summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-08-10 16:35:18 +0000
committerChris Reffett <creffett@gentoo.org>2012-08-10 16:35:18 +0000
commit303398b21e1c6912409a2add72d60935f095df5a (patch)
treec6c62e828fa076773c0aefac97af0748c005f5d2 /net-libs/libkolabxml
parentBump to 0.8.8, bug 429988. Thanks to Pinkbyte (diff)
downloadgentoo-2-303398b21e1c6912409a2add72d60935f095df5a.tar.gz
gentoo-2-303398b21e1c6912409a2add72d60935f095df5a.tar.bz2
gentoo-2-303398b21e1c6912409a2add72d60935f095df5a.zip
Increase swig dependency to 2.0.7 wrt bug 430314, thanks to alexander haensch <alexander.haensch@gmail.com> for the catch. Add language dependencies. Add version bump to 0.8.0.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libkolabxml')
-rw-r--r--net-libs/libkolabxml/ChangeLog11
-rw-r--r--net-libs/libkolabxml/libkolabxml-0.6.0.ebuild10
-rw-r--r--net-libs/libkolabxml/libkolabxml-0.8.0.ebuild41
3 files changed, 55 insertions, 7 deletions
diff --git a/net-libs/libkolabxml/ChangeLog b/net-libs/libkolabxml/ChangeLog
index b20f9ad46147..0a5f0e1dbb78 100644
--- a/net-libs/libkolabxml/ChangeLog
+++ b/net-libs/libkolabxml/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for net-libs/libkolabxml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/ChangeLog,v 1.1 2012/08/01 20:00:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/ChangeLog,v 1.2 2012/08/10 16:35:18 creffett Exp $
+
+*libkolabxml-0.8.0 (10 Aug 2012)
+
+ 10 Aug 2012; Chris Reffett <creffett@gentoo.org> +libkolabxml-0.8.0.ebuild,
+ libkolabxml-0.6.0.ebuild:
+ Increase swig dependency to 2.0.7 wrt bug 430314, thanks to alexander haensch
+ <alexander.haensch@gmail.com> for the catch. Add language dependencies. Add
+ version bump to 0.8.0.
*libkolabxml-0.6.0 (01 Aug 2012)
01 Aug 2012; Johannes Huber <johu@gentoo.org> +libkolabxml-0.6.0.ebuild,
+metadata.xml:
Initial commit. Import from kde overlay. Needed for KDE SC 4.9.0.
-
diff --git a/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild b/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild
index 8dbfa9627fde..f46d936b50ec 100644
--- a/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild
+++ b/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild,v 1.1 2012/08/01 20:00:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/libkolabxml-0.6.0.ebuild,v 1.2 2012/08/10 16:35:18 creffett Exp $
EAPI=4
@@ -22,10 +22,10 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- csharp? ( dev-lang/swig )
- java? ( dev-lang/swig )
- php? ( dev-lang/swig )
- python? ( dev-lang/swig )
+ csharp? ( >=dev-lang/swig-2.0.7 dev-lang/mono )
+ java? ( >=dev-lang/swig-2.0.7 virtual/jre )
+ php? ( >=dev-lang/swig-2.0.7 dev-lang/php )
+ python? ( >=dev-lang/swig-2.0.7 dev-lang/python )
test? ( x11-libs/qt-test:4 )
"
diff --git a/net-libs/libkolabxml/libkolabxml-0.8.0.ebuild b/net-libs/libkolabxml/libkolabxml-0.8.0.ebuild
new file mode 100644
index 000000000000..cb0942e14898
--- /dev/null
+++ b/net-libs/libkolabxml/libkolabxml-0.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/libkolabxml-0.8.0.ebuild,v 1.1 2012/08/10 16:35:18 creffett Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Kolab XML format schema definitions library"
+HOMEPAGE="http://www.kolab.org"
+SRC_URI="http://dev.gentoo.org/~creffett/distfiles/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="csharp java python php test"
+
+RDEPEND="
+ dev-cpp/xsd
+ || ( >=dev-libs/boost-1.42.0 ( <dev-libs/boost-1.42.0 dev-libs/ossp-uuid ) )
+ dev-libs/xerces-c
+"
+DEPEND="
+ ${RDEPEND}
+ csharp? ( >=dev-lang/swig-2.0.7 dev-lang/mono )
+ java? ( >=dev-lang/swig-2.0.7 virtual/jre )
+ php? ( >=dev-lang/swig-2.0.7 dev-lang/php )
+ python? ( >=dev-lang/swig-2.0.7 dev-lang/python )
+ test? ( x11-libs/qt-test:4 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use csharp CSHARP_BINDINGS)
+ $(cmake-utils_use java JAVA_BINDINGS)
+ $(cmake-utils_use python PYTHON_BINDINGS)
+ $(cmake-utils_use php PHP_BINDINGS)
+ $(cmake-utils_use_build test TESTS)
+ )
+ cmake-utils_src_configure
+}