summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-18 20:07:46 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-18 20:07:46 +0000
commitb70ff9769db365064f37ced1c73d691e8ecb4468 (patch)
treed024c7cda682b6b96654fb655e41914754149f9d /net-libs/lcrzo
parentchangelog (diff)
downloadgentoo-2-b70ff9769db365064f37ced1c73d691e8ecb4468.tar.gz
gentoo-2-b70ff9769db365064f37ced1c73d691e8ecb4468.tar.bz2
gentoo-2-b70ff9769db365064f37ced1c73d691e8ecb4468.zip
lcrzo 4.04
Diffstat (limited to 'net-libs/lcrzo')
-rw-r--r--net-libs/lcrzo/ChangeLog11
-rw-r--r--net-libs/lcrzo/files/digest-lcrzo-4.041
-rw-r--r--net-libs/lcrzo/lcrzo-4.04.ebuild49
3 files changed, 60 insertions, 1 deletions
diff --git a/net-libs/lcrzo/ChangeLog b/net-libs/lcrzo/ChangeLog
index 499a83146c31..df9da9c83af7 100644
--- a/net-libs/lcrzo/ChangeLog
+++ b/net-libs/lcrzo/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/lcrzo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/ChangeLog,v 1.1 2002/02/01 21:53:34 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/ChangeLog,v 1.2 2002/02/18 20:07:46 karltk Exp $
+
+*lcrzo-4.04 (18 Feb 2002)
+
+ 18 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> ChangeLog files/digest-lcrzo-4.04 lcrzo-4.04.ebuild:
+
+ Lcrzo is a network library for network administrators and network hackers.
+ It is designed to make it easy to create network programs. It supports
+ spoofing, sniffing, and client/server creation. This library has been
+ successfully installed under Linux, Windows, FreeBSD, OpenBSD, and Solaris.
*lcrzo-4.03 (1 Feb 2002)
diff --git a/net-libs/lcrzo/files/digest-lcrzo-4.04 b/net-libs/lcrzo/files/digest-lcrzo-4.04
new file mode 100644
index 000000000000..a083f4a53216
--- /dev/null
+++ b/net-libs/lcrzo/files/digest-lcrzo-4.04
@@ -0,0 +1 @@
+MD5 bc0b5eb597af2337f58d5a7b5762528d lcrzo-4.04-src.tgz 635245
diff --git a/net-libs/lcrzo/lcrzo-4.04.ebuild b/net-libs/lcrzo/lcrzo-4.04.ebuild
new file mode 100644
index 000000000000..e65136f94881
--- /dev/null
+++ b/net-libs/lcrzo/lcrzo-4.04.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/lcrzo-4.04.ebuild,v 1.1 2002/02/18 20:07:46 karltk Exp $
+
+DESCRIPTION="Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols"
+HOMEPAGE="http://www.laurentconstantin.com/en/lcrzo/"
+SRC_URI="http://www.laurentconstantin.com/common/${PN}/download/v4/${P}-src.tgz"
+S=${WORKDIR}/${P}-src
+
+DEPEND="virtual/glibc net-libs/libpcap"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}/src
+
+ # genemake checks that these directories exist...
+ mv genemake genemake.orig
+ sed -e "s:/usr/local/include:/usr/include:" \
+ -e "s:/usr/local/lib:/usr/lib:" \
+ -e "s:/usr/local/bin:/usr/bin:" \
+ -e "s:/usr/local/man/man1:/usr/share/man/man1:" \
+ -e "s:/usr/local/man/man3:/usr/share/man/man3:" \
+ genemake.orig > genemake
+
+ chmod 755 genemake
+ ./genemake || die "problem creating Makefile"
+
+ # plug in our CFLAGS and make it install into ${D}...
+ mv Makefile Makefile.orig
+ sed -e "s:^GCCOPT=.*:GCCOPT=${CFLAGS}:" \
+ -e "s:^GCCOPTL=.*:GCCOPTL=${CFLAGS}:" \
+ -e "s:^GCCOPTP=.*:GCCOPTP=${CFLAGS}:" \
+ -e "s:^INSTINCLUDE=:INSTINCLUDE=${D}:" \
+ -e "s:^INSTLIB=:INSTLIB=${D}:" \
+ -e "s:^INSTBIN=:INSTBIN=${D}:" \
+ -e "s:^INSTMAN1=:INSTMAN1=${D}:" \
+ -e "s:^INSTMAN3=:INSTMAN3=${D}:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+ make -C src || die "compile problem :("
+}
+
+src_install() {
+ dodir /usr/{bin,include,lib} /usr/share/man/{man1,man3}
+ make -C src install || die
+ dodoc doc/*.txt
+}