summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-11-16 21:50:37 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-11-16 21:50:37 +0000
commit78de9b9fda74bd1d51932ed8ae2fe20f7818ba12 (patch)
treebc1e0f357b99419cce55143c448ea7ad39384f97 /net-libs/gtk-vnc
parentversion bump, bug #345275 (diff)
downloadgentoo-2-78de9b9fda74bd1d51932ed8ae2fe20f7818ba12.tar.gz
gentoo-2-78de9b9fda74bd1d51932ed8ae2fe20f7818ba12.tar.bz2
gentoo-2-78de9b9fda74bd1d51932ed8ae2fe20f7818ba12.zip
Version bump. Fix configure with python:3. Add introspection support.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/ChangeLog8
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.4.2.ebuild57
-rw-r--r--net-libs/gtk-vnc/metadata.xml6
3 files changed, 69 insertions, 2 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index 9f62c448b9ab..f4a19bfc330d 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.52 2010/10/13 21:22:02 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.53 2010/11/16 21:50:37 eva Exp $
+
+*gtk-vnc-0.4.2 (16 Nov 2010)
+
+ 16 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org> +gtk-vnc-0.4.2.ebuild,
+ metadata.xml:
+ Version bump. Fix configure with python:3. Add introspection support.
*gtk-vnc-0.4.2_pre20100917 (13 Oct 2010)
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.4.2.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.4.2.ebuild
new file mode 100644
index 000000000000..4b29ebb827f6
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-0.4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.4.2.ebuild,v 1.1 2010/11/16 21:50:37 eva Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit base gnome.org python
+
+DESCRIPTION="VNC viewer widget for GTK."
+HOMEPAGE="http://live.gnome.org/gtk-vnc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples +introspection python sasl"
+
+# libview is used in examples/gvncviewer -- no need
+# TODO: review nsplugin when it will be considered less experimental
+
+RDEPEND=">=dev-libs/glib-2.10:2
+ >=net-libs/gnutls-1.4
+ >=x11-libs/cairo-1.2
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ introspection? ( >=dev-libs/gobject-introspection-0.9.4 )
+ python? ( >=dev-python/pygtk-2:2 )
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ $(use_with examples) \
+ $(use_enable introspection) \
+ $(use_with python) \
+ $(use_with sasl) \
+ --with-coroutine=gthread \
+ --without-libview \
+ --with-gtk=2.0 \
+ --disable-static
+}
+
+src_install() {
+ # bug #328273
+ MAKEOPTS="${MAKEOPTS} -j1" \
+ base_src_install
+ python_clean_installation_image
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
diff --git a/net-libs/gtk-vnc/metadata.xml b/net-libs/gtk-vnc/metadata.xml
index dad9001338dc..0b6b5da045eb 100644
--- a/net-libs/gtk-vnc/metadata.xml
+++ b/net-libs/gtk-vnc/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>gnome</herd>
+<herd>gnome</herd>
+<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+</use>
</pkgmetadata>