summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-07-19 15:33:23 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-07-19 15:33:23 +0000
commite83f9125ebd340b6d507026e1fb516d160ed6d6f (patch)
tree91c47ecf6fdd19b51890b7006bff4effc2890170 /net-libs/gnutls/gnutls-1.6.3.ebuild
parentFix pkgconfig installation location from datadir to libdir. (diff)
downloadgentoo-2-e83f9125ebd340b6d507026e1fb516d160ed6d6f.tar.gz
gentoo-2-e83f9125ebd340b6d507026e1fb516d160ed6d6f.tar.bz2
gentoo-2-e83f9125ebd340b6d507026e1fb516d160ed6d6f.zip
Version bump, bug#185700
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-libs/gnutls/gnutls-1.6.3.ebuild')
-rw-r--r--net-libs/gnutls/gnutls-1.6.3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/gnutls/gnutls-1.6.3.ebuild b/net-libs/gnutls/gnutls-1.6.3.ebuild
new file mode 100644
index 000000000000..e099b2ffad47
--- /dev/null
+++ b/net-libs/gnutls/gnutls-1.6.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-1.6.3.ebuild,v 1.1 2007/07/19 15:33:23 alonbl Exp $
+
+DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="http://josefsson.org/gnutls/releases/${P}.tar.bz2"
+
+# GPL-2 for the gnutls-extras library and LGPL for the gnutls library.
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="zlib doc nls"
+
+RDEPEND=">=dev-libs/libgcrypt-1.2.2
+ >=app-crypt/opencdk-0.5.5
+ zlib? ( >=sys-libs/zlib-1.1 )
+ virtual/libc
+ >=dev-libs/lzo-2
+ dev-libs/libgpg-error
+ >=dev-libs/libtasn1-0.3.4
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )"
+#>=sys-devel/gettext-0.14.5" autoconf indicates this version but it works
+# without it
+
+src_compile() {
+ local myconf=""
+
+ econf \
+ $(use_with zlib) \
+ $(use_enable nls) \
+ --without-included-minilzo \
+ --without-included-opencdk \
+ $(use_enable doc gtk-doc) \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS \
+ README THANKS doc/TODO
+
+ if use doc ; then
+ dodoc doc/README.autoconf doc/tex/gnutls.ps
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}