summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-11-30 20:24:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-11-30 20:24:11 +0000
commite2938ef710a28a2821707c5492ac74f17c7a6553 (patch)
treedfbaf0ab2785fdf7e32f66f20caf96bf82961e01 /net-irc
parentAdded new version and removed old version. Fixed website according to bug #28... (diff)
downloadgentoo-2-e2938ef710a28a2821707c5492ac74f17c7a6553.tar.gz
gentoo-2-e2938ef710a28a2821707c5492ac74f17c7a6553.tar.bz2
gentoo-2-e2938ef710a28a2821707c5492ac74f17c7a6553.zip
Fix patch to support multilib and mark it stable for amd64 wrt #286873.
(Portage version: 2.2_rc54/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/cwirc/ChangeLog6
-rw-r--r--net-irc/cwirc/cwirc-2.0.0.ebuild20
-rw-r--r--net-irc/cwirc/files/cwirc-1.7.1-gentoo.patch18
3 files changed, 25 insertions, 19 deletions
diff --git a/net-irc/cwirc/ChangeLog b/net-irc/cwirc/ChangeLog
index e4163bc27bb3..4deadce967a8 100644
--- a/net-irc/cwirc/ChangeLog
+++ b/net-irc/cwirc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/cwirc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/cwirc/ChangeLog,v 1.23 2009/04/30 21:17:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/cwirc/ChangeLog,v 1.24 2009/11/30 20:24:11 ssuominen Exp $
+
+ 30 Nov 2009; Samuli Suominen <ssuominen@gentoo.org>
+ files/cwirc-1.7.1-gentoo.patch, cwirc-2.0.0.ebuild:
+ Fix patch to support multilib and mark it stable for amd64 wrt #286873.
30 Apr 2009; Patrick Lauer <patrick@gentoo.org> cwirc-2.0.0.ebuild:
Homepage and src_uri fix for #267950, additional ~amd64 keyword for extra
diff --git a/net-irc/cwirc/cwirc-2.0.0.ebuild b/net-irc/cwirc/cwirc-2.0.0.ebuild
index c002719211b9..50dd44257e4f 100644
--- a/net-irc/cwirc/cwirc-2.0.0.ebuild
+++ b/net-irc/cwirc/cwirc-2.0.0.ebuild
@@ -1,36 +1,34 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/cwirc/cwirc-2.0.0.ebuild,v 1.4 2009/04/30 21:17:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/cwirc/cwirc-2.0.0.ebuild,v 1.5 2009/11/30 20:24:11 ssuominen Exp $
-inherit eutils toolchain-funcs
+EAPI=2
+inherit eutils multilib toolchain-funcs
DESCRIPTION="An X-chat plugin for sending and receiving raw morse code over IRC"
HOMEPAGE="http://myspace.voo.be/pcoupard/cwirc/"
SRC_URI="http://myspace.voo.be/pcoupard/cwirc/download/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE=""
-RDEPEND="x11-libs/gtk+
+RDEPEND="x11-libs/gtk+:2
>=net-irc/xchat-2.0.1"
-
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/cwirc-1.7.1-gentoo.patch
}
src_compile() {
- emake STRIP="true" CC="$(tc-getCC)" CFLAGS="${CFLAGS} -DLINUX" || die "emake failed"
+ emake STRIP="true" CC="$(tc-getCC)" CFLAGS="${CFLAGS} -DLINUX" || die
}
src_install() {
- make install || die "make install failed"
+ emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || die
dodoc README RELEASE_NOTES Changelog
docinto schematics
diff --git a/net-irc/cwirc/files/cwirc-1.7.1-gentoo.patch b/net-irc/cwirc/files/cwirc-1.7.1-gentoo.patch
index 8f578004e067..84db7cac5bff 100644
--- a/net-irc/cwirc/files/cwirc-1.7.1-gentoo.patch
+++ b/net-irc/cwirc/files/cwirc-1.7.1-gentoo.patch
@@ -1,7 +1,8 @@
-diff -Naur cwirc-1.7.1-orig/Makefile cwirc-1.7.1/Makefile
---- cwirc-1.7.1-orig/Makefile 2003-11-10 03:20:07.000000000 +0100
-+++ cwirc-1.7.1/Makefile 2003-11-23 19:42:52.000000000 +0100
-@@ -22,10 +22,10 @@
+GNU DESTDIR and multilib directory support
+
+--- Makefile
++++ Makefile
+@@ -22,10 +22,13 @@
#EXTRA_LDFLAGS=
# Use these with Debian GNU/Linux for example
@@ -10,9 +11,12 @@ diff -Naur cwirc-1.7.1-orig/Makefile cwirc-1.7.1/Makefile
-#FRONTEND_INSTALL_DIRECTORY=/usr/bin
-#CWIRC_EXTENSIONS_DIRECTORY=/usr/lib/cwirc/extensions
+TARGET_OS=LINUX
-+PLUGIN_INSTALL_DIRECTORY=${D}/usr/lib/xchat/plugins
-+FRONTEND_INSTALL_DIRECTORY=${D}/usr/bin
-+CWIRC_EXTENSIONS_DIRECTORY=${D}/usr/lib/cwirc/extensions
++DESTDIR=
++PREFIX=/usr
++LIBDIR=$(PREFIX)/lib
++PLUGIN_INSTALL_DIRECTORY=$(DESTDIR)$(LIBDIR)/xchat/plugins
++FRONTEND_INSTALL_DIRECTORY=$(DESTDIR)$(PREFIX)/bin
++CWIRC_EXTENSIONS_DIRECTORY=$(DESTDIR)$(LIBDIR)/cwirc/extensions
#EXTRA_LDFLAGS=
# Use these with FreeBSD 5.1 for example