summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-11-19 18:39:13 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-11-19 18:39:13 +0000
commitcb07a1a634b612da1dc57bc919ec84ba9524cce9 (patch)
treeea00f43968ab4f0eeb6d5f96e889ab8dd4c60033 /net-irc
parentfixed my fix (diff)
downloadgentoo-2-cb07a1a634b612da1dc57bc919ec84ba9524cce9.tar.gz
gentoo-2-cb07a1a634b612da1dc57bc919ec84ba9524cce9.tar.bz2
gentoo-2-cb07a1a634b612da1dc57bc919ec84ba9524cce9.zip
new version
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi/ChangeLog8
-rw-r--r--net-irc/irssi/files/digest-irssi-0.8.61
-rw-r--r--net-irc/irssi/irssi-0.8.6.ebuild78
3 files changed, 85 insertions, 2 deletions
diff --git a/net-irc/irssi/ChangeLog b/net-irc/irssi/ChangeLog
index b40bbbcb2bc6..ef69c270aee5 100644
--- a/net-irc/irssi/ChangeLog
+++ b/net-irc/irssi/ChangeLog
@@ -1,8 +1,10 @@
# ChangeLog for homeblutgensgentoo-x86net-ircirssiChangeLog/
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.10 2002/10/20 19:29:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.11 2002/11/19 18:39:13 blizzy Exp $
-*irssi-0.8.5-r2 (12 Sep 2002)
+*irssi-0.8.6 (19 Nov 2002)
+
+ 19 Nov 2002; Maik Schreiber <blizzy@gentoo.org> : New version.
20 Oct 2002; Mike Frysinger <vapier@gentoo.org> irssi-0.8.5-r2.ebuild :
Added 'prepalldocs' to src_install since `make install` was putting them there
@@ -13,6 +15,8 @@
13 Sep 2002; Michael Cummings <mcummings@gentoo.org>: Corrected perl
syntax to use perl eclass for perl Makefile.PL actions, bug 7868.
+*irssi-0.8.5-r2 (12 Sep 2002)
+
12 Sep 2002; Daniel Robbins <drobbins@gentoo.org>: new rev bump with
configuration flag fixes: several use/configure combos were toggled, the
ebuild had "--enable-perl" instead of "--with-perl", etc. Lamer's socks
diff --git a/net-irc/irssi/files/digest-irssi-0.8.6 b/net-irc/irssi/files/digest-irssi-0.8.6
new file mode 100644
index 000000000000..0ecb65f16bf8
--- /dev/null
+++ b/net-irc/irssi/files/digest-irssi-0.8.6
@@ -0,0 +1 @@
+MD5 6d66982723e2eb8780ae3b8b3a7ba08d irssi-0.8.6.tar.bz2 746551
diff --git a/net-irc/irssi/irssi-0.8.6.ebuild b/net-irc/irssi/irssi-0.8.6.ebuild
new file mode 100644
index 000000000000..e051e540deb9
--- /dev/null
+++ b/net-irc/irssi/irssi-0.8.6.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.6.ebuild,v 1.1 2002/11/19 18:39:13 blizzy Exp $
+
+IUSE="nls ipv6 perl"
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A modular textUI IRC client with IPv6 support."
+SRC_URI="http://irssi.org/files/${P}.tar.bz2"
+HOMEPAGE="http://irssi.org/"
+
+DEPEND="=dev-libs/glib-1.2*
+ sys-libs/ncurses
+ perl? ( sys-devel/perl )"
+ #socks? ( >=net-misc/dante-1.1.13 )
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+src_compile() {
+ # Note: there is an option to build a GUI for irssi, but according
+ # to the website the GUI is no longer developed, so that option is
+ # not used here.
+
+ # Edit these if you like
+ myconf="--without-servertest --with-bot --with-proxy --with-ncurses"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ #perl is auto-detected and must be explicitly disabled
+ use perl || myconf="${myconf} --with-perl=no"
+
+ #ipv6 needs to be explicitly enabled
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ #socks needs to be explicitly enabled
+ #use socks && myconf="${myconf} --with-socks"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ myflags=""
+
+ use perl && ( \
+ cd ${S}/src/perl/common
+ perl-module_src_prep
+ cd ${S}/src/perl/irc
+ perl-module_src_prep
+ cd ${S}/src/perl/textui
+ perl-module_src_prep
+ cd ${S}/src/perl/ui
+ perl-module_src_prep
+ cd ${S}
+ )
+
+ make DESTDIR=${D} \
+ PREFIX=${D}/usr \
+ docdir=/usr/share/doc/${PF} \
+ gnulocaledir=${D}/usr/share/locale \
+ ${myflags} \
+ install || die
+
+ prepalldocs
+ dodoc AUTHORS ChangeLog README TODO NEWS
+}