summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-09-05 11:45:25 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-09-05 11:45:25 +0000
commitafabf9b684b7cf284502d1d268e7c2d1c50ab86d (patch)
tree6b7e86392c9401cf75ac9b56aff51c6664dd476f /net-irc
parentVersion bump. (diff)
downloadgentoo-2-afabf9b684b7cf284502d1d268e7c2d1c50ab86d.tar.gz
gentoo-2-afabf9b684b7cf284502d1d268e7c2d1c50ab86d.tar.bz2
gentoo-2-afabf9b684b7cf284502d1d268e7c2d1c50ab86d.zip
2.6 kernels report L2 cache information for Alphas, actually use it as suggested by Thomas Cort <tcort@gentoo.org> in bug #137217.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat-xsys/ChangeLog9
-rw-r--r--net-irc/xchat-xsys/files/2.1.0-alpha-L2-cache.patch10
-rw-r--r--net-irc/xchat-xsys/files/digest-xchat-xsys-2.1.0-r13
-rw-r--r--net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild53
4 files changed, 74 insertions, 1 deletions
diff --git a/net-irc/xchat-xsys/ChangeLog b/net-irc/xchat-xsys/ChangeLog
index 2614f3780677..4bc0458700c9 100644
--- a/net-irc/xchat-xsys/ChangeLog
+++ b/net-irc/xchat-xsys/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/xchat-xsys
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/ChangeLog,v 1.45 2006/07/04 16:49:34 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/ChangeLog,v 1.46 2006/09/05 11:45:25 chainsaw Exp $
+
+*xchat-xsys-2.1.0-r1 (05 Sep 2006)
+
+ 05 Sep 2006; Tony Vroon <chainsaw@gentoo.org>
+ +files/2.1.0-alpha-L2-cache.patch, +xchat-xsys-2.1.0-r1.ebuild:
+ 2.6 kernels report L2 cache information for Alphas, actually use it as
+ suggested by Thomas Cort <tcort@gentoo.org> in bug #137217.
04 Jul 2006; Gustavo Zacarias <gustavoz@gentoo.org>
xchat-xsys-2.0.9.ebuild:
diff --git a/net-irc/xchat-xsys/files/2.1.0-alpha-L2-cache.patch b/net-irc/xchat-xsys/files/2.1.0-alpha-L2-cache.patch
new file mode 100644
index 000000000000..667931938f6b
--- /dev/null
+++ b/net-irc/xchat-xsys/files/2.1.0-alpha-L2-cache.patch
@@ -0,0 +1,10 @@
+--- parse.c.orig 2006-09-05 12:35:52.000000000 +0100
++++ parse.c 2006-09-05 12:38:24.000000000 +0100
+@@ -81,6 +81,7 @@
+ find_match_char(buffer, "cpu model", model);
+ find_match_char(buffer, "system type", vendor);
+ find_match_double(buffer, "cycle frequency [Hz]", freq);
++ find_match_char(buffer, "L2 cache", cache);
+ find_match_int(buffer, "cpus detected", count);
+ }
+ *freq = *freq / 1000000;
diff --git a/net-irc/xchat-xsys/files/digest-xchat-xsys-2.1.0-r1 b/net-irc/xchat-xsys/files/digest-xchat-xsys-2.1.0-r1
new file mode 100644
index 000000000000..a8764842ccab
--- /dev/null
+++ b/net-irc/xchat-xsys/files/digest-xchat-xsys-2.1.0-r1
@@ -0,0 +1,3 @@
+MD5 fd4d97152422341b5ce81469481d10a8 xsys-2.1.0.tar.bz2 16499
+RMD160 cca47892379b0022d306370a93e35b0a0c8dfbd8 xsys-2.1.0.tar.bz2 16499
+SHA256 d91b302bdf9583cc769c664d98a28f76d8d34d635a0446a14833ad4f5b6ef61d xsys-2.1.0.tar.bz2 16499
diff --git a/net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild b/net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..4a4844e5e0db
--- /dev/null
+++ b/net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild,v 1.1 2006/09/05 11:45:25 chainsaw Exp $
+
+inherit toolchain-funcs eutils
+
+MY_P="${P/xchat-/}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Sysinfo plugin for X-Chat."
+SRC_URI="http://dev.gentoo.org/~chainsaw/xsys/download/${MY_P}.tar.bz2 mirror://gentoo/${MY_P}.tar.bz2"
+HOMEPAGE="http://dev.gentoo.org/~chainsaw/xsys/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="audacious buttons xmms"
+
+DEPEND="|| (
+ >=net-irc/xchat-2.4.0
+ >=net-irc/xchat-gnome-0.4
+ )
+ sys-apps/pciutils
+ audacious? ( media-sound/audacious )
+ xmms? ( media-sound/xmms )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:-O2 -Wall:${CFLAGS} -Wall:" Makefile
+ if use buttons; then
+ sed -i -e "s:#BUTTON:BUTTON:" Makefile
+ fi
+ if use audacious; then
+ sed -i -e "s:# FOR AUDACIOUS # ::g" Makefile
+ elif use xmms; then
+ sed -i -e "s:# FOR XMMS # ::g" Makefile
+ fi
+ epatch ${FILESDIR}/${PV}-alpha-L2-cache.patch
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" || die "Compile failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/xchat/plugins
+ doexe xsys-${PV}.so || die "doexe failed"
+
+ exeinto /usr/$(get_libdir)/xchat-gnome/plugins
+ doexe xsys-${PV}.so || die "doexe failed"
+
+ dodoc ChangeLog README || die "dodoc failed"
+}