summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-12-31 22:46:14 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-12-31 22:46:14 +0000
commita89231c298fffca78d1214d656deb55dc28a436c (patch)
treea91ee723496f1499f19f8e14d20c3aa9a1485501 /net-irc
parentStable for x86, wrt bug #449430 (diff)
downloadgentoo-2-a89231c298fffca78d1214d656deb55dc28a436c.tar.gz
gentoo-2-a89231c298fffca78d1214d656deb55dc28a436c.tar.bz2
gentoo-2-a89231c298fffca78d1214d656deb55dc28a436c.zip
Version bump due to security advisory ASA-2012-12-31
(Portage version: 2.2.0_alpha149/cvs/Linux i686, signed Manifest commit with key 23E9E900)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/shadowircd/ChangeLog8
-rw-r--r--net-irc/shadowircd/shadowircd-6.3.3.ebuild92
2 files changed, 98 insertions, 2 deletions
diff --git a/net-irc/shadowircd/ChangeLog b/net-irc/shadowircd/ChangeLog
index f6c77a8b8266..7cbc2003a57c 100644
--- a/net-irc/shadowircd/ChangeLog
+++ b/net-irc/shadowircd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/shadowircd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/shadowircd/ChangeLog,v 1.6 2012/04/05 20:37:32 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/shadowircd/ChangeLog,v 1.7 2012/12/31 22:46:14 jdhore Exp $
+
+*shadowircd-6.3.3 (31 Dec 2012)
+
+ 31 Dec 2012; Jeff Horelick <jdhore@gentoo.org> +shadowircd-6.3.3.ebuild:
+ Version bump due to security advisory ASA-2012-12-31
05 Apr 2012; Jeff Horelick <jdhore@gentoo.org> shadowircd-6.3.2.1.ebuild:
marked x86 per bug 410849
@@ -24,4 +29,3 @@
+files/shadowircd.initd, +metadata.xml, +shadowircd-6.3.2.1.ebuild:
Add net-irc/shadowircd-6.3.2.1, an IRCd based on charybdis, but adds several
useful features.
-
diff --git a/net-irc/shadowircd/shadowircd-6.3.3.ebuild b/net-irc/shadowircd/shadowircd-6.3.3.ebuild
new file mode 100644
index 000000000000..28cce0fc4ebf
--- /dev/null
+++ b/net-irc/shadowircd/shadowircd-6.3.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/shadowircd/shadowircd-6.3.3.ebuild,v 1.1 2012/12/31 22:46:14 jdhore Exp $
+
+EAPI=4
+
+inherit eutils multilib user
+
+DESCRIPTION="An IRCd based on charybdis that adds several useful features"
+HOMEPAGE="http://shadowircd.net"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +ipv6 largenet ssl zlib"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+S="${WORKDIR}/${PN}-${P}"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 "${EPREFIX}"/usr ${PN}
+}
+
+src_prepare() {
+ # Fill the example configuration file with proper paths.
+ sed -i \
+ -e "s:path =.*modules:path = \"$(get_libdir)/${PN}/modules:g" \
+ -e "s:etc/:../etc/${PN}/:g" \
+ -e "s:logs/:../var/log/shadowircd/:g" \
+ -e "s:test\.\(cert\|key\):ssl.\1:g" \
+ doc/example.conf \
+ doc/reference.conf \
+ || die
+}
+
+src_configure() {
+ econf \
+ ac_cv_prog_cc_g=no \
+ --disable-gnutls \
+ $(use_enable debug assert soft) \
+ $(use_enable debug iodebug) \
+ $(use_enable ipv6) \
+ $(use_enable !largenet small-net) \
+ $(use_enable ssl openssl) \
+ $(use_enable zlib) \
+ --with-program-prefix=shadowircd- \
+ \
+ --enable-fhs-paths \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --libdir="${EPREFIX}"/usr/"$(get_libdir)"/${PN} \
+ --with-logdir="${EPREFIX}"/var/log/${PN} \
+ --with-moduledir="${EPREFIX}"/usr/"$(get_libdir)"/${PN}/modules \
+ --with-rundir="${EPREFIX}"/var/run
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ insinto etc/${PN}
+ newins doc/reference.conf ircd.conf
+
+ keepdir var/{lib,log}/${PN}
+
+ # Ensure that if `make install' created /var/run/${PN}, we still
+ # force the initscript to create that directory.
+ rm -rf "${D}"/var/run || die
+
+ # shadowircd needs writing to its state (bandb) and log directories
+ fowners :shadowircd /var/{lib,log}/${PN}
+ fperms 770 /var/{lib,log}/${PN}
+
+ # ensure that shadowircd can access but not modify its configuration
+ # while protecting it from others
+ fowners :shadowircd /etc/${PN}{,/ircd.conf}
+ fperms 750 /etc/${PN}
+ fperms 640 /etc/${PN}/ircd.conf
+}
+
+pkg_postinst() {
+ elog "All of the shadowircd binaries in PATH have been prefixed with"
+ elog "'shadowircd-' to prevent file collisions."
+}