summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-08-10 19:03:25 +0000
committerSven Wegener <swegener@gentoo.org>2006-08-10 19:03:25 +0000
commit9521d03adf3f0db5b4d74b15d6ced006b258791a (patch)
treedb83f212eddba5c95cd57e91578a21135071d5b7 /net-irc
parentdvb fix (diff)
downloadgentoo-2-9521d03adf3f0db5b4d74b15d6ced006b258791a.tar.gz
gentoo-2-9521d03adf3f0db5b4d74b15d6ced006b258791a.tar.bz2
gentoo-2-9521d03adf3f0db5b4d74b15d6ced006b258791a.zip
Version bump, bug #141366.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/files/digest-xchat-2.6.66
-rw-r--r--net-irc/xchat/xchat-2.6.6.ebuild88
3 files changed, 100 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index c8f0010d3508..bfe3101cb478 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.204 2006/07/13 17:02:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.205 2006/08/10 19:03:25 swegener Exp $
+
+*xchat-2.6.6 (10 Aug 2006)
+
+ 10 Aug 2006; Sven Wegener <swegener@gentoo.org> +xchat-2.6.6.ebuild:
+ Version bump, bug #141366.
13 Jul 2006; Aron Griffis <agriffis@gentoo.org> xchat-2.6.4.ebuild:
Mark 2.6.4 stable on ia64
diff --git a/net-irc/xchat/files/digest-xchat-2.6.6 b/net-irc/xchat/files/digest-xchat-2.6.6
new file mode 100644
index 000000000000..48ad87596305
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.6.6
@@ -0,0 +1,6 @@
+MD5 43c187582beb31e744c4c5a833a022b5 xchat-2.6.6.tar.bz2 1098934
+RMD160 27cef034342dc831e2ddb11f8bd5f6cb727e8f93 xchat-2.6.6.tar.bz2 1098934
+SHA256 c4b38d29e6a9872c8ffde27c8866d8c3b9f1fe6e227cef5fed39bc79f983d44c xchat-2.6.6.tar.bz2 1098934
+MD5 c0220456a4df8ee54ae02e7704a6e024 xchat-dccserver-0.6.patch.bz2 49320
+RMD160 24cc9bd414b1dd0e7e38ba9a49d12257aeb89e68 xchat-dccserver-0.6.patch.bz2 49320
+SHA256 90a49a8d810380020c507c1a36f02e7d972cf92b5e4802dcd5cc518cba29078f xchat-dccserver-0.6.patch.bz2 49320
diff --git a/net-irc/xchat/xchat-2.6.6.ebuild b/net-irc/xchat/xchat-2.6.6.ebuild
new file mode 100644
index 000000000000..61dfc4e85277
--- /dev/null
+++ b/net-irc/xchat/xchat-2.6.6.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.6.6.ebuild,v 1.1 2006/08/10 19:03:25 swegener Exp $
+
+inherit eutils versionator gnome2
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/$(get_version_component_range 1-2)/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-dccserver-0.6.patch.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="perl dbus tcl python ssl mmx ipv6 nls spell xchattext xchatnogtk xchatdccserver"
+
+RDEPEND=">=dev-libs/glib-2.6.0
+ !xchatnogtk? ( >=x11-libs/gtk+-2.6.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( >=dev-lang/python-2.2 )
+ tcl? ( dev-lang/tcl )
+ dbus? ( >=sys-apps/dbus-0.35 )
+ spell? ( app-text/enchant )
+ !<net-irc/xchat-gnome-0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
+
+ # use libdir/xchat/plugins as the plugin directory
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \
+ "${S}"/configure{,.in} || die
+ fi
+}
+
+src_compile() {
+ # Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+ if [ ${ARCH} = "sparc" ] ; then
+ replace-flags "-O[3-9]" "-O2"
+ fi
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ econf \
+ --enable-shm \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable spell spell static) \
+ $(use_enable xchattext textfe) \
+ $(use_enable !xchatnogtk gtkfe) \
+ --program-suffix=-2 \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # some magic to create a menu entry for xchat 2
+ sed -i \
+ -e "s:^Exec=xchat$:Exec=xchat-2:" \
+ -e "s:Name=XChat IRC:Name=XChat 2 IRC:" \
+ xchat.desktop
+
+ USE_DESTDIR=1 gnome2_src_install || die "make install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc ChangeLog README* || die "dodoc failed"
+}