summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-12-09 03:46:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-12-09 03:46:42 +0000
commit4d35712b61e5af6ddcd49c81312af947e32d98fb (patch)
treee3491eab2a60e73a3a869f28f04d77b6968ac91d /net-irc
parentBump, remove old (diff)
downloadgentoo-2-4d35712b61e5af6ddcd49c81312af947e32d98fb.tar.gz
gentoo-2-4d35712b61e5af6ddcd49c81312af947e32d98fb.tar.bz2
gentoo-2-4d35712b61e5af6ddcd49c81312af947e32d98fb.zip
Build fix for *BSD, #492756
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/ChangeLog6
-rw-r--r--net-irc/quassel/files/missing-bsd-includes.patch33
-rw-r--r--net-irc/quassel/quassel-0.9.2.ebuild7
3 files changed, 44 insertions, 2 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 2a09d3d79812..b29ca210800a 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.159 2013/11/27 03:40:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.160 2013/12/09 03:46:42 patrick Exp $
+
+ 09 Dec 2013; Patrick Lauer <patrick@gentoo.org>
+ +files/missing-bsd-includes.patch, quassel-0.9.2.ebuild:
+ Build fix for *BSD, #492756
*quassel-0.9.2 (27 Nov 2013)
diff --git a/net-irc/quassel/files/missing-bsd-includes.patch b/net-irc/quassel/files/missing-bsd-includes.patch
new file mode 100644
index 000000000000..22cf32f9bdbb
--- /dev/null
+++ b/net-irc/quassel/files/missing-bsd-includes.patch
@@ -0,0 +1,33 @@
+From 9e798c47eac3f01295016b6f27a48e787a072c25 Mon Sep 17 00:00:00 2001
+From: Manuel Nickschas <sputnick@quassel-irc.org>
+Date: Thu, 28 Nov 2013 01:45:43 +0100
+Subject: [PATCH] Make sys includes POSIX-compliant
+
+We're using <sys/resources.h> in quassel.cpp for the backtrace generation
+stuff. Documentation for that header indicates that <sys/time.h> shall also
+be included (even though it doesn't seem to be needed for our usage).
+Additionally, compiling started to fail in recent FreeBSD versions, because
+we lacked the <sys/types.h> include, which seems to be mandated by POSIX
+(but not on Linux, although it won't hurt to have it).
+
+tl;dr: This should make Quassel compile on recent versions of FreeBSD again.
+---
+ src/common/quassel.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/common/quassel.cpp b/src/common/quassel.cpp
+index e081775..058b4b9 100644
+--- a/src/common/quassel.cpp
++++ b/src/common/quassel.cpp
+@@ -23,6 +23,8 @@
+ #include <iostream>
+ #include <signal.h>
+ #if !defined Q_OS_WIN32 && !defined Q_OS_MAC
++# include <sys/types.h>
++# include <sys/time.h>
+ # include <sys/resource.h>
+ #endif
+
+--
+1.8.4
+
diff --git a/net-irc/quassel/quassel-0.9.2.ebuild b/net-irc/quassel/quassel-0.9.2.ebuild
index 15901dc1521b..e3b0d89113a5 100644
--- a/net-irc/quassel/quassel-0.9.2.ebuild
+++ b/net-irc/quassel/quassel-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.9.2.ebuild,v 1.1 2013/11/27 03:40:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.9.2.ebuild,v 1.2 2013/12/09 03:46:42 patrick Exp $
EAPI=4
@@ -88,6 +88,11 @@ pkg_setup() {
fi
}
+src_prepare() {
+ # fix for #492756
+ epatch "${FILESDIR}/missing-bsd-includes.patch" || die
+}
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with ayatana LIBINDICATE)