summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-03 09:55:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-03 09:55:34 +0000
commit2cbdbc7b35da0ec59fd1465addc51a3ba47e9634 (patch)
tree3752656312e834de65da0eb6ff1c5ccf00919774 /net-irc
parentDependencie fixes (diff)
downloadgentoo-2-2cbdbc7b35da0ec59fd1465addc51a3ba47e9634.tar.gz
gentoo-2-2cbdbc7b35da0ec59fd1465addc51a3ba47e9634.tar.bz2
gentoo-2-2cbdbc7b35da0ec59fd1465addc51a3ba47e9634.zip
*** empty log message ***
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/xchat-1.6.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-irc/xchat/xchat-1.6.4.ebuild b/net-irc/xchat/xchat-1.6.4.ebuild
new file mode 100644
index 000000000000..7433f08c766d
--- /dev/null
+++ b/net-irc/xchat/xchat-1.6.4.ebuild
@@ -0,0 +1,51 @@
+# Copyrigth 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.6.4.ebuild,v 1.1 2001/06/03 09:55:34 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="xchat"
+SRC_URI="http://www.xchat.org/files/source/1.6/"${A}
+HOMEPAGE="http://www.xchat.org/"
+
+DEPEND=">=media-libs/imlib-1.9.8.1
+ gnome? ( >=gnome-base/gnome-core-1.2.2.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/po
+ cp zh_TW.Big5.po zh_TW.Big5.po.orig
+ sed -e 's:\\\\:\\:' zh_TW.Big5.po.orig > zh_TW.Big5.po
+}
+
+src_compile() {
+ cd ${S}
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ myopts="--enable-gnome --prefix=/opt/gnome"
+ else
+ myopts="--disable-gnome --prefix=/usr/X11R6"
+ fi
+ try ./configure --host=${CHOST} --disable-perl --disable-python ${myopts} \
+ --with-included-gettext
+ try make
+}
+
+src_install() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr/X11R6 install
+ fi
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+
+
+
+
+