summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-05-16 15:55:08 +0000
committerSven Wegener <swegener@gentoo.org>2005-05-16 15:55:08 +0000
commitec8922231de5e3c7f47efc58cd266a687d5f8a43 (patch)
treecfc5042b121e24193ac726521a41215eedbf1d67 /net-irc/xchat-xsys/files
parentMarked stable on x86. (diff)
downloadgentoo-2-ec8922231de5e3c7f47efc58cd266a687d5f8a43.tar.gz
gentoo-2-ec8922231de5e3c7f47efc58cd266a687d5f8a43.tar.bz2
gentoo-2-ec8922231de5e3c7f47efc58cd266a687d5f8a43.zip
Removed old ebuild. Some general cleanup.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'net-irc/xchat-xsys/files')
-rw-r--r--net-irc/xchat-xsys/files/1.9.1-bmp-support.patch100
-rw-r--r--net-irc/xchat-xsys/files/1.9.3-sysfs-instead-of-lspci.patch127
-rw-r--r--net-irc/xchat-xsys/files/digest-xchat-xsys-1.9.31
3 files changed, 0 insertions, 228 deletions
diff --git a/net-irc/xchat-xsys/files/1.9.1-bmp-support.patch b/net-irc/xchat-xsys/files/1.9.1-bmp-support.patch
deleted file mode 100644
index f08767d3fc4c..000000000000
--- a/net-irc/xchat-xsys/files/1.9.1-bmp-support.patch
+++ /dev/null
@@ -1,100 +0,0 @@
---- parse.c.orig 2005-01-16 10:28:16.271149064 +0000
-+++ parse.c 2005-01-16 10:38:13.400371624 +0000
-@@ -28,6 +28,45 @@
-
- #include "xchat-plugin.h"
-
-+int xs_parse_bmp(char *title, char *pos, char *time)
-+{
-+ char buffer[1024], *position;
-+ FILE *fp = fopen("/tmp/xmms-info", "r");
-+ if(fp == NULL)
-+ return 1;
-+
-+ while(fgets(buffer, 1024, fp) != NULL)
-+ {
-+ if(strstr(buffer, "Position") != NULL && pos != NULL)
-+ {
-+ position = strstr(buffer, ":");
-+ position += 2;
-+ strcpy(pos, position);
-+ position = strstr(pos, "\n");
-+ *(position) = '\0';
-+ }
-+ else if(strstr(buffer, "Time") != NULL && time != NULL)
-+ {
-+ position = strstr(buffer, ":");
-+ position += 2;
-+ strcpy(time, position);
-+ position = strstr(time, "\n");
-+ *(position) = '\0';
-+ }
-+ else if(strstr(buffer, "Title") != NULL && title != NULL)
-+ {
-+ position = strstr(buffer, ":");
-+ position += 2;
-+ strcpy(title, position);
-+ position = strstr(title, "\n");
-+ *(position) = '\0';
-+ }
-+ }
-+ fclose(fp);
-+
-+ return 0;
-+}
-+
- int xs_parse_cpu(char *model, char *vendor, double *freq, char *cache, unsigned int *count)
- {
- char buffer[1024], *position;
---- parse.h.orig 2005-01-16 10:36:30.070080216 +0000
-+++ parse.h 2005-01-16 10:36:48.007353336 +0000
-@@ -22,6 +22,7 @@
- #ifndef _PARSE_H_
- #define _PARSE_H_
-
-+int xs_parse_bmp(char *title, char *pos, char *time);
- int xs_parse_cpu(char *model, char *vendor, double *freq, char *cache, unsigned int *count);
- int xs_parse_uptime(int *weeks, int *days, int *hours, int *minutes, int *seconds);
- int xs_parse_os(char *user, char *host, char *kernel);
---- xsys.c.orig 2005-01-16 10:38:50.338756136 +0000
-+++ xsys.c 2005-01-16 10:49:31.290316688 +0000
-@@ -46,6 +46,7 @@
- static int disk_cb (char *word[], char *word_eol[], void *userdata);
- static int mem_cb (char *word[], char *word_eol[], void *userdata);
- static int video_cb (char *word[], char *word_eol[], void *userdata);
-+static int bmp_cb (char *word[], char *word_eol[], void *userdata);
-
- int xchat_plugin_init(xchat_plugin *plugin_handle, char **plugin_name,
- char **plugin_desc, char **plugin_version, char *arg)
-@@ -80,6 +81,8 @@
- xchat_hook_command(ph, "EMEMINFO", XCHAT_PRI_NORM, mem_cb, NULL, (void *) 1);
- xchat_hook_command(ph, "VIDEO", XCHAT_PRI_NORM, video_cb, NULL, (void *) 0);
- xchat_hook_command(ph, "EVIDEO", XCHAT_PRI_NORM, video_cb, NULL, (void *) 1);
-+ xchat_hook_command(ph, "BMP", XCHAT_PRI_NORM, bmp_cb, NULL, (void *) 0);
-+ xchat_hook_command(ph, "EBMP", XCHAT_PRI_NORM, bmp_cb, NULL, (void *) 1);
-
- load_format();
- xchat_printf(ph, "X-Sys 2 Loaded Succesfully");
-@@ -580,3 +583,22 @@
- return XCHAT_EAT_ALL;
- }
-
-+static int bmp_cb(char *word[], char *word_eol[], void *userdata)
-+{
-+ char buffer[1024], time[16], pos[16], title[256];
-+ if(xs_parse_bmp(title, pos, time) != 0)
-+ {
-+ xchat_printf(ph, "BMP/XMMS is not running");
-+ return XCHAT_EAT_NONE;
-+ }
-+
-+ snprintf(buffer, 1024, "%s (%s/%s)", title, pos, time);
-+
-+ format_output("bmp_playing", buffer);
-+ if((int)userdata)
-+ xchat_printf(ph, "%s", buffer);
-+ else
-+ xchat_commandf(ph, "say %s", buffer);
-+
-+ return XCHAT_EAT_ALL;
-+}
diff --git a/net-irc/xchat-xsys/files/1.9.3-sysfs-instead-of-lspci.patch b/net-irc/xchat-xsys/files/1.9.3-sysfs-instead-of-lspci.patch
deleted file mode 100644
index cfe01e6ac3ce..000000000000
--- a/net-irc/xchat-xsys/files/1.9.3-sysfs-instead-of-lspci.patch
+++ /dev/null
@@ -1,127 +0,0 @@
---- xsys2/parse.c.orig 2005-04-17 21:01:24.000000000 +0100
-+++ xsys2/parse.c 2005-04-17 23:05:40.000000000 +0100
-@@ -150,19 +150,91 @@
-
- int xs_parse_video(char *vid_card)
- {
-- char *pos = NULL;
-- FILE *pipe = popen(LSPCI" | grep VGA | cut -d\" \" -f5-", "r");
-- if(pipe == NULL)
-- return 1;
-- while(fgets(vid_card, 1024, pipe) != NULL)
-+ char buffer[1024], pcibus[42], vendor[7], device[7], vendorname[128] = "", devicename[128] = "", *position;
-+ int busnr = 0, devnr = 0, cardfound = 0;
-+
-+ while ( busnr <= 9 )
- {
-- if((pos = strchr(vid_card, '\n')) != NULL)
-- *pos = '\0';
-+ while ( devnr <= 9 ) {
-+ snprintf(pcibus, 42, "/sys/bus/pci/devices/0000:%.2d:%.2d.0/class", busnr, devnr);
-+ FILE *fp = fopen(pcibus, "r");
-+ if(fp != NULL) {
-+ if(fgets(buffer, 1024, fp) != NULL)
-+ if(strncmp("0x03", buffer, 4) == 0) {
-+ cardfound = 1;
-+ break;
-+ }
-+ fclose(fp);
-+ }
-+ devnr++;
-+ }
-+ if (cardfound == 1)
-+ break;
-+ busnr++;
-+ devnr = 0;
-+ }
-+
-+ if (cardfound == 0) {
-+ strncpy(vid_card, "No AGP card found", 42);
-+ return 0;
- }
-- if(pos == NULL) return 2;
-+
-+ snprintf(pcibus, 42, "/sys/bus/pci/devices/0000:%.2d:%.2d.0/device", busnr, devnr);
-+ FILE *fp = fopen(pcibus, "r");
-+ if(fp != NULL) {
-+ if(fgets(buffer, 1024, fp) != NULL)
-+ if(strstr(buffer, "0x") != NULL) {
-+ position = strstr(buffer, "0x");
-+ position += 2;
-+ strncpy(device, position, 7);
-+ position = strstr(device, "\n");
-+ *(position) = '\0';
-+ }
-+ fclose(fp);
-+ }
-+
-+ snprintf(pcibus, 42, "/sys/bus/pci/devices/0000:%.2d:%.2d.0/vendor", busnr, devnr);
-+ FILE *fp2 = fopen(pcibus, "r");
-+ if(fp2 != NULL) {
-+ if(fgets(buffer, 1024, fp) != NULL)
-+ if(strstr(buffer, "0x") != NULL) {
-+ position = strstr(buffer, "0x");
-+ position += 2;
-+ strncpy(vendor, position, 7);
-+ position = strstr(vendor, "\n");
-+ *(position) = '\0';
-+ }
-+ fclose(fp2);
-+ }
-
-- pclose(pipe);
-+ FILE *fp3 = fopen("/usr/share/misc/pci.ids", "r");
-+ if(fp3 == NULL) {
-+ snprintf(vid_card, 42, "Found AGP card %s:%s", vendor, device);
-+ return 0;
-+ }
-
-+ while(fgets(buffer, 1024, fp3) != NULL) {
-+ if (!isspace(buffer[0]) && strstr(buffer, vendor) != NULL) {
-+ position = strstr(buffer, vendor);
-+ position += 6;
-+ strncpy(vendorname, position, 128);
-+ position = strstr(vendorname, "\n");
-+ *(position) = '\0';
-+ break;
-+ }
-+ }
-+ while(fgets(buffer, 1024, fp3) != NULL) {
-+ if(strstr(buffer, device) != NULL) {
-+ position = strstr(buffer, device);
-+ position += 6;
-+ strncpy(devicename, position, 128);
-+ position = strstr(devicename, "\n");
-+ *(position) = '\0';
-+ break;
-+ }
-+ }
-+ fclose(fp3);
-+ snprintf(vid_card, 256, "%s %s", vendorname, devicename);
- return 0;
- }
-
-@@ -389,4 +461,3 @@
- }
- return 0;
- }
--
---- xsys2/Makefile.orig 2005-04-17 21:01:27.000000000 +0100
-+++ xsys2/Makefile 2005-04-17 21:01:31.000000000 +0100
-@@ -1,7 +1,3 @@
--#### SET THIS VALUE TO THE LOCATION OF 'lspci' ####
--LSPCI = /sbin/lspci
--
--
- #### SHOULD NOT NEED TO EDIT BELOW THIS LINE ####
- VER_MAJOR = 1
- VER_MINOR = 9
-@@ -9,7 +5,7 @@
- CC = gcc
- CFLAGS += -O2 -Wall -fPIC
- CFLAGS += -DVER_MINOR=$(VER_MINOR) -DVER_MAJOR=$(VER_MAJOR) -DVER_PATCH=$(VER_PATCH) \
-- -DVER_STRING=\"$(VER_MAJOR).$(VER_MINOR).$(VER_PATCH)\" -DLSPCI=\"$(LSPCI)\"
-+ -DVER_STRING=\"$(VER_MAJOR).$(VER_MINOR).$(VER_PATCH)\"
- LDFLAGS = $(CFLAGS) -shared
- LIBRARY = xsys-$(VER_MAJOR).$(VER_MINOR).$(VER_PATCH).so
- OBJECTS = xsys.o parse.o
diff --git a/net-irc/xchat-xsys/files/digest-xchat-xsys-1.9.3 b/net-irc/xchat-xsys/files/digest-xchat-xsys-1.9.3
deleted file mode 100644
index 717d41bf4a89..000000000000
--- a/net-irc/xchat-xsys/files/digest-xchat-xsys-1.9.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7a284ae9aea5f951e8e89e1c846848fb xsys-1.9.3.tar.bz2 10578