summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-10-03 19:41:33 +0000
committerSven Wegener <swegener@gentoo.org>2004-10-03 19:41:33 +0000
commit3138d002eafaaf9e0ee121c21e50dc649671e1af (patch)
tree1781416332f9d00d62485ee3634ebf3a268dd85a /net-irc/pisg/pisg-0.59.ebuild
parentAdd new Version 0.8.0, fixes Bug 33653. (Manifest recommit) (diff)
downloadgentoo-2-3138d002eafaaf9e0ee121c21e50dc649671e1af.tar.gz
gentoo-2-3138d002eafaaf9e0ee121c21e50dc649671e1af.tar.bz2
gentoo-2-3138d002eafaaf9e0ee121c21e50dc649671e1af.zip
Version bump.
Diffstat (limited to 'net-irc/pisg/pisg-0.59.ebuild')
-rw-r--r--net-irc/pisg/pisg-0.59.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-irc/pisg/pisg-0.59.ebuild b/net-irc/pisg/pisg-0.59.ebuild
new file mode 100644
index 000000000000..b26ab085ed02
--- /dev/null
+++ b/net-irc/pisg/pisg-0.59.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/pisg-0.59.ebuild,v 1.1 2004/10/03 19:41:33 swegener Exp $
+
+inherit eutils
+
+DESCRIPTION="Perl IRC Statistics Generator"
+HOMEPAGE="http://pisg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/Text-Iconv"
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.56-network-option-fix.patch
+
+ sed -i 's!lang\.txt!/usr/share/pisg/lang.txt!' modules/Pisg.pm
+ sed -i 's!layout/!/usr/share/pisg/layout/!' modules/Pisg.pm
+}
+
+src_install () {
+ eval `perl -V:installprivlib`
+
+ dobin pisg
+
+ dodir ${installprivlib}
+ cp -r modules/* ${D}/${installprivlib}
+
+ dodir /usr/share/pisg
+ cp -r gfx layout lang.txt ${D}/usr/share/pisg
+
+ dodoc \
+ docs/{CREDITS,Changelog,FORMATS,pisg-doc.txt} \
+ docs/dev/API pisg.cfg README
+ dohtml docs/html/*
+
+ find ${D}/usr/{lib,share} -type d -exec chmod 755 {} \;
+ find ${D}/usr/{lib,share} -type f -exec chmod 644 {} \;
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The pisg images have been installed in /usr/share/pisg/gfx"
+ einfo
+}