summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-02-01 17:38:25 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-02-01 17:38:25 +0000
commit0ce2eef9543214906d1353e70ec0c0a74b9a6068 (patch)
tree4f68eea1abbd70c69b40fa1efae860d7ce3b1942 /net-irc/ngircd
parenttypo in homepage (diff)
downloadgentoo-2-0ce2eef9543214906d1353e70ec0c0a74b9a6068.tar.gz
gentoo-2-0ce2eef9543214906d1353e70ec0c0a74b9a6068.tar.bz2
gentoo-2-0ce2eef9543214906d1353e70ec0c0a74b9a6068.zip
Add new version. From my dev overlay. Polised thanks to Nathan Phillip Brink (binki).
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/ngircd')
-rw-r--r--net-irc/ngircd/ChangeLog11
-rw-r--r--net-irc/ngircd/files/ngircd.init.d8
-rw-r--r--net-irc/ngircd/ngircd-17.1.ebuild82
3 files changed, 95 insertions, 6 deletions
diff --git a/net-irc/ngircd/ChangeLog b/net-irc/ngircd/ChangeLog
index 99309267c93d..80747969342e 100644
--- a/net-irc/ngircd/ChangeLog
+++ b/net-irc/ngircd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/ngircd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ChangeLog,v 1.51 2009/09/23 18:44:41 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ChangeLog,v 1.52 2011/02/01 17:38:24 scarabeus Exp $
+
+*ngircd-17.1 (01 Feb 2011)
+
+ 01 Feb 2011; Tomáš Chvátal <scarabeus@gentoo.org> +ngircd-17.1.ebuild,
+ files/ngircd.init.d:
+ Add new version. From my dev overlay. Polised thanks to Nathan Phillip Brink
+ (binki).
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> ngircd-0.12.1.ebuild,
ngircd-13.ebuild:
diff --git a/net-irc/ngircd/files/ngircd.init.d b/net-irc/ngircd/files/ngircd.init.d
index 807d844e8d97..984f8a861d22 100644
--- a/net-irc/ngircd/files/ngircd.init.d
+++ b/net-irc/ngircd/files/ngircd.init.d
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/files/ngircd.init.d,v 1.3 2006/01/02 15:31:27 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/files/ngircd.init.d,v 1.4 2011/02/01 17:38:25 scarabeus Exp $
depend() {
need net
@@ -11,11 +11,11 @@ depend() {
start() {
ebegin "Starting ngIRCd"
start-stop-daemon --start --quiet --exec /usr/sbin/ngircd
- eend $? "Failed to start ngIRCd"
+ eend $?
}
stop() {
ebegin "Stopping ngIRCd"
start-stop-daemon --stop --quiet --exec /usr/sbin/ngircd
- eend $? "Failed to stop ngIRCd"
+ eend $?
}
diff --git a/net-irc/ngircd/ngircd-17.1.ebuild b/net-irc/ngircd/ngircd-17.1.ebuild
new file mode 100644
index 000000000000..726215420c50
--- /dev/null
+++ b/net-irc/ngircd/ngircd-17.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ngircd-17.1.ebuild,v 1.1 2011/02/01 17:38:24 scarabeus Exp $
+
+EAPI=4
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A IRC server written from scratch"
+HOMEPAGE="http://ngircd.barton.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/${PN}/${P}.tar.gz
+ ftp://ngircd.barton.de/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x64-macos"
+IUSE="debug gnutls ident ipv6 pam ssl tcpd zlib"
+
+DEPEND="
+ >=sys-apps/sed-4
+ virtual/libc
+ ident? ( net-libs/libident )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ )
+ pam? ( virtual/pam )
+ tcpd? ( sys-apps/tcp-wrappers )
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_configure() {
+ if ! use prefix; then
+ sed -i \
+ -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
+ -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
+ doc/sample-ngircd.conf.tmpl || die
+ fi
+
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --sysconfdir="${EPREFIX}"/etc/ngircd
+ --without-zeroconf
+ $(use_enable ipv6)
+ $(use_with zlib)
+ $(use_with tcpd tcp-wrappers)
+ $(use_with ident)
+ $(use_with pam)
+ $(use_enable debug)
+ $(use_enable debug sniffer)
+ )
+
+ if use ssl; then
+ myeconfargs+=(
+ $(use_with !gnutls openssl)
+ $(use_with gnutls)
+ )
+ else
+ myeconfargs+=(
+ --without-gnutls
+ --without-ssl
+ )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newinitd "${FILESDIR}"/ngircd.init.d ngircd
+}
+
+pkg_postinst() {
+ if ! use prefix; then
+ enewuser ngircd
+ chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
+ fi
+}