summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-07-25 23:34:33 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-07-25 23:34:33 +0000
commit581641d024c0cb5c91b35fa89252a20d7d9970b0 (patch)
tree0f4c57411862a4a3460277832ddb12cabcee4c77 /net-irc/irssi-otr
parentDrop unneeded dependencies (per configure). (diff)
downloadgentoo-2-581641d024c0cb5c91b35fa89252a20d7d9970b0.tar.gz
gentoo-2-581641d024c0cb5c91b35fa89252a20d7d9970b0.tar.bz2
gentoo-2-581641d024c0cb5c91b35fa89252a20d7d9970b0.zip
Revision bump: EAPI 5, proper handling of python-related stuff, wrt bug #315307, drop old revision
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-irc/irssi-otr')
-rw-r--r--net-irc/irssi-otr/ChangeLog9
-rw-r--r--net-irc/irssi-otr/irssi-otr-0.3-r1.ebuild43
-rw-r--r--net-irc/irssi-otr/irssi-otr-0.3.ebuild39
3 files changed, 51 insertions, 40 deletions
diff --git a/net-irc/irssi-otr/ChangeLog b/net-irc/irssi-otr/ChangeLog
index 131198348ccf..32d5e30f1d5d 100644
--- a/net-irc/irssi-otr/ChangeLog
+++ b/net-irc/irssi-otr/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/irssi-otr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/ChangeLog,v 1.12 2013/06/01 14:42:58 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/ChangeLog,v 1.13 2013/07/25 23:34:32 pinkbyte Exp $
+
+*irssi-otr-0.3-r1 (25 Jul 2013)
+
+ 25 Jul 2013; Sergey Popov <pinkbyte@gentoo.org> -irssi-otr-0.3.ebuild,
+ +irssi-otr-0.3-r1.ebuild:
+ Revision bump: EAPI 5, proper handling of python-related stuff, wrt bug
+ #315307, drop old revision
01 Jun 2013; Chris Reffett <creffett@gentoo.org> irssi-otr-0.2.ebuild:
EAPI bump wrt bug 460572
diff --git a/net-irc/irssi-otr/irssi-otr-0.3-r1.ebuild b/net-irc/irssi-otr/irssi-otr-0.3-r1.ebuild
new file mode 100644
index 000000000000..c8a2bc44ea70
--- /dev/null
+++ b/net-irc/irssi-otr/irssi-otr-0.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/irssi-otr-0.3-r1.ebuild,v 1.1 2013/07/25 23:34:32 pinkbyte Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="Off-The-Record messaging (OTR) for irssi"
+HOMEPAGE="http://irssi-otr.tuxfamily.org"
+SRC_URI="ftp://download.tuxfamily.org/irssiotr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="net-libs/libotr
+ dev-libs/glib:2
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error
+ net-irc/irssi"
+
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+
+src_prepare() {
+ # do not install docs through buildsystem
+ sed -i -e '/README LICENSE/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCDIR="/usr/share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-irc/irssi-otr/irssi-otr-0.3.ebuild b/net-irc/irssi-otr/irssi-otr-0.3.ebuild
deleted file mode 100644
index b7570c3ab883..000000000000
--- a/net-irc/irssi-otr/irssi-otr-0.3.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/irssi-otr-0.3.ebuild,v 1.5 2012/05/03 06:27:14 jdhore Exp $
-
-EAPI=2
-inherit cmake-utils
-
-DESCRIPTION="Off-The-Record messaging (OTR) for irssi"
-HOMEPAGE="http://irssi-otr.tuxfamily.org"
-
-# This should probably be exported by cmake-utils as a variable
-CMAKE_BINARY_DIR="${WORKDIR}"/${PN}_build
-mycmakeargs="-DDOCDIR=/usr/share/doc/${PF}"
-
-SRC_URI="ftp://download.tuxfamily.org/irssiotr/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~sparc ~x86"
-IUSE="debug"
-
-RDEPEND="net-libs/libotr
- dev-libs/glib:2
- dev-libs/libgcrypt
- dev-libs/libgpg-error
- || (
- net-irc/irssi
- net-irc/irssi-svn
- )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-lang/python"
-
-src_install() {
- cmake-utils_src_install
- rm "${D}"/usr/share/doc/${PF}/LICENSE
- prepalldocs
-}