summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2007-07-01 15:42:40 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2007-07-01 15:42:40 +0000
commitf8516aa59b7226eb6af208b60972b8dc495d15ff (patch)
tree5bb602f284f2f941406045e7fa5e02b97b82c11e /net-irc/inspircd
parentStable on ppc; bug #178635. (diff)
downloadgentoo-2-f8516aa59b7226eb6af208b60972b8dc495d15ff.tar.gz
gentoo-2-f8516aa59b7226eb6af208b60972b8dc495d15ff.tar.bz2
gentoo-2-f8516aa59b7226eb6af208b60972b8dc495d15ff.zip
Version bump by Craig Edwards
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-irc/inspircd')
-rw-r--r--net-irc/inspircd/ChangeLog8
-rw-r--r--net-irc/inspircd/files/digest-inspircd-1.1.83
-rw-r--r--net-irc/inspircd/inspircd-1.1.8.ebuild75
-rw-r--r--net-irc/inspircd/metadata.xml4
4 files changed, 87 insertions, 3 deletions
diff --git a/net-irc/inspircd/ChangeLog b/net-irc/inspircd/ChangeLog
index d2ec0e84ca73..06b2de50456e 100644
--- a/net-irc/inspircd/ChangeLog
+++ b/net-irc/inspircd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/inspircd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.9 2007/01/28 22:02:47 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.10 2007/07/01 15:42:40 hansmi Exp $
+
+*inspircd-1.1.8 (16 Jun 2007)
+
+ 16 Jun 2007; Michael Hanselmann <hansmi@gentoo.org> metadata.xml,
+ +inspircd-1.1.8.ebuild:
+ Version bump by Craig Edwards, bug 181243.
28 Jan 2007; Michael Hanselmann <hansmi@gentoo.org>
-inspircd-1.0.6.ebuild, -inspircd-1.0.7.ebuild:
diff --git a/net-irc/inspircd/files/digest-inspircd-1.1.8 b/net-irc/inspircd/files/digest-inspircd-1.1.8
new file mode 100644
index 000000000000..e4eebbd838de
--- /dev/null
+++ b/net-irc/inspircd/files/digest-inspircd-1.1.8
@@ -0,0 +1,3 @@
+MD5 4ca1b55574e8d4abd86bbd2a6637dd2e InspIRCd-1.1.8.tar.bz2 484273
+RMD160 6e3b0c9b480fc523998f63cb9c4b033a5fd8ca0f InspIRCd-1.1.8.tar.bz2 484273
+SHA256 cf65aaf23d04dfe08770580bf095a6b7c7ae3051abdfeda7cd2fab1548626616 InspIRCd-1.1.8.tar.bz2 484273
diff --git a/net-irc/inspircd/inspircd-1.1.8.ebuild b/net-irc/inspircd/inspircd-1.1.8.ebuild
new file mode 100644
index 000000000000..8a87d2475a9e
--- /dev/null
+++ b/net-irc/inspircd/inspircd-1.1.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.8.ebuild,v 1.1 2007/07/01 15:42:40 hansmi Exp $
+
+inherit eutils toolchain-funcs multilib # subversion
+
+IUSE="openssl gnutls ipv6 kernel_linux"
+
+DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
+HOMEPAGE="http://www.inspircd.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RDEPEND="
+ >=sys-devel/gcc-3.3.0
+ >=dev-lang/perl-5.8
+ openssl? ( >=dev-libs/openssl-0.9.7d )
+ gnutls? ( >=net-libs/gnutls-1.3.0 )"
+DEPEND="${RDEPEND}"
+SRC_URI="mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
+#ESVN_REPO_URI="http://svn.inspircd.org/repository/trunk/inspircd"
+#ESVN_PROJECT="inspircd"
+
+S="${WORKDIR}/inspircd"
+
+pkg_setup() {
+ enewgroup inspircd
+ enewuser inspircd -1 -1 -1 inspircd
+}
+
+src_compile() {
+ local myconf=""
+
+ # Write a configuration file
+ # we don't use econf.
+ USE_SSL="$(use_enable openssl)"
+ use gnutls && USE_SSL="$(use_enable gnutls)"
+ USE_SOCKET_ENGINE="--enable-epoll"
+ ./configure $(use_enable ipv6) --enable-remote-ipv6 ${USE_SSL} \
+ ${USE_SOCKET_ENGINE} \
+ --prefix="/usr/$(get_libdir)/inspircd" \
+ --config-dir="/etc/inspircd" --bin-dir="/usr/bin" \
+ --library-dir="/usr/$(get_libdir)/inspircd" \
+ --module-dir="/usr/$(get_libdir)/inspircd/modules" \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # the inspircd buildsystem does not create these, it's configure script
+ # does. so, we have to at this point to make sure they are there.
+ dodir /usr/$(get_libdir)/inspircd
+ dodir /usr/$(get_libdir)/inspircd/modules
+ dodir /etc/inspircd
+
+ emake install \
+ LIBPATH="${D}/usr/$(get_libdir)/inspircd/" \
+ MODPATH="${D}/usr/$(get_libdir)/inspircd/modules/" \
+ CONPATH="${D}/etc/inspircd" \
+ BINPATH="${D}/usr/bin" \
+ BASE="${D}/usr/$(get_libdir)/inspircd/inspircd.launcher"
+
+ newinitd "${FILESDIR}"/init.d_inspircd inspircd
+}
+
+pkg_postinst() {
+ chown -R inspircd:inspircd "${ROOT}"/etc/inspircd
+ chmod 700 "${ROOT}"/etc/inspircd
+
+ chown -R inspircd:inspircd "${ROOT}"/usr/$(get_libdir)/inspircd
+ chmod -R 755 "${ROOT}"/usr/$(get_libdir)/inspircd
+
+ chmod -R 755 /usr/bin/inspircd
+}
diff --git a/net-irc/inspircd/metadata.xml b/net-irc/inspircd/metadata.xml
index 50a7771a1b0d..7e47956222a8 100644
--- a/net-irc/inspircd/metadata.xml
+++ b/net-irc/inspircd/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>nenolod@nenolod.net</email>
- <name>William Pitcock</name>
+ <email>brain@winbot.co.uk</email>
+ <name>Craig Edwards</name>
<description>Indirectly maintaining through hansmi@gentoo.org</description>
</maintainer>
</pkgmetadata>