summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 12:53:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 12:53:35 +0000
commitbe8a6e07aeb292147a2957314b46385e588e0995 (patch)
tree4c14cb76a39bb5d393f000ab10aa134f47ce256a /net-irc/ezbounce/files
parentAdd patch to build with --as-needed, closes bug #248015. (diff)
downloadgentoo-2-be8a6e07aeb292147a2957314b46385e588e0995.tar.gz
gentoo-2-be8a6e07aeb292147a2957314b46385e588e0995.tar.bz2
gentoo-2-be8a6e07aeb292147a2957314b46385e588e0995.zip
Add --as-needed patch by Kevin Pyle (bug #248017); fix building with glibc 2.10.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/ezbounce/files')
-rw-r--r--net-irc/ezbounce/files/ezbounce-1.99.14+glibc-2.10.patch26
-rw-r--r--net-irc/ezbounce/files/ezbounce-1.99.14-asneeded.patch12
2 files changed, 38 insertions, 0 deletions
diff --git a/net-irc/ezbounce/files/ezbounce-1.99.14+glibc-2.10.patch b/net-irc/ezbounce/files/ezbounce-1.99.14+glibc-2.10.patch
new file mode 100644
index 000000000000..d3be181150d0
--- /dev/null
+++ b/net-irc/ezbounce/files/ezbounce-1.99.14+glibc-2.10.patch
@@ -0,0 +1,26 @@
+Index: ezbounce-1.99.14/src/irc/server_info.cc
+===================================================================
+--- ezbounce-1.99.14.orig/src/irc/server_info.cc
++++ ezbounce-1.99.14/src/irc/server_info.cc
+@@ -131,7 +131,7 @@ int server_info::parse_numeric(const tex
+ /* static */ int server_info::get_005_token(const char * text,
+ const char * token, char * buf, int bufflen)
+ {
+- char * tok = strstr(text, token);
++ const char * tok = strstr(text, token);
+ int c = 0;
+ if (!tok) {
+ return 0;
+Index: ezbounce-1.99.14/src/util/tokenizer.cc
+===================================================================
+--- ezbounce-1.99.14.orig/src/util/tokenizer.cc
++++ ezbounce-1.99.14/src/util/tokenizer.cc
+@@ -45,7 +45,7 @@ char * modifying_tokenizer::next()
+ {
+ int state = 0;
+ char * p;
+- char * d;
++ const char * d;
+
+ if (end) {
+ if (end_char == 0)
diff --git a/net-irc/ezbounce/files/ezbounce-1.99.14-asneeded.patch b/net-irc/ezbounce/files/ezbounce-1.99.14-asneeded.patch
new file mode 100644
index 000000000000..bb1cc2a79b9e
--- /dev/null
+++ b/net-irc/ezbounce/files/ezbounce-1.99.14-asneeded.patch
@@ -0,0 +1,12 @@
+diff -ur a/Makefile.in b/Makefile.in
+--- a/Makefile.in 2008-04-09 23:12:05.000000000 -0500
++++ b/Makefile.in 2009-01-25 16:25:43.000000000 -0600
+@@ -91,7 +91,7 @@
+
+ $(EXE): $(OBJECTS)
+ @echo " [LINK] " $@ " (options: $(CXX_LINKER_FLAGS) $(CXX_LIBS))"
+- @$(CXX_LINKER) -o $@ $(CXX_LINKER_FLAGS) $(CXX_LIBS) $(CXX_OPTIMIZATIONS) $(OBJECTS)
++ @$(CXX_LINKER) -o $@ $(CXX_LINKER_FLAGS) $(CXX_OPTIMIZATIONS) $(OBJECTS) $(CXX_LIBS)
+
+ $(SYMLINK): $(EXE)
+ @ln -sf $(EXE) $(SYMLINK)