summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2007-12-29 15:29:07 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2007-12-29 15:29:07 +0000
commitca6d74673509c72efe170d7a88ae1895cfbfae8d (patch)
treeed5e4f109ab9ce804192b731f584bffba6787592 /net-im
parentMarking ncurses-5.6-r2 ppc64 for bug 203575 (diff)
downloadgentoo-2-ca6d74673509c72efe170d7a88ae1895cfbfae8d.tar.gz
gentoo-2-ca6d74673509c72efe170d7a88ae1895cfbfae8d.tar.bz2
gentoo-2-ca6d74673509c72efe170d7a88ae1895cfbfae8d.zip
Fix a segfault which affected Empathy.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telepathy-mission-control/ChangeLog9
-rw-r--r--net-im/telepathy-mission-control/files/digest-telepathy-mission-control-4.51-r13
-rw-r--r--net-im/telepathy-mission-control/files/telepathy-mission-control-4.51-fix-segfault.patch29
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-4.51-r1.ebuild42
4 files changed, 82 insertions, 1 deletions
diff --git a/net-im/telepathy-mission-control/ChangeLog b/net-im/telepathy-mission-control/ChangeLog
index af09b1aef6ac..b996426aced7 100644
--- a/net-im/telepathy-mission-control/ChangeLog
+++ b/net-im/telepathy-mission-control/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/telepathy-mission-control
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/ChangeLog,v 1.9 2007/12/18 11:54:12 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/ChangeLog,v 1.10 2007/12/29 15:29:06 coldwind Exp $
+
+*telepathy-mission-control-4.51-r1 (29 Dec 2007)
+
+ 29 Dec 2007; Santiago M. Mola <coldwind@gentoo.org>
+ +files/telepathy-mission-control-4.51-fix-segfault.patch,
+ +telepathy-mission-control-4.51-r1.ebuild:
+ Fix a segfault which affected Empathy.
*telepathy-mission-control-4.51 (18 Dec 2007)
diff --git a/net-im/telepathy-mission-control/files/digest-telepathy-mission-control-4.51-r1 b/net-im/telepathy-mission-control/files/digest-telepathy-mission-control-4.51-r1
new file mode 100644
index 000000000000..1b36e6a1ad9b
--- /dev/null
+++ b/net-im/telepathy-mission-control/files/digest-telepathy-mission-control-4.51-r1
@@ -0,0 +1,3 @@
+MD5 7ca18503a7a64ddedf735659820142bf telepathy-mission-control-4.51.tar.gz 584321
+RMD160 7bf42c11f89a940426e23a636fd2d04964636070 telepathy-mission-control-4.51.tar.gz 584321
+SHA256 974d2cbece40307dd569378940d13cc3c57abdb3f5a1f0407da2512a3cd2b604 telepathy-mission-control-4.51.tar.gz 584321
diff --git a/net-im/telepathy-mission-control/files/telepathy-mission-control-4.51-fix-segfault.patch b/net-im/telepathy-mission-control/files/telepathy-mission-control-4.51-fix-segfault.patch
new file mode 100644
index 000000000000..ab4e62a1f56b
--- /dev/null
+++ b/net-im/telepathy-mission-control/files/telepathy-mission-control-4.51-fix-segfault.patch
@@ -0,0 +1,29 @@
+http://sourceforge.net/tracker/index.php?func=detail&aid=1849202&group_id=190214&atid=932444
+--- src/mcd-connection.c.orig 2007-12-29 16:16:33.000000000 +0100
++++ src/mcd-connection.c 2007-12-29 16:18:41.000000000 +0100
+@@ -662,6 +662,7 @@
+ pending_channel_free (McdPendingChannel *pc)
+ {
+ g_object_unref (pc->channel);
++ g_free (pc->type);
+ g_free (pc);
+ }
+
+@@ -2186,7 +2187,7 @@
+ pc = g_malloc (sizeof(McdPendingChannel));
+ pc->handle = chan_handle;
+ pc->handle_type = chan_handle_type;
+- pc->type = chan_type;
++ pc->type = g_strdup(chan_type);
+ pc->channel = channel;
+ priv->pending_channels = g_list_prepend (priv->pending_channels, pc);
+
+@@ -2234,7 +2235,7 @@
+ pc = g_malloc (sizeof(McdPendingChannel));
+ pc->handle = req->channel_handle;
+ pc->handle_type = req->channel_handle_type;
+- pc->type = req->channel_type;
++ pc->type = g_strdup(req->channel_type);
+ pc->channel = channel;
+ priv->pending_channels = g_list_prepend (priv->pending_channels, pc);
+
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-4.51-r1.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-4.51-r1.ebuild
new file mode 100644
index 000000000000..412c77e812f8
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-4.51-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/telepathy-mission-control-4.51-r1.ebuild,v 1.1 2007/12/29 15:29:06 coldwind Exp $
+
+inherit eutils
+
+DESCRIPTION="Nokia's implementation of a Telepathy Mission Control"
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Mission_Control"
+SRC_URI="mirror://sourceforge/mission-control/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=net-libs/libtelepathy-0.3.0
+ >=dev-libs/dbus-glib-0.51
+ >=gnome-base/gconf-2
+ >=dev-util/pkgconfig-0.12.0
+ >=dev-libs/glib-2"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ doc? ( >=dev-util/gtk-doc-1.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fix-segfault.patch
+}
+
+src_compile() {
+ econf $(use_enable doc gtk-doc) \
+ --enable-server \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog
+}