summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-03-02 16:10:03 +0000
committerMichael Januszewski <spock@gentoo.org>2004-03-02 16:10:03 +0000
commitbd7286dc43fd5cfb24e76ce2300242dc37ee91d0 (patch)
tree33925a9fd885cbf89542f830b99053dbde2726b9 /net-im
parentadding s390 arch support (diff)
downloadgentoo-2-bd7286dc43fd5cfb24e76ce2300242dc37ee91d0.tar.gz
gentoo-2-bd7286dc43fd5cfb24e76ce2300242dc37ee91d0.tar.bz2
gentoo-2-bd7286dc43fd5cfb24e76ce2300242dc37ee91d0.zip
Version bump.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gnugadu/ChangeLog7
-rw-r--r--net-im/gnugadu/files/digest-gnugadu-2.0_pre71
-rw-r--r--net-im/gnugadu/gnugadu-2.0_pre7.ebuild50
3 files changed, 57 insertions, 1 deletions
diff --git a/net-im/gnugadu/ChangeLog b/net-im/gnugadu/ChangeLog
index 08f8befdd693..ec7c42c43c6d 100644
--- a/net-im/gnugadu/ChangeLog
+++ b/net-im/gnugadu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gnugadu
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.1 2004/02/07 11:30:46 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.2 2004/03/02 16:10:03 spock Exp $
+
+*gnugadu-2.0_pre7 (02 Mar 2004)
+
+ 02 Mar 2004; Michal Januszewski <spock@gentoo.org> gnugadu-2.0_pre7.ebuild:
+ Version bump, updated ebuild submitted by MadeJ <madej@afn.no-ip.org>.
*gnugadu-2.0_pre6 (07 Feb 2004)
diff --git a/net-im/gnugadu/files/digest-gnugadu-2.0_pre7 b/net-im/gnugadu/files/digest-gnugadu-2.0_pre7
new file mode 100644
index 000000000000..25ba3dbc5ece
--- /dev/null
+++ b/net-im/gnugadu/files/digest-gnugadu-2.0_pre7
@@ -0,0 +1 @@
+MD5 855526fd075bfbd739a8bc823b2aa0ac gg2-2.0pre7.tar.bz2 893819
diff --git a/net-im/gnugadu/gnugadu-2.0_pre7.ebuild b/net-im/gnugadu/gnugadu-2.0_pre7.ebuild
new file mode 100644
index 000000000000..b7636bf8f8a9
--- /dev/null
+++ b/net-im/gnugadu/gnugadu-2.0_pre7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0_pre7.ebuild,v 1.1 2004/03/02 16:10:03 spock Exp $
+
+IUSE="debug tlen esd oss xosd arts jabber perl"
+
+MY_P="gg2-2.0pre7"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="GTK-based Gadu-Gadu, Tlen and Jabber IM client"
+SRC_URI="mirror://sourceforge/ggadu/${MY_P}.tar.bz2"
+HOMEPAGE="http://gadu.gnu.pl/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-libs/gtk+-2.2.0
+ sys-devel/gettext
+ >=sys-devel/automake-1.7
+ >=sys-devel/libtool-1.4
+ jabber? ( >=net-libs/loudmouth-0.15.1 )
+ xosd? ( x11-libs/xosd )
+ perl? ( dev-lang/perl dev-perl/XML-Parser )
+ >=net-im/ekg-1.4
+ arts? ( >=kde-base/arts-0.9.5 )
+ esd? ( media-sound/esound )
+ tlen? ( net-libs/libtlen )"
+
+src_compile() {
+
+ myconf="--with-gui --with-gadu --with-remote --with-docklet_system_tray --with-docklet_dockapp --with-sms --with-update --with-external"
+
+ econf ${myconf} \
+ `use_enable debug` \
+ `use_with oss` \
+ `use_with esd` \
+ `use_with xosd` \
+ `use_with arts` \
+ `use_enable perl` \
+ `use_with tlen` \
+ `use_with jabber` || die
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+