summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-03-16 09:14:41 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-03-16 09:14:41 +0000
commit9a7362148a69598d819be9c8237a6f8a1d515c67 (patch)
treef77d0f68c0d81b0a82b3419215f4519d648c0c08 /net-im
parentFix slot-deps on gtk+ and other libs (diff)
downloadgentoo-2-9a7362148a69598d819be9c8237a6f8a1d515c67.tar.gz
gentoo-2-9a7362148a69598d819be9c8237a6f8a1d515c67.tar.bz2
gentoo-2-9a7362148a69598d819be9c8237a6f8a1d515c67.zip
Version bump prosody to 0.7.0 (bug 323999).
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/prosody/ChangeLog10
-rw-r--r--net-im/prosody/files/prosody-0.7.0-cfg.lua.patch39
-rw-r--r--net-im/prosody/metadata.xml3
-rw-r--r--net-im/prosody/prosody-0.7.0.ebuild63
4 files changed, 113 insertions, 2 deletions
diff --git a/net-im/prosody/ChangeLog b/net-im/prosody/ChangeLog
index c5a0e6bc787c..18f8065e3eee 100644
--- a/net-im/prosody/ChangeLog
+++ b/net-im/prosody/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/prosody
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.7 2010/11/05 23:15:54 rafaelmartins Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.8 2011/03/16 09:14:41 djc Exp $
+
+*prosody-0.7.0 (16 Mar 2011)
+
+ 16 Mar 2011; Dirkjan Ochtman <djc@gentoo.org> +prosody-0.7.0.ebuild,
+ +files/prosody-0.7.0-cfg.lua.patch, metadata.xml:
+ Version bump to 0.7.0 (bug 323999).
05 Nov 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
prosody-0.6.2.ebuild:
diff --git a/net-im/prosody/files/prosody-0.7.0-cfg.lua.patch b/net-im/prosody/files/prosody-0.7.0-cfg.lua.patch
new file mode 100644
index 000000000000..68423f413f48
--- /dev/null
+++ b/net-im/prosody/files/prosody-0.7.0-cfg.lua.patch
@@ -0,0 +1,39 @@
+--- prosody.cfg.lua.old 2010-06-13 02:23:02.000000000 +0200
++++ prosody.cfg.lua.dist 2010-06-18 10:45:40.165045845 +0200
+@@ -16,6 +16,10 @@
+ -- Settings in this section apply to the whole server and are the default settings
+ -- for any virtual hosts
+
++prosody_user = "jabber"
++prosody_group = "jabber"
++pidfile = "/var/run/jabber/prosody.pid"
++
+ -- This is a (by default, empty) list of accounts that are admins
+ -- for the server. Note that you must create the accounts separately
+ -- (see http://prosody.im/doc/creating_accounts for info)
+@@ -26,6 +30,14 @@
+ -- For more information see: http://prosody.im/doc/libevent
+ --use_libevent = true;
+
++-- Enable the Cyrus SASL backend for authentication against different backends,
++-- such as PAM, LDAP, SQL and more.
++-- It also allows the use of GSSAPI for single-sign-on services.
++-- For more information see: http://prosody.im/doc/cyrus_sasl
++--sasl_backend = "cyrus"
++-- Optional, defaults to "xmpp"
++--cyrus_service_name = "xmpp"
++
+ -- This is the list of modules Prosody will load on startup.
+ -- It looks for mod_modulename.lua in the plugins folder, so make sure that exists too.
+ -- Documentation on modules can be found at: http://prosody.im/doc/modules
+@@ -90,7 +102,9 @@
+
+ -- Logging configuration
+ -- For advanced logging see http://prosody.im/doc/logging
+-log = "prosody.log";
++log = "/var/log/jabber/prosody.log"
++-- Requires mod_posix to be loaded
++-- log = "*syslog"
+ debug = false; -- Log debug messages?
+
+ ----------- Virtual hosts -----------
diff --git a/net-im/prosody/metadata.xml b/net-im/prosody/metadata.xml
index be02d466dcff..9b63785cf637 100644
--- a/net-im/prosody/metadata.xml
+++ b/net-im/prosody/metadata.xml
@@ -8,4 +8,7 @@
<maintainer>
<email>rafaelmartins@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name="libevent">Use libevent for event handling</flag>
+ </use>
</pkgmetadata>
diff --git a/net-im/prosody/prosody-0.7.0.ebuild b/net-im/prosody/prosody-0.7.0.ebuild
new file mode 100644
index 000000000000..96eb3edfb5f0
--- /dev/null
+++ b/net-im/prosody/prosody-0.7.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.7.0.ebuild,v 1.1 2011/03/16 09:14:40 djc Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs versionator
+
+MY_PV=$(replace_version_separator 3 '')
+DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua."
+HOMEPAGE="http://prosody.im/"
+SRC_URI="http://prosody.im/downloads/source/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libevent ssl"
+
+DEPEND="net-im/jabber-base
+ >=dev-lang/lua-5.1
+ dev-lua/luasocket
+ ssl? ( dev-lua/luasec )
+ dev-lua/luaexpat
+ dev-lua/luafilesystem
+ libevent? ( dev-lua/luaevent )
+ >=net-dns/libidn-1.1
+ >=dev-libs/openssl-0.9.8"
+RDEPEND="${DEPEND}"
+
+PROVIDE="virtual/jabber-server"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+JABBER_ETC="/etc/jabber"
+JABBER_SPOOL="/var/spool/jabber"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-cfg.lua.patch"
+ useq libevent && sed -i "s!--use_libevent.*!use_libevent = true!" prosody.cfg.lua.dist
+ sed -i "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!" Makefile
+ sed -i "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!" Makefile
+ sed -i "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = \$(PREFIX)/$(get_libdir)/!" Makefile
+ sed -i "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = \$(PREFIX)/$(get_libdir)/!" Makefile
+}
+
+src_configure() {
+ ./configure --prefix="/usr" \
+ --sysconfdir="${JABBER_ETC}" \
+ --datadir="${JABBER_SPOOL}" \
+ --with-lua-lib=/usr/$(get_libdir)/lua \
+ --c-compiler="$(tc-getCC)" --linker="$(tc-getLD)" \
+ --require-config || die "configure failed"
+}
+
+src_install() {
+ DESTDIR="${D}" emake install || die "make failed"
+ newinitd "${FILESDIR}/${PN}".initd ${PN}
+}
+
+src_test() {
+ cd tests
+ ./run_tests.sh
+}