summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-11-21 04:11:27 +0000
committerDon Seiler <rizzo@gentoo.org>2003-11-21 04:11:27 +0000
commit85463d91d4a59e98820ceeecfbfdfdddb9ea04a4 (patch)
treeb2c692feb8f765d53b0c9af5d3856a690120225e /net-im
parentRevision bump for MSN patches. Also new Mozilla/NSS detection logic (diff)
downloadgentoo-2-85463d91d4a59e98820ceeecfbfdfdddb9ea04a4.tar.gz
gentoo-2-85463d91d4a59e98820ceeecfbfdfdddb9ea04a4.tar.bz2
gentoo-2-85463d91d4a59e98820ceeecfbfdfdddb9ea04a4.zip
Revision bump for MSN patches. Also new Mozilla/NSS detection logic
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog8
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.72-r22
-rw-r--r--net-im/gaim/files/gaim-0.72-msn-fixes.patch37
-rw-r--r--net-im/gaim/gaim-0.72-r2.ebuild115
5 files changed, 163 insertions, 3 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 2814c119ba51..f77e5bacc69e 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.93 2003/11/19 22:09:46 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.94 2003/11/21 04:11:23 rizzo Exp $
+
+*gaim-0.72-r2 (20 Nov 2003)
+
+ 20 Nov 2003; Don Seiler <rizzo@gentoo.org>; gaim-0.72-r2.ebuild,
+ files/gaim-0.72-msn-fixes.patch:
+ Revision bump for MSN fixes and better NSS/NSPR/Mozilla logic
19 Nov 2003; Don Seiler <rizzo@gentoo.org>; gaim-0.72-r1.ebuild:
Marking 0.72-r1 stable for x86
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 8053e88ff090..a0830c43366e 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,11 +1,11 @@
MD5 bed467c3e7077888cf4fd615c5f47678 gaim-0.67.ebuild 2185
-MD5 15ac5d0de842b0dcd2f629cd3bb0658d gaim-0.72-r2.ebuild 3542
+MD5 9fcaa9353bfd5534a605056d0731f8aa gaim-0.72-r2.ebuild 3542
MD5 7f89f602fb6fe4954a39c6909cbf3333 gaim-0.71-r2.ebuild 2658
MD5 22b1f8bda98f0542ea455eb5b2f9955f gaim-0.72-r1.ebuild 2891
MD5 9319539d29d9fb3908789ccf6026d7db gaim-0.66-r3.ebuild 1991
MD5 9c060fe66488650173c0a493e8744b0a gaim-0.72.ebuild 2508
MD5 1a9b1940485519f26cffa675c833ca7d gaim-0.70-r2.ebuild 2506
-MD5 2f440c1b4bf8c9f2691b6e09aad4a4a3 ChangeLog 15928
+MD5 39b17d83242c85268bb712e7268d6cf2 ChangeLog 15928
MD5 19b3cafbbe380403d46cccc45a984b80 metadata.xml 481
MD5 5993641de8d56c2c433f252997c3c39c files/digest-gaim-0.67 135
MD5 e6a8773cabdf14d7422e573723258437 files/digest-gaim-0.72 135
diff --git a/net-im/gaim/files/digest-gaim-0.72-r2 b/net-im/gaim/files/digest-gaim-0.72-r2
new file mode 100644
index 000000000000..bd08cc5b99b3
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.72-r2
@@ -0,0 +1,2 @@
+MD5 2eb9478126ffc76b9a5f3cbf7cd82062 gaim-0.72.tar.bz2 3165345
+MD5 c7cea5b99b2e05f083db77032b0457d5 gaim-encryption-2.17.tar.gz 316928
diff --git a/net-im/gaim/files/gaim-0.72-msn-fixes.patch b/net-im/gaim/files/gaim-0.72-msn-fixes.patch
new file mode 100644
index 000000000000..8d5642cd59ec
--- /dev/null
+++ b/net-im/gaim/files/gaim-0.72-msn-fixes.patch
@@ -0,0 +1,37 @@
+diff -ruN gaim-0.72.orig/src/protocols/msn/msn.c gaim-0.72/src/protocols/msn/msn.c
+--- gaim-0.72.orig/src/protocols/msn/msn.c 2003-10-24 00:46:01.000000000 -0500
++++ gaim-0.72/src/protocols/msn/msn.c 2003-11-20 21:35:17.000000000 -0600
+@@ -854,6 +854,13 @@
+ }
+
+ gaim_privacy_permit_add(gc->account, who, TRUE);
++
++ g_snprintf(buf, sizeof(buf), "AL %s", who);
++
++ if (!msn_servconn_send_command(session->notification_conn, "ADD", buf)) {
++ gaim_connection_error(gc, _("Write error"));
++ return;
++ }
+ }
+
+ static void
+diff -ruN gaim-0.72.orig/src/protocols/msn/notification.c gaim-0.72/src/protocols/msn/notification.c
+--- gaim-0.72.orig/src/protocols/msn/notification.c 2003-10-30 16:27:36.000000000 -0600
++++ gaim-0.72/src/protocols/msn/notification.c 2003-11-20 21:36:40.000000000 -0600
+@@ -345,7 +345,7 @@
+ request_str = g_strdup_printf(
+ "GET %s HTTP/1.1\r\n"
+ "Authorization: Passport1.4 OrgVerb=GET,OrgURL=%s,sign-in=%s,pwd=%s,"
+- "lc=%s,id=%s,tw=%s,fs=%s,ct=%s,kpp=%s,kv=%s,ver=%s,tpf=%s\r\n"
++ "lc=%s,id=%s,tw=%s,fs=%s,ru=%s,ct=%s,kpp=%s,kv=%s,ver=%s,tpf=%s\r\n"
+ "User-Agent: MSMSGS\r\n"
+ "Host: %s\r\n"
+ "Connection: Keep-Alive\r\n"
+@@ -358,6 +358,7 @@
+ (char *)g_hash_table_lookup(session->ssl_challenge_data, "id"),
+ (char *)g_hash_table_lookup(session->ssl_challenge_data, "tw"),
+ (char *)g_hash_table_lookup(session->ssl_challenge_data, "fs"),
++ (char *)g_hash_table_lookup(session->ssl_challenge_data, "ru"),
+ (char *)g_hash_table_lookup(session->ssl_challenge_data, "ct"),
+ (char *)g_hash_table_lookup(session->ssl_challenge_data, "kpp"),
+ (char *)g_hash_table_lookup(session->ssl_challenge_data, "kv"),
diff --git a/net-im/gaim/gaim-0.72-r2.ebuild b/net-im/gaim/gaim-0.72-r2.ebuild
new file mode 100644
index 000000000000..dc3353e78dcd
--- /dev/null
+++ b/net-im/gaim/gaim-0.72-r2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.72-r2.ebuild,v 1.3 2003/11/21 04:11:23 rizzo Exp $
+
+IUSE="nls perl spell nas ssl cjk"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.17
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/gaim-encryption-${EV}.tar.gz )"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~sparc ~amd64"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1
+ >=sys-apps/sed-4.0.0 )
+ ( || ( dev-libs/nss
+ ( net-www/mozilla )
+ )
+ )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${A} || die
+ epatch ${FILESDIR}/gaim-0.72-msn-fixes.patch
+
+ use cjk && epatch ${FILESDIR}/gaim_cjk_gtkconv.patch
+
+ use ssl && {
+ cd ${S}/plugins
+ unpack gaim-encryption-${EV}.tar.gz
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ if has_version "net-www/mozilla"; then
+ NSS_LIB=/usr/lib/mozilla
+ NSS_INC=/usr/lib/mozilla/include
+ elif has_version "dev-libs/nspr"; then
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ else
+ # Not sure how this would happen with our current DEPEND setup
+ eerror "Neither net-www/mozilla nor dev-libs/nspr found."
+ die "Unexpected error. Unable to find nss/nspr"
+ fi
+
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+
+ econf ${myconf} || die "Configuration failed"
+ use perl && sed -i -e 's:^\(PERL_MM_PARAMS =.*PREFIX=\)\(.*\):\1'${D}'\2:' plugins/perl/Makefile
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+
+ use ssl && {
+ local myencconf
+ cd ${S}/plugins/gaim-encryption-${EV}
+
+ myencconf="${myencconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myencconf="${myencconf} --with-nss-includes=${NSS_INC}/nss"
+ myencconf="${myencconf} --with-nspr-libs=${NSS_LIB}"
+ myencconf="${myencconf} --with-nss-libs=${NSS_LIB}"
+ econf ${myencconf} || die "Configuration failed for encryption"
+ emake || die "Make failed for encryption"
+ }
+}
+
+src_install() {
+ einstall || die "Install failed"
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ einstall || die "Install failed for encryption"
+ cd ${S}
+ }
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ if [ `use cjk` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=cjk') to compile with"
+ ewarn "a patch for CJK support. Please be aware that this patch"
+ ewarn "causes problems with skkinput. kinput2 works fine. Details"
+ ewarn "can be found at http://bugs.gentoo.org/show_bug.cgi?id=24657#c23"
+ ewarn
+ fi
+
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ fi
+}