summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAlex Veber <coronalvr@gentoo.org>2003-07-25 17:47:53 +0000
committerAlex Veber <coronalvr@gentoo.org>2003-07-25 17:47:53 +0000
commit68522ab790caed959251b30c5f70a64db5730b50 (patch)
tree9a8b29c1cda129c429a0bcff422397a284a531b6 /net-im
parentfribidi support (diff)
downloadgentoo-2-68522ab790caed959251b30c5f70a64db5730b50.tar.gz
gentoo-2-68522ab790caed959251b30c5f70a64db5730b50.tar.bz2
gentoo-2-68522ab790caed959251b30c5f70a64db5730b50.zip
fribidi support
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/ChangeLog7
-rw-r--r--net-im/centericq/Manifest4
-rw-r--r--net-im/centericq/centericq-4.9.5-r1.ebuild58
-rw-r--r--net-im/centericq/files/digest-centericq-4.9.5-r11
4 files changed, 67 insertions, 3 deletions
diff --git a/net-im/centericq/ChangeLog b/net-im/centericq/ChangeLog
index 77fa41fde399..b409b2b7215c 100644
--- a/net-im/centericq/ChangeLog
+++ b/net-im/centericq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/centericq
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/centericq/ChangeLog,v 1.22 2003/07/16 06:01:06 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/centericq/ChangeLog,v 1.23 2003/07/25 17:47:38 coronalvr Exp $
+
+*centericq-4.9.5-r1 (25 Jul 2003)
+
+ 25 Jul 2003; coronalvr <coronalvr@gentoo.org> centericq-4.9.5-r1.ebuild:
+ added fribidi support
*centericq-4.9.5 (16 Jul 2003)
diff --git a/net-im/centericq/Manifest b/net-im/centericq/Manifest
index ec901c417c58..db387b49aed7 100644
--- a/net-im/centericq/Manifest
+++ b/net-im/centericq/Manifest
@@ -1,8 +1,8 @@
MD5 a647326544cbcbff451928d34d839762 centericq-4.9.5.ebuild 1481
MD5 53c1e711c5751f999a092ad3e0ea25d1 centericq-4.9.2.ebuild 900
-MD5 9eb031e2ca0e737c9102180a444343a6 centericq-4.9.5-r1.ebuild 1556
+MD5 35c5266702ac6df51be0a53f67cc615e centericq-4.9.5-r1.ebuild 1563
MD5 1df689d403dd6bd34be444f9cf625f98 centericq-4.9.4.ebuild 898
-MD5 aa9cd6be613310fec801d73f5e65bd43 ChangeLog 3617
+MD5 efeb82a183abe52c3a041f819ddddbe2 ChangeLog 3756
MD5 c1ac500e020c9d6a530191e1187bcca6 files/digest-centericq-4.9.2 68
MD5 a5a5c7ea33197ccca36feee6b923b504 files/digest-centericq-4.9.4 68
MD5 6086e6257164cf0ad32293134961cdba files/digest-centericq-4.9.5 68
diff --git a/net-im/centericq/centericq-4.9.5-r1.ebuild b/net-im/centericq/centericq-4.9.5-r1.ebuild
new file mode 100644
index 000000000000..3df06e182857
--- /dev/null
+++ b/net-im/centericq/centericq-4.9.5-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/centericq/centericq-4.9.5-r1.ebuild,v 1.1 2003/07/25 17:47:39 coronalvr Exp $
+
+inherit eutils
+
+IUSE="nls ssl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A ncurses ICQ/Yahoo!/MSN/IRC/Jabber Client"
+SRC_URI="http://konst.org.ua/download/${P}.tar.gz"
+HOMEPAGE="http://konst.org.ua/eng/software/centericq/info.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ =dev-libs/libsigc++-1.0*
+ =dev-libs/glib-1.2*
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ nls? ( dev-libs/fribidi )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/missing_namespace.patch
+}
+
+src_compile() {
+ # Options you can add to myopts
+ # --disable-msn Build without MSN
+ # --disable-yahoo Build without Yahoo!
+ # --disable-aim Build without AIM
+ # --disable-irc Build without IRC
+ # --disable-jabber Build without Jabber
+ # --disable-rss Build without RSS reader
+ # --no-konst Don't add contact list items
+ # supplied by author by default
+ local myopts="--with-gnu-ld"
+
+ use nls || myopts="${myopts} --disable-nls"
+
+ use nls && myopts="${myopts} --with-fribidi"
+
+ use ssl && myopts="${myopts} --with-ssl"
+
+ econf ${myopts} || die "Configure failed"
+ emake || die "Compilation failed"
+}
+
+src_install () {
+ einstall || die "Installation failed"
+
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING FAQ README THANKS TODO
+}
diff --git a/net-im/centericq/files/digest-centericq-4.9.5-r1 b/net-im/centericq/files/digest-centericq-4.9.5-r1
new file mode 100644
index 000000000000..113cd8800d49
--- /dev/null
+++ b/net-im/centericq/files/digest-centericq-4.9.5-r1
@@ -0,0 +1 @@
+MD5 3c377af2fc9dacfc4bea23655f173b3b centericq-4.9.5.tar.gz 1325550