summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-03-17 19:50:00 +0000
committerMichael Januszewski <spock@gentoo.org>2004-03-17 19:50:00 +0000
commit59c36831ffa3e27a1c4970356659e68a5cc2db8e (patch)
treec1628b89843436ccf253e85695ff0a8b3cb274b7 /net-im
parenttidy (Manifest recommit) (diff)
downloadgentoo-2-59c36831ffa3e27a1c4970356659e68a5cc2db8e.tar.gz
gentoo-2-59c36831ffa3e27a1c4970356659e68a5cc2db8e.tar.bz2
gentoo-2-59c36831ffa3e27a1c4970356659e68a5cc2db8e.zip
Fixed Perl support, added preliminary support for gtkspell.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gnugadu/ChangeLog5
-rw-r--r--net-im/gnugadu/gnugadu-2.0_pre8.ebuild12
2 files changed, 12 insertions, 5 deletions
diff --git a/net-im/gnugadu/ChangeLog b/net-im/gnugadu/ChangeLog
index 77fe427bd9bb..a8e811c1426b 100644
--- a/net-im/gnugadu/ChangeLog
+++ b/net-im/gnugadu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/gnugadu
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.3 2004/03/17 16:03:05 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.4 2004/03/17 19:50:00 spock Exp $
+
+ 17 Mar 2004; Michal Januszewski <spock@gentoo.org> gnugadu-2.0_pre8.ebuild:
+ Fixed Perl support, added preliminary support for gtkspell.
*gnugadu-2.0_pre8 (17 Mar 2004)
diff --git a/net-im/gnugadu/gnugadu-2.0_pre8.ebuild b/net-im/gnugadu/gnugadu-2.0_pre8.ebuild
index b1edb407ec06..7a183edb0ab1 100644
--- a/net-im/gnugadu/gnugadu-2.0_pre8.ebuild
+++ b/net-im/gnugadu/gnugadu-2.0_pre8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0_pre8.ebuild,v 1.1 2004/03/17 16:03:05 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0_pre8.ebuild,v 1.2 2004/03/17 19:50:00 spock Exp $
-IUSE="debug tlen esd oss xosd arts jabber perl"
+IUSE="debug tlen esd oss xosd arts jabber perl spell"
MY_P="gg2-2.0pre8"
S="${WORKDIR}/${MY_P}"
@@ -24,19 +24,23 @@ DEPEND=">=x11-libs/gtk+-2.2.0
>=net-im/ekg-1.4
arts? ( >=kde-base/arts-0.9.5 )
esd? ( media-sound/esound )
- tlen? ( net-libs/libtlen )"
+ tlen? ( net-libs/libtlen )
+ spell? ( app-text/gtkspell )"
src_compile() {
myconf="--with-gui --with-gadu --with-remote --with-docklet_system_tray --with-docklet_dockapp --with-sms --with-update --with-external"
+ # we don't use this just yet as it appears to be somewhat broken
+ # use spell && myconf="${myconf} --with-gtkspell"
+
econf ${myconf} \
`use_enable debug` \
`use_with oss` \
`use_with esd` \
`use_with xosd` \
`use_with arts` \
- `use_enable perl` \
+ `use_with perl` \
`use_with tlen` \
`use_with jabber` || die
emake || die