summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPavlos Ratis <dastergon@gentoo.org>2012-11-22 00:56:46 +0000
committerPavlos Ratis <dastergon@gentoo.org>2012-11-22 00:56:46 +0000
commit552448ff9c05d278283d61dc86e2ac8d0cb8da6d (patch)
treec0d44d5042863498064ca5707164b235a2ccfb6f /net-im
parentAdd RESTRICT="test": The "testing" subdirectory needed for tests is only pres... (diff)
downloadgentoo-2-552448ff9c05d278283d61dc86e2ac8d0cb8da6d.tar.gz
gentoo-2-552448ff9c05d278283d61dc86e2ac8d0cb8da6d.tar.bz2
gentoo-2-552448ff9c05d278283d61dc86e2ac8d0cb8da6d.zip
Version bump KDE Telepathy 0.5.1
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0x3A051746)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ktp-text-ui/ChangeLog7
-rw-r--r--net-im/ktp-text-ui/ktp-text-ui-0.5.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-im/ktp-text-ui/ChangeLog b/net-im/ktp-text-ui/ChangeLog
index 327daf00bbeb..c988c1813931 100644
--- a/net-im/ktp-text-ui/ChangeLog
+++ b/net-im/ktp-text-ui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/ktp-text-ui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-text-ui/ChangeLog,v 1.9 2012/08/28 12:27:49 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-text-ui/ChangeLog,v 1.10 2012/11/22 00:56:46 dastergon Exp $
+
+*ktp-text-ui-0.5.1 (22 Nov 2012)
+
+ 22 Nov 2012; Pavlos Ratis <dastergon@gentoo.org> +ktp-text-ui-0.5.1.ebuild:
+ Version bump KDE Telepathy 0.5.1
28 Aug 2012; Johannes Huber <johu@gentoo.org> -ktp-text-ui-0.4.0.ebuild,
-ktp-text-ui-0.4.0-r1.ebuild,
diff --git a/net-im/ktp-text-ui/ktp-text-ui-0.5.1.ebuild b/net-im/ktp-text-ui/ktp-text-ui-0.5.1.ebuild
new file mode 100644
index 000000000000..18ec8b84e26b
--- /dev/null
+++ b/net-im/ktp-text-ui/ktp-text-ui-0.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-text-ui/ktp-text-ui-0.5.1.ebuild,v 1.1 2012/11/22 00:56:46 dastergon Exp $
+
+EAPI=4
+
+KDE_LINGUAS="ca cs da de el es et fi fr ga gl hu it ja km lt nb nds nl pl pt
+pt_BR sk sr sr@ijekavian sr@ijekavianlatin sr@latin sv ug uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="KDE Telepathy text chat window"
+HOMEPAGE="http://community.kde.org/Real-Time_Communication_and_Collaboration"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://kde/unstable/kde-telepathy/${PV}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug +history"
+
+DEPEND="
+ >=net-libs/telepathy-qt-0.9.3
+ history? ( >=net-libs/telepathy-logger-qt-0.5.0 )
+"
+RDEPEND="${DEPEND}
+ >=net-im/ktp-contact-list-${PV}
+"
+
+RESTRICT="test"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with history TelepathyLoggerQt4)
+ )
+
+ cmake-utils_src_configure
+}