summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-14 15:22:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-14 15:22:57 +0000
commit507676abb6408d84fb598866440ee374951f16c7 (patch)
tree6cf99b11f4eea3ae75acf871b1e79664d0f6a137 /net-im
parentRESTRICT test phase for latest stable too; bug 118106 (diff)
downloadgentoo-2-507676abb6408d84fb598866440ee374951f16c7.tar.gz
gentoo-2-507676abb6408d84fb598866440ee374951f16c7.tar.bz2
gentoo-2-507676abb6408d84fb598866440ee374951f16c7.zip
Version bump, removing old version and related patches (all merged in latest version).
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kopete/ChangeLog11
-rw-r--r--net-im/kopete/files/digest-kopete-0.12.13
-rw-r--r--net-im/kopete/kopete-0.12.1.ebuild123
3 files changed, 136 insertions, 1 deletions
diff --git a/net-im/kopete/ChangeLog b/net-im/kopete/ChangeLog
index c0f07f055585..3a61bbb26d41 100644
--- a/net-im/kopete/ChangeLog
+++ b/net-im/kopete/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-im/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.70 2006/07/13 17:12:09 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.71 2006/07/14 15:22:57 flameeyes Exp $
+
+*kopete-0.12.1 (14 Jul 2006)
+
+ 14 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/kopete-0.12-icqfix2.patch, -files/kopete-0.12-away.diff,
+ -files/kopete-0.12-icqfix.patch, -files/kopete-0.12-jabber-muc-chat.patch,
+ -kopete-0.12.0-r3.ebuild, +kopete-0.12.1.ebuild:
+ Version bump, removing old version and related patches (all merged in latest
+ version).
*kopete-0.12.0-r3 (13 Jul 2006)
diff --git a/net-im/kopete/files/digest-kopete-0.12.1 b/net-im/kopete/files/digest-kopete-0.12.1
new file mode 100644
index 000000000000..2f6f75f34afa
--- /dev/null
+++ b/net-im/kopete/files/digest-kopete-0.12.1
@@ -0,0 +1,3 @@
+MD5 b646f2f45fc0fbcd56ada5078fb540fb kopete-0.12.1.tar.bz2 5309636
+RMD160 0bb66fb0a8a0d12b0d19845d5a39993520cb368d kopete-0.12.1.tar.bz2 5309636
+SHA256 a18174bf48257361c6a337073e2fa1c7dc0b0eba274d558ac9fd5bc84275927e kopete-0.12.1.tar.bz2 5309636
diff --git a/net-im/kopete/kopete-0.12.1.ebuild b/net-im/kopete/kopete-0.12.1.ebuild
new file mode 100644
index 000000000000..80a265c2f8f5
--- /dev/null
+++ b/net-im/kopete/kopete-0.12.1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/kopete-0.12.1.ebuild,v 1.1 2006/07/14 15:22:57 flameeyes Exp $
+
+inherit kde eutils
+
+MY_P="${P/_/-}"
+MY_P="${MY_P/.0/}"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="jingle sametime ssl xmms xscreensaver slp kernel_linux latex crypt
+ winpopup sms irc yahoo gadu groupwise netmeeting statistics autoreplace
+ connectionstatus contactnotes translator webpresence texteffect highlight
+ alias autoreplace history nowlistening addbookmarks"
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ slp? ( net-libs/openslp )
+ jingle? (
+ >=media-libs/speex-1.1.6
+ dev-libs/expat
+ ~net-libs/ortp-0.7.1 )
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ ) <virtual/x11-7 )
+ kernel_linux? ( virtual/opengl )
+ sms? ( app-mobilephone/gsmlib )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )
+ !kde-base/kopete
+ !kde-base/kdenetwork
+ !net-libs/libjingle
+ latex? ( app-text/tetex )
+ crypt? ( app-crypt/gnupg )
+ netmeeting? ( net-im/gnomemeeting )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ xscreensaver? ( x11-proto/scrnsaverproto )
+ ) <virtual/x11-7 )"
+
+need-kde 3.4
+
+#dev-libs/ilbc-rfc3951: could not see any benifit in it
+#sed -i 's:ilbc_found="no":ilbc_found="yes":' ${S}/kopete/protocols/jabber/jingle/configure.in.in
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+kopete_disable() {
+ einfo "Disabling $2 $1"
+ sed -i -e "s/$2//" "${S}/kopete/$1s/Makefile.am"
+}
+
+src_unpack() {
+ kde_src_unpack
+ epatch "${FILESDIR}/${PN}-0.12_alpha1-xscreensaver.patch"
+
+ use latex || kopete_disable plugin latex
+ use crypt || kopete_disable plugin cryptography
+ use netmeeting || kopete_disable plugin netmeeting
+ use statistics || kopete_disable plugin statistics
+ use autoreplace || kopete_disable plugin autoreplace
+ use connectionstatus || kopete_disable plugin connectionstatus
+ use contactnotes || kopete_disable plugin contactnotes
+ use translator || kopete_disable plugin translator
+ use webpresence || kopete_disable plugin webpresence
+ use texteffect || kopete_disable plugin texteffect
+ use highlight || kopete_disable plugin highlight
+ use alias || kopete_disable plugin alias
+ use addbookmarks || kopete_disable plugin addbookmarks
+ use history || kopete_disable plugin history
+ use nowlistening || kopete_disable plugin nowlistening
+
+ use winpopup || kopete_disable protocol winpopup
+ use gadu || kopete_disable protocol '\$(GADU)'
+ use irc || kopete_disable protocol irc
+ use groupwise || kopete_disable protocol groupwise
+ use yahoo || kopete_disable protocol yahoo
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable jingle)
+ $(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu
+ $(use_with xscreensaver) $(use_enable sms smsgsm)
+ $(use_enable debug testbed)"
+
+ kde_src_compile
+}