summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:44:35 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:44:35 +0000
commit4e2cf4a1cedeedb21c2fb71fdee5578ad87976e2 (patch)
treeb230b68d61e0c76832b280f4dfd2da88d20cb204 /net-im
parentInitial ebuild required by gnome-photos and gnome-online-miners. (diff)
downloadgentoo-2-4e2cf4a1cedeedb21c2fb71fdee5578ad87976e2.tar.gz
gentoo-2-4e2cf4a1cedeedb21c2fb71fdee5578ad87976e2.tar.bz2
gentoo-2-4e2cf4a1cedeedb21c2fb71fdee5578ad87976e2.zip
Version bump for Gnome>=3.10. Add uper limit to upower dependency since it will fail to build with 0.99 but this version is required in Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telepathy-mission-control/ChangeLog9
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-5.16.1.ebuild51
2 files changed, 59 insertions, 1 deletions
diff --git a/net-im/telepathy-mission-control/ChangeLog b/net-im/telepathy-mission-control/ChangeLog
index 0237d74d1ed5..c16e11fb2da7 100644
--- a/net-im/telepathy-mission-control/ChangeLog
+++ b/net-im/telepathy-mission-control/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/telepathy-mission-control
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/ChangeLog,v 1.96 2014/02/22 22:23:01 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/ChangeLog,v 1.97 2014/04/27 17:44:35 eva Exp $
+
+*telepathy-mission-control-5.16.1 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +telepathy-mission-control-5.16.1.ebuild:
+ Version bump for Gnome>=3.10. Add uper limit to upower dependency since it
+ will fail to build with 0.99 but this version is required in Gnome 3.12.
22 Feb 2014; Pacho Ramos <pacho@gentoo.org>
telepathy-mission-control-5.14.1.ebuild:
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-5.16.1.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.1.ebuild
new file mode 100644
index 000000000000..4013336706b0
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/telepathy-mission-control-5.16.1.ebuild,v 1.1 2014/04/27 17:44:35 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+# Needed for tests and build #489466
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="An account manager and channel dispatcher for the Telepathy framework"
+HOMEPAGE="http://cgit.freedesktop.org/telepathy/telepathy-mission-control/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="debug networkmanager +upower" # test
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.82
+ >=dev-libs/glib-2.32:2
+ >=sys-apps/dbus-0.95
+ >=net-libs/telepathy-glib-0.20
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ upower? (
+ >=sys-power/upower-0.9.11
+ <sys-power/upower-0.99 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.17
+ virtual/pkgconfig
+"
+# test? ( dev-python/twisted-words )"
+
+# Tests are broken, see upstream bug #29334 and #64212
+# upstream doesn't want it enabled everywhere (#29334#c12)
+RESTRICT="test"
+
+src_configure() {
+ # creds is not available
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_with networkmanager connectivity nm) \
+ $(use_enable upower)
+}