summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-04-29 16:08:39 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-04-29 16:08:39 +0000
commit8c36b231b6eab7aec141f36c6f4230431d9b24cd (patch)
tree06829a877de5bc634d58f2acc99312b5408602d5 /net-im/vacuum/vacuum-1.1.0.ebuild
parentRespect user CFLAGS, fix compilation error on x86 platforms. (diff)
downloadgentoo-2-8c36b231b6eab7aec141f36c6f4230431d9b24cd.tar.gz
gentoo-2-8c36b231b6eab7aec141f36c6f4230431d9b24cd.tar.bz2
gentoo-2-8c36b231b6eab7aec141f36c6f4230431d9b24cd.zip
Add net-im/vacuum, #296004
(Portage version: 2.1.9.45/cvs/Linux i686)
Diffstat (limited to 'net-im/vacuum/vacuum-1.1.0.ebuild')
-rw-r--r--net-im/vacuum/vacuum-1.1.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-im/vacuum/vacuum-1.1.0.ebuild b/net-im/vacuum/vacuum-1.1.0.ebuild
new file mode 100644
index 000000000000..197c08620a7f
--- /dev/null
+++ b/net-im/vacuum/vacuum-1.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-1.1.0.ebuild,v 1.1 2011/04/29 16:08:39 maksbotan Exp $
+
+EAPI="4"
+LANGS="de pl ru uk"
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Crossplatform Jabber client."
+HOMEPAGE="http://code.google.com/p/vacuum-im"
+SRC_URI="http://vacuum-im.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+PLUGINS=" adiummessagestyle annotations autostatus avatars bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rostersearch servicediscovery sessionnegotiation socksstreams vcard xmppuriqueries"
+IUSE="${PLUGINS// / +}"
+for x in ${LANGS}; do
+ IUSE+=" linguas_${x}"
+done
+
+REQUIRED_USE="
+ annotations? ( privatestorage )
+ avatars? ( vcard )
+ bookmarks? ( privatestorage )
+ captchaforms? ( dataforms )
+ commands? ( dataforms )
+ datastreamsmanager? ( dataforms )
+ filestreamsmanager? ( datastreamsmanager )
+ filetransfer? ( filestreamsmanager datastreamsmanager )
+ pepmanager? ( servicediscovery )
+ registration? ( dataforms )
+ remotecontrol? ( commands dataforms )
+ sessionnegotiation? ( dataforms )"
+
+RDEPEND="
+ >=x11-libs/qt-core-4.5:4[ssl]
+ >=x11-libs/qt-gui-4.5:4
+ >=dev-libs/openssl-0.9.8k
+ adiummessagestyle? ( >=x11-libs/qt-webkit-4.5:4 )
+ x11-libs/libXScrnSaver"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS CHANGELOG README TRANSLATORS"
+
+src_configure() {
+ # linguas
+ local langs="none;"
+ for x in ${LANGS}; do
+ use linguas_${x} && langs+="${x};"
+ done
+
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="$(get_libdir)"
+ -DINSTALL_SDK=ON
+ -DLANGS="${langs}"
+ -DINSTALL_DOCS=OFF
+ )
+
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( "$(cmake-utils_use ${x} PLUGIN_${x})" )
+ done
+
+ cmake-utils_src_configure
+}