summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-05-22 17:37:22 +0000
committerMamoru Komachi <usata@gentoo.org>2005-05-22 17:37:22 +0000
commit59fd26bae93c352f5e1827c98efd44b107b1532f (patch)
tree006368e35b411b05fa0d55915a968f8df9ae49f8 /net-im/micq/micq-0.5.0.3.ebuild
parentStable on hppa. (diff)
downloadgentoo-2-59fd26bae93c352f5e1827c98efd44b107b1532f.tar.gz
gentoo-2-59fd26bae93c352f5e1827c98efd44b107b1532f.tar.bz2
gentoo-2-59fd26bae93c352f5e1827c98efd44b107b1532f.zip
Version bumped.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-im/micq/micq-0.5.0.3.ebuild')
-rw-r--r--net-im/micq/micq-0.5.0.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-im/micq/micq-0.5.0.3.ebuild b/net-im/micq/micq-0.5.0.3.ebuild
new file mode 100644
index 000000000000..1e4175db16cc
--- /dev/null
+++ b/net-im/micq/micq-0.5.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/micq/micq-0.5.0.3.ebuild,v 1.1 2005/05/22 17:37:22 usata Exp $
+
+IUSE="tcltk ssl"
+
+SRC_URI="ftp://www.micq.org/pub/micq/source/${P}.tgz
+ http://www.micq.org/source/${P}.tgz"
+DESCRIPTION="ICQ text-mode client with many features"
+HOMEPAGE="http://www.micq.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc ~amd64"
+DEPEND="virtual/libc
+ ssl? ( >=net-libs/gnutls-0.8.10
+ dev-libs/openssl )
+ tcltk? ( dev-lang/tcl )"
+
+src_compile() {
+
+ econf $(use_enable tcltk tcl) \
+ $(use_enable ssl) \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING AUTHORS ChangeLog FAQ INSTALL NEWS README TODO
+}