summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-21 00:08:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-21 00:08:50 +0000
commit86b556f613665463b9195aa848f50e14278b0d59 (patch)
treeb60201621cdf5810f684577a731948f120a7c893 /net-im/ekiga
parentadding quotes for ${D} (although it should never need it) (diff)
downloadgentoo-2-86b556f613665463b9195aa848f50e14278b0d59.tar.gz
gentoo-2-86b556f613665463b9195aa848f50e14278b0d59.tar.bz2
gentoo-2-86b556f613665463b9195aa848f50e14278b0d59.zip
bump to 2.0.12 and cleanup dependencies
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-im/ekiga')
-rw-r--r--net-im/ekiga/ChangeLog10
-rw-r--r--net-im/ekiga/ekiga-2.0.12.ebuild88
-rw-r--r--net-im/ekiga/files/ekiga-2.0.12-gdu.patch111
3 files changed, 207 insertions, 2 deletions
diff --git a/net-im/ekiga/ChangeLog b/net-im/ekiga/ChangeLog
index e0f9416230ad..a5d87817b586 100644
--- a/net-im/ekiga/ChangeLog
+++ b/net-im/ekiga/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/ekiga
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekiga/ChangeLog,v 1.51 2007/11/21 07:02:19 mr_bones_ Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekiga/ChangeLog,v 1.52 2008/03/21 00:08:50 eva Exp $
+
+*ekiga-2.0.12 (20 Mar 2008)
+
+ 20 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/ekiga-2.0.12-gdu.patch, +ekiga-2.0.12.ebuild:
+ bump to 2.0.12, cleanup dependencies
21 Nov 2007; Michael Sterrett <mr_bones_@gentoo.org> -ekiga-2.0.7.ebuild,
-ekiga-2.0.9.ebuild:
diff --git a/net-im/ekiga/ekiga-2.0.12.ebuild b/net-im/ekiga/ekiga-2.0.12.ebuild
new file mode 100644
index 000000000000..5ac3d1a8267b
--- /dev/null
+++ b/net-im/ekiga/ekiga-2.0.12.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekiga/ekiga-2.0.12.ebuild,v 1.1 2008/03/21 00:08:50 eva Exp $
+
+inherit gnome2 eutils flag-o-matic
+
+DESCRIPTION="H.323 and SIP VoIP softphone"
+HOMEPAGE="http://www.ekiga.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="avahi dbus doc gnome sdl"
+
+RDEPEND="~dev-libs/pwlib-1.10.$[${PV##*.}-2]
+ ~net-libs/opal-2.2.$[${PV##*.}-1]
+ >=x11-libs/gtk+-2.4.0
+ >=dev-libs/glib-2.0.0
+ sdl? ( >=media-libs/libsdl-1.2.4 )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ avahi? ( net-dns/avahi )
+ gnome? (
+ >=gnome-base/libbonobo-2.2.0
+ >=gnome-base/libgnomeui-2.2.0
+ >=gnome-base/libgnome-2.2.0
+ >=gnome-base/gconf-2.2.0
+ >=gnome-base/orbit-2.5.0
+ gnome-extra/evolution-data-server
+ >=media-sound/esound-0.2.28 )"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.20
+ gnome? ( app-text/scrollkeeper
+ doc? ( app-text/gnome-doc-utils ) )"
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/pwlib ldap; then
+ eerror "You need to build dev-libs/pwlib with USE=ldap enabled."
+ die "Pwlib w/o ldap-support detected."
+ fi
+
+ if use avahi && ! built_with_use net-dns/avahi dbus; then
+ eerror "You need to build net-dns/avahi with USE=dbus enabled."
+ die "Avahi without dbus-support detected."
+ fi
+
+ G2CONF="${G2CONF}
+ $(use_enable dbus)
+ $(use_enable sdl)
+ $(use_enable avahi)
+ $(use_enable doc)
+ $(use_enable gnome)
+ --disable-scrollkeeper"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix configure to install schemafile into the proper directory
+ epatch "${FILESDIR}"/${PN}-1.99.0-configure.patch
+
+ # Fix gnome-doc-utils detection
+ epatch "${FILESDIR}"/${P}-gdu.patch
+}
+
+src_install() {
+ if use gnome; then
+ gnome2_src_install
+ else
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ${DOCS}
+ fi
+}
+
+pkg_postinst() {
+ if use gnome; then
+ gnome2_pkg_postinst
+
+ # we need to fix the GConf permissions, see bug #59764
+ einfo "Fixing GConf permissions for ekiga"
+ ekiga-config-tool --fix-permissions
+ fi
+}
diff --git a/net-im/ekiga/files/ekiga-2.0.12-gdu.patch b/net-im/ekiga/files/ekiga-2.0.12-gdu.patch
new file mode 100644
index 000000000000..2f6d8b47568f
--- /dev/null
+++ b/net-im/ekiga/files/ekiga-2.0.12-gdu.patch
@@ -0,0 +1,111 @@
+--- configure.in 2008-03-12 21:20:29.925476633 +0000
++++ configure.in 2008-03-12 21:22:29.000000000 +0000
+@@ -60,8 +60,8 @@
+ if test ${enable_gnome} = yes && test ${enable_doc} = yes; then
+ GNOME_DOC_INIT
+ else
+-ENABLE_SK_TRUE="#"
+-ENABLE_SK_FALSE=""
++dnl Do not care if GDU is not found
++GNOME_DOC_INIT(,,[:])
+ fi
+
+ AM_CONDITIONAL(DISABLE_DOC, test ${enable_doc} = no)
+--- configure 2008-03-21 00:47:35.000000000 +0100
++++ configure 2008-03-21 00:47:48.000000000 +0100
+@@ -2968,8 +2966,93 @@
+
+
+ else
+-ENABLE_SK_TRUE="#"
+-ENABLE_SK_FALSE=""
++
++gdu_cv_version_required=0.3.2
++
++if test -n "$PKG_CONFIG" && \
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gnome-doc-utils >= \$gdu_cv_version_required\"") >&5
++ ($PKG_CONFIG --exists --print-errors "gnome-doc-utils >= $gdu_cv_version_required") 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; then
++ gdu_cv_have_gdu=yes
++else
++ gdu_cv_have_gdu=no
++fi
++
++if test "$gdu_cv_have_gdu" = "yes"; then
++ :
++else
++ :
++fi
++
++
++
++# Check whether --with-help-dir was given.
++if test "${with_help_dir+set}" = set; then
++ withval=$with_help_dir;
++else
++ with_help_dir='${datadir}/gnome/help'
++fi
++
++HELP_DIR="$with_help_dir"
++
++
++
++# Check whether --with-omf-dir was given.
++if test "${with_omf_dir+set}" = set; then
++ withval=$with_omf_dir;
++else
++ with_omf_dir='${datadir}/omf'
++fi
++
++OMF_DIR="$with_omf_dir"
++
++
++
++# Check whether --with-help-formats was given.
++if test "${with_help_formats+set}" = set; then
++ withval=$with_help_formats;
++else
++ with_help_formats=''
++fi
++
++DOC_USER_FORMATS="$with_help_formats"
++
++
++# Check whether --enable-scrollkeeper was given.
++if test "${enable_scrollkeeper+set}" = set; then
++ enableval=$enable_scrollkeeper;
++else
++ enable_scrollkeeper=yes
++fi
++
++
++
++if test "$gdu_cv_have_gdu" = "yes" -a "$enable_scrollkeeper" = "yes"; then
++ ENABLE_SK_TRUE=
++ ENABLE_SK_FALSE='#'
++else
++ ENABLE_SK_TRUE='#'
++ ENABLE_SK_FALSE=
++fi
++
++
++DISTCHECK_CONFIGURE_FLAGS="--disable-scrollkeeper $DISTCHECK_CONFIGURE_FLAGS"
++
++
++
++
++if test "$gdu_cv_have_gdu" = "yes"; then
++ HAVE_GNOME_DOC_UTILS_TRUE=
++ HAVE_GNOME_DOC_UTILS_FALSE='#'
++else
++ HAVE_GNOME_DOC_UTILS_TRUE='#'
++ HAVE_GNOME_DOC_UTILS_FALSE=
++fi
++
++
++
+ fi
+
+