summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-05-05 09:30:14 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-05-05 09:30:14 +0000
commitf462b7f06738179a806ddd2b51c99e5b0d00c16b (patch)
tree8378e9efc7aa45140fd1526dc05667353d2bfdb2 /net-ftp
parentVersion bump. (diff)
downloadgentoo-2-f462b7f06738179a806ddd2b51c99e5b0d00c16b.tar.gz
gentoo-2-f462b7f06738179a806ddd2b51c99e5b0d00c16b.tar.bz2
gentoo-2-f462b7f06738179a806ddd2b51c99e5b0d00c16b.zip
patch from upstream to prevent compile failure when USE=-ssl is selected
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog6
-rw-r--r--net-ftp/lftp/files/lftp-3.4.6-nossl.patch22
-rw-r--r--net-ftp/lftp/lftp-3.4.6.ebuild10
3 files changed, 36 insertions, 2 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index c120c038970d..93170d3adaea 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.99 2006/04/25 22:24:48 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.100 2006/05/05 09:30:14 dragonheart Exp $
+
+ 05 May 2006; Daniel Black <dragonheart@gentoo.org>
+ +files/lftp-3.4.6-nossl.patch, lftp-3.4.6.ebuild:
+ patch from upstream to prevent compile failure when USE=-ssl is selected
*lftp-3.4.6 (25 Apr 2006)
diff --git a/net-ftp/lftp/files/lftp-3.4.6-nossl.patch b/net-ftp/lftp/files/lftp-3.4.6-nossl.patch
new file mode 100644
index 000000000000..e92eee006a6c
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-3.4.6-nossl.patch
@@ -0,0 +1,22 @@
+Index: ftpclass.cc
+===================================================================
+RCS file: /home/lav/cvsroot/lftp/src/ftpclass.cc,v
+retrieving revision 1.380
+diff -u -p -r1.380 ftpclass.cc
+--- ftpclass.cc 24 Apr 2006 10:24:18 -0000 1.380
++++ ftpclass.cc 3 May 2006 07:48:47 -0000
+@@ -1326,12 +1326,14 @@ int Ftp::Do()
+ goto usual_return;
+
+ pre_CONNECTED_STATE:
++#if USE_SSL
+ if(ftps && (!proxy || conn->proxy_is_http))
+ {
+ conn->MakeSSLBuffers(hostname);
+ const char *initial_prot=ResMgr::Query("ftps:initial-prot",hostname);
+ conn->prot=initial_prot[0];
+ }
++#endif
+ if(use_telnet_iac)
+ conn->InitTelnetLayer();
+
diff --git a/net-ftp/lftp/lftp-3.4.6.ebuild b/net-ftp/lftp/lftp-3.4.6.ebuild
index 1f093b7b10ff..fead34127b33 100644
--- a/net-ftp/lftp/lftp-3.4.6.ebuild
+++ b/net-ftp/lftp/lftp-3.4.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.4.6.ebuild,v 1.1 2006/04/25 22:24:49 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.4.6.ebuild,v 1.2 2006/05/05 09:30:14 dragonheart Exp $
+
+inherit eutils
DESCRIPTION="A sophisticated ftp/http client, file transfer program"
HOMEPAGE="http://lftp.yar.ru/"
@@ -32,6 +34,12 @@ DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/libtool"
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ epatch ${FILESDIR}/${P}-nossl.patch
+}
+
src_compile() {
local myconf="$(use_enable nls)"