summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-02-11 00:13:53 +0000
committerJeroen Roovers <jer@gentoo.org>2013-02-11 00:13:53 +0000
commitd600350a2a99b76c8d67fa20ec12724aa3049418 (patch)
treeb5e2f379dca1f5a7ba58b0d2115f53ca8294bd79 /net-ftp
parentCovert icu to subslot dependency. #455900; Drop old versions. (diff)
downloadgentoo-2-d600350a2a99b76c8d67fa20ec12724aa3049418.tar.gz
gentoo-2-d600350a2a99b76c8d67fa20ec12724aa3049418.tar.bz2
gentoo-2-d600350a2a99b76c8d67fa20ec12724aa3049418.zip
Version bump.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.4.3.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 48d2fe95614c..74c987aaa475 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.391 2013/02/05 18:14:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.392 2013/02/11 00:13:53 jer Exp $
+
+*lftp-4.4.3 (11 Feb 2013)
+
+ 11 Feb 2013; Jeroen Roovers <jer@gentoo.org> +lftp-4.4.3.ebuild:
+ Version bump.
05 Feb 2013; Jeroen Roovers <jer@gentoo.org> -lftp-4.4.1.ebuild:
Old.
diff --git a/net-ftp/lftp/lftp-4.4.3.ebuild b/net-ftp/lftp/lftp-4.4.3.ebuild
new file mode 100644
index 000000000000..d13c8a568f31
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.4.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.4.3.ebuild,v 1.1 2013/02/11 00:13:53 jer Exp $
+
+EAPI=5
+inherit autotools eutils libtool
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="gnutls nls socks5 +ssl"
+LFTP_LINGUAS=( cs de es fr it ja ko pl pt_BR ru zh_CN zh_HK zh_TW )
+IUSE+=" ${LFTP_LINGUAS[@]/#/linguas_}"
+
+RDEPEND="
+ dev-libs/expat
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ =sys-devel/libtool-2*
+ app-arch/xz-utils
+ dev-lang/perl
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=(
+ BUGS ChangeLog FAQ FEATURES MIRRORS NEWS README README.debug-levels
+ README.dnssec README.modules THANKS TODO
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-4.0.2.91-lafile.patch" \
+ "${FILESDIR}/${PN}-4.3.5-autopoint.patch" \
+ "${FILESDIR}/${PN}-4.3.8-gets.patch"
+ eautoreconf
+ elibtoolize # for Darwin bundles
+}
+
+src_configure() {
+ local myconf=""
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=${EPREFIX}/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=${EPREFIX}/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ $(use_enable nls) \
+ ${myconf} \
+ --enable-packager-mode \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --with-modules \
+ --without-included-regex
+}