summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2007-04-07 10:54:11 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2007-04-07 10:54:11 +0000
commitb389302892dc30cfe28bbe0254ce1509a88b596a (patch)
treedffe78c436681a6ab4993fea08bde4b209e9200a /net-ftp
parenttouchup (diff)
downloadgentoo-2-b389302892dc30cfe28bbe0254ce1509a88b596a.tar.gz
gentoo-2-b389302892dc30cfe28bbe0254ce1509a88b596a.tar.bz2
gentoo-2-b389302892dc30cfe28bbe0254ce1509a88b596a.zip
Remove krb4 use flag and dependency on app-crypt/kth-krb. Bug 173354
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/yafc/ChangeLog8
-rw-r--r--net-ftp/yafc/files/digest-yafc-1.1.1-r13
-rw-r--r--net-ftp/yafc/yafc-1.1.1-r1.ebuild44
3 files changed, 54 insertions, 1 deletions
diff --git a/net-ftp/yafc/ChangeLog b/net-ftp/yafc/ChangeLog
index 427bc0cc5f53..feb97b129efd 100644
--- a/net-ftp/yafc/ChangeLog
+++ b/net-ftp/yafc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/yafc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.26 2007/03/14 17:56:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.27 2007/04/07 10:54:11 masterdriverz Exp $
+
+*yafc-1.1.1-r1 (07 Apr 2007)
+
+ 07 Apr 2007; Charlie Shepherd <masterdriverz@gentoo.org>
+ +yafc-1.1.1-r1.ebuild:
+ Remove krb4 use flag and dependency on app-crypt/kth-krb. Bug 173354
14 Mar 2007; Raúl Porcel <armin76@gentoo.org>
+files/yafc-1.1.1-gcc4.patch:
diff --git a/net-ftp/yafc/files/digest-yafc-1.1.1-r1 b/net-ftp/yafc/files/digest-yafc-1.1.1-r1
new file mode 100644
index 000000000000..441a27942e4e
--- /dev/null
+++ b/net-ftp/yafc/files/digest-yafc-1.1.1-r1
@@ -0,0 +1,3 @@
+MD5 832d074183a36ee15b47553ed5962fce yafc-1.1.1.tar.bz2 858991
+RMD160 1a1af7f618e9fada90b23390e64ec0ee4c8ed370 yafc-1.1.1.tar.bz2 858991
+SHA256 ab72b2ed89fb75dbe8ebd119458cf513392225f367cccfad881e9780aefcd7e6 yafc-1.1.1.tar.bz2 858991
diff --git a/net-ftp/yafc/yafc-1.1.1-r1.ebuild b/net-ftp/yafc/yafc-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..83b986a4e291
--- /dev/null
+++ b/net-ftp/yafc/yafc-1.1.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1-r1.ebuild,v 1.1 2007/04/07 10:54:11 masterdriverz Exp $
+
+inherit eutils
+
+DESCRIPTION="Console ftp client with a lot of nifty features"
+HOMEPAGE="http://yafc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yafc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="readline kerberos socks5"
+
+DEPEND="readline? ( >=sys-libs/readline-4.1-r4 )
+ kerberos? ( virtual/krb5 )
+ socks5? ( net-proxy/dante )"
+RDEPEND=">=net-misc/openssh-3.0
+ ${DEPEND}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use kerberos && myconf="${myconf} --with-krb5=/usr/ --with-gssapi=/usr" \
+ || myconf="${myconf} --with-krb5=no --with-gssapi=no"
+ use socks5 && myconf="${myconf} --with-socks5=/usr" \
+ || myconf="${myconf} --with-socks5=no"
+ use readline && myconf="${myconf} --with-readline=/usr" \
+ || myconf="${myconf} --with-readline=no"
+
+ econf $(use_with readline) ${myconf} || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc BUGS NEWS README THANKS TODO *.sample
+}