summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-04-13 07:26:11 +0000
committerRoy Marples <uberlord@gentoo.org>2006-04-13 07:26:11 +0000
commitb13b4279dcffd4a69009fef4793ed6ec639c794b (patch)
tree19427ee6dca45ed61b1a6b756cc19c49388c5be5 /net-ftp
parent2.1_pre8-r3 bug fix revbump (diff)
downloadgentoo-2-b13b4279dcffd4a69009fef4793ed6ec639c794b.tar.gz
gentoo-2-b13b4279dcffd4a69009fef4793ed6ec639c794b.tar.bz2
gentoo-2-b13b4279dcffd4a69009fef4793ed6ec639c794b.zip
Fixed up some quoting issues and remove eindent command, #129774.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpbase/ChangeLog7
-rw-r--r--net-ftp/ftpbase/ftpbase-0.00.ebuild19
2 files changed, 14 insertions, 12 deletions
diff --git a/net-ftp/ftpbase/ChangeLog b/net-ftp/ftpbase/ChangeLog
index 5cc0929bf53f..29a10221f628 100644
--- a/net-ftp/ftpbase/ChangeLog
+++ b/net-ftp/ftpbase/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-ftp/ftpbase
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.10 2005/10/05 17:27:33 uberlord Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.11 2006/04/13 07:26:11 uberlord Exp $
+
+ 13 Apr 2006; Roy Marples <uberlord@gentoo.org> ftpbase-0.00.ebuild:
+ Fixed up some quoting issues and remove eindent command, #129774.
05 Oct 2005; Roy Marples <uberlord@gentoo.org> ftpbase-0.00.ebuild:
Use "egethome ftp" instead of greping and cuting /etc/passwd.
diff --git a/net-ftp/ftpbase/ftpbase-0.00.ebuild b/net-ftp/ftpbase/ftpbase-0.00.ebuild
index 0390ce7b59b1..c400f44a0d07 100644
--- a/net-ftp/ftpbase/ftpbase-0.00.ebuild
+++ b/net-ftp/ftpbase/ftpbase-0.00.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.00.ebuild,v 1.12 2005/10/05 17:27:33 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.00.ebuild,v 1.13 2006/04/13 07:26:11 uberlord Exp $
inherit eutils pam
@@ -18,20 +18,19 @@ DEPEND="pam? ( || ( virtual/pam sys-libs/pam ) )
!<net-ftp/pure-ftpd-1.0.20-r2
!<net-ftp/vsftpd-2.0.3-r1"
-S=${WORKDIR}
+S="${WORKDIR}"
check_collision() {
- [[ ! -e ${1} ]] && return 0
+ [[ ! -e "$1" ]] && return 0
- [[ $( head -n 1 "${1}" ) == $( head -n 1 "${2}" ) ]] && return 0
+ [[ $( head -n 1 "$1" ) == "$( head -n 1 "$2" )" ]] && return 0
- eerror "${1} exists and was not provided by ${P}"
+ eerror " $1 exists and was not provided by ${P}"
return 1
}
pkg_setup() {
ebegin "Checking for possible file collisions..."
- eindent
local collide=false
check_collision /etc/ftpusers "${FILESDIR}/ftpusers" || collide=true
@@ -47,7 +46,7 @@ pkg_setup() {
echo
ewarn "If you edited them, remember to backup and when restoring make"
ewarn " sure the first line in each file is:"
- einfo $( head -n 1 "${FILESDIR}/ftpusers" )
+ einfo "$( head -n 1 "${FILESDIR}/ftpusers" )"
eend 1
die "Can't be installed, files will collide"
fi
@@ -83,8 +82,8 @@ pkg_postinst() {
# Install manually using install -d until bug #9849 is solved.
# This means that the home directory will not be removed when we uninstall
# if it's empty.
- local homedir=$( egethome ftp )
- if [[ ! -d ${homedir} ]]; then
+ local homedir="$(egethome ftp)"
+ if [[ ! -d "${homedir}" ]]; then
einfo "Creating home directory for ftp user"
einfo " ${homedir}"
install -d "${homedir}" \