summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-11-30 16:32:28 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-11-30 16:32:28 +0000
commit249f80a8e22a4e6c4d0939d33b48f9ea0ff33b4c (patch)
tree04bb20bfd083116632d0730c49f5f178504c7083 /net-ftp
parentStable for ppc, wrt bug #442394 (diff)
downloadgentoo-2-249f80a8e22a4e6c4d0939d33b48f9ea0ff33b4c.tar.gz
gentoo-2-249f80a8e22a4e6c4d0939d33b48f9ea0ff33b4c.tar.bz2
gentoo-2-249f80a8e22a4e6c4d0939d33b48f9ea0ff33b4c.zip
Version bump, fixes problems with stalling FTP over TLS uploads, maybe finally fixing bug #431404
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/ChangeLog9
-rw-r--r--net-ftp/filezilla/filezilla-3.6.0.2.ebuild57
2 files changed, 65 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index 9b7dcd5bf7c8..65a729cffe6f 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.93 2012/11/19 09:48:18 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.94 2012/11/30 16:32:28 voyageur Exp $
+
+*filezilla-3.6.0.2 (30 Nov 2012)
+
+ 30 Nov 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ +filezilla-3.6.0.2.ebuild:
+ Version bump, fixes problems with stalling FTP over TLS uploads, maybe
+ finally fixing bug #431404
*filezilla-3.6.0.1 (19 Nov 2012)
diff --git a/net-ftp/filezilla/filezilla-3.6.0.2.ebuild b/net-ftp/filezilla/filezilla-3.6.0.2.ebuild
new file mode 100644
index 000000000000..0cffc6f8065d
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.6.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.6.0.2.ebuild,v 1.1 2012/11/30 16:32:28 voyageur Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit autotools eutils flag-o-matic multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="dbus nls test"
+
+RDEPEND=">=app-admin/eselect-wxwidgets-0.7-r1
+ >=dev-db/sqlite-3.7
+ >=dev-libs/tinyxml-2.6.1-r1[stl]
+ net-dns/libidn
+ >=net-libs/gnutls-3.1
+ >=x11-libs/wxGTK-2.8.12:2.8[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.3.5.1-debug.patch
+ append-cppflags -DTIXML_USE_STL
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-tinyxml=system \
+ --disable-autoupdatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ doicon src/interface/resources/48x48/${PN}.png
+
+ dodoc AUTHORS ChangeLog NEWS
+}