summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-12-09 11:09:28 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-12-09 11:09:28 +0000
commite0b8fb87740c4f4bc37e47b187ba7b1adc2f819c (patch)
tree519c07ef5b18f06406a4de982d2b580e43963791 /net-ftp/yafc
parentVersion bump. Bug #157330, by Daniel Webert <rockoo at gmail.com>. Removed eb... (diff)
downloadgentoo-2-e0b8fb87740c4f4bc37e47b187ba7b1adc2f819c.tar.gz
gentoo-2-e0b8fb87740c4f4bc37e47b187ba7b1adc2f819c.tar.bz2
gentoo-2-e0b8fb87740c4f4bc37e47b187ba7b1adc2f819c.zip
Add fix for gcc-4; thanks to P Nienaber for reporting; bug 127634
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'net-ftp/yafc')
-rw-r--r--net-ftp/yafc/ChangeLog6
-rw-r--r--net-ftp/yafc/files/yafc-1.1.1-gcc4.patch41
-rw-r--r--net-ftp/yafc/yafc-1.1.1.ebuild10
3 files changed, 54 insertions, 3 deletions
diff --git a/net-ftp/yafc/ChangeLog b/net-ftp/yafc/ChangeLog
index 4b3afe66416b..66e145d7408a 100644
--- a/net-ftp/yafc/ChangeLog
+++ b/net-ftp/yafc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/yafc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.19 2006/07/08 14:09:15 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.20 2006/12/09 11:09:28 masterdriverz Exp $
+
+ 09 Dec 2006; Charlie Shepherd <masterdriverz@gentoo.org>
+ +files/yafc-1.1.1-gcc4.patch, yafc-1.1.1.ebuild:
+ Add fix for gcc-4; thanks to P Nienaber for reporting; bug 127634
08 Jul 2006; Lars Weiler <pylon@gentoo.org> yafc-1.1.1.ebuild:
Stable on ppc; it's better for our default unicode-support.
diff --git a/net-ftp/yafc/files/yafc-1.1.1-gcc4.patch b/net-ftp/yafc/files/yafc-1.1.1-gcc4.patch
new file mode 100644
index 000000000000..9e0735f32d02
--- /dev/null
+++ b/net-ftp/yafc/files/yafc-1.1.1-gcc4.patch
@@ -0,0 +1,41 @@
+--- lib/krb4.c 2002-12-05 22:12:37.000000000 +0000
++++ lib/krb4.c 2006-12-09 10:49:28.000000000 +0000
+@@ -62,24 +62,6 @@
+ };
+
+ static int
+-krb_get_int(void *f, u_int32_t *to, int size, int lsb)
+-{
+- int i;
+- unsigned char *from = (unsigned char *)f;
+-
+- *to = 0;
+- if(lsb){
+- for(i = size-1; i >= 0; i--)
+- *to = (*to << 8) | from[i];
+- }else{
+- for(i = 0; i < size; i++)
+- *to = (*to << 8) | from[i];
+- }
+- return size;
+-}
+-
+-
+-static int
+ krb4_check_prot(void *app_data, int level)
+ {
+ if(level == prot_confidential)
+--- lib/gssapi.c 2002-12-05 22:12:36.000000000 +0000
++++ lib/gssapi.c 2006-12-09 10:50:18.000000000 +0000
+@@ -72,11 +72,6 @@
+ static gss_OID_desc gss_c_nt_hostbased_service_oid_desc =
+ {10, (void *)"\x2a\x86\x48\x86\xf7\x12" "\x01\x02\x01\x04"};
+
+-static gss_OID GSS_C_NT_HOSTBASED_SERVICE = &gss_c_nt_hostbased_service_oid_desc;
+-
+-
+-
+-
+ /*RCSID("$Id: gssapi.c,v 1.5 2002/12/05 22:12:36 mhe Exp $");*/
+
+ struct gss_data {
diff --git a/net-ftp/yafc/yafc-1.1.1.ebuild b/net-ftp/yafc/yafc-1.1.1.ebuild
index d60d648adbc0..fc29f2b8a1f9 100644
--- a/net-ftp/yafc/yafc-1.1.1.ebuild
+++ b/net-ftp/yafc/yafc-1.1.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1.ebuild,v 1.3 2006/07/08 14:09:15 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1.ebuild,v 1.4 2006/12/09 11:09:28 masterdriverz Exp $
-inherit flag-o-matic
+inherit eutils
DESCRIPTION="Console ftp client with a lot of nifty features"
HOMEPAGE="http://yafc.sourceforge.net/"
@@ -20,6 +20,12 @@ DEPEND="readline? ( >=sys-libs/readline-4.1-r4 )
RDEPEND=">=net-misc/openssh-3.0
${DEPEND}"
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+}
+
src_compile() {
local myconf=""
use krb4 && myconf="${myconf} --with-krb4=/usr/athena" \