summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2006-05-14 15:49:00 +0000
committerThilo Bangert <bangert@gentoo.org>2006-05-14 15:49:00 +0000
commit706eca9396cf6506eca5a70d75fd2ea71da345b2 (patch)
treece9b618564bb8c9abfa9e79ca297957820e01ff8 /net-ftp/twoftpd
parentstable amd64 (diff)
downloadgentoo-2-706eca9396cf6506eca5a70d75fd2ea71da345b2.tar.gz
gentoo-2-706eca9396cf6506eca5a70d75fd2ea71da345b2.tar.bz2
gentoo-2-706eca9396cf6506eca5a70d75fd2ea71da345b2.zip
initial import. twoftpd, a new FTP server that strives to be secure, simple, and efficient.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'net-ftp/twoftpd')
-rw-r--r--net-ftp/twoftpd/ChangeLog8
-rw-r--r--net-ftp/twoftpd/Manifest4
-rw-r--r--net-ftp/twoftpd/files/digest-twoftpd-1.211
-rw-r--r--net-ftp/twoftpd/metadata.xml13
-rw-r--r--net-ftp/twoftpd/twoftpd-1.21.ebuild40
5 files changed, 66 insertions, 0 deletions
diff --git a/net-ftp/twoftpd/ChangeLog b/net-ftp/twoftpd/ChangeLog
new file mode 100644
index 000000000000..73c439abdcaf
--- /dev/null
+++ b/net-ftp/twoftpd/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-ftp/twoftpd
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/twoftpd/ChangeLog,v 1.1 2006/05/14 15:49:00 bangert Exp $
+
+ 14 May 2006; Thilo Bangert <bangert@gentoo.org> ChangeLog:
+ initial import. twoftpd, a new FTP server that strives to
+ be secure, simple, and efficient.
+
diff --git a/net-ftp/twoftpd/Manifest b/net-ftp/twoftpd/Manifest
new file mode 100644
index 000000000000..3d424aba0c65
--- /dev/null
+++ b/net-ftp/twoftpd/Manifest
@@ -0,0 +1,4 @@
+MD5 13842a281322d31d72955a0430404207 ChangeLog 275
+MD5 888b45da2e2da021c6caea595b448706 files/digest-twoftpd-1.21 63
+MD5 a7d9b466c41b18f1dd8d72df4674b06b metadata.xml 558
+MD5 0a4bffdb517ad7c6b0f35c4ea56399d0 twoftpd-1.21.ebuild 958
diff --git a/net-ftp/twoftpd/files/digest-twoftpd-1.21 b/net-ftp/twoftpd/files/digest-twoftpd-1.21
new file mode 100644
index 000000000000..d781f4948f23
--- /dev/null
+++ b/net-ftp/twoftpd/files/digest-twoftpd-1.21
@@ -0,0 +1 @@
+MD5 aea76c06d38b50c9a230def0f16475c0 twoftpd-1.21.tar.gz 61205
diff --git a/net-ftp/twoftpd/metadata.xml b/net-ftp/twoftpd/metadata.xml
new file mode 100644
index 000000000000..a9e396315390
--- /dev/null
+++ b/net-ftp/twoftpd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bangert@gentoo.org</email>
+ <name>Thilo Bangert</name>
+</maintainer>
+<longdescription lang="en">This is twoftpd, a new FTP server that strives to be secure,
+simple, and efficient. None of the commands can cause execution of other programs,
+and the normal model of execution does a chroot to the logged in user's
+directory immediately after authentication.</longdescription>
+</pkgmetadata>
diff --git a/net-ftp/twoftpd/twoftpd-1.21.ebuild b/net-ftp/twoftpd/twoftpd-1.21.ebuild
new file mode 100644
index 000000000000..c55f36b2bb98
--- /dev/null
+++ b/net-ftp/twoftpd/twoftpd-1.21.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/twoftpd/twoftpd-1.21.ebuild,v 1.1 2006/05/14 15:49:00 bangert Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple secure efficient FTP server by Bruce Guenter"
+HOMEPAGE="http://untroubled.org/twoftpd/"
+SRC_URI="http://untroubled.org/twoftpd/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=dev-libs/bglibs-1.026
+ >=net-libs/cvm-0.32"
+RDEPEND="sys-apps/ucspi-tcp
+ sys-process/daemontools
+ >=net-libs/cvm-0.32"
+
+src_compile() {
+ echo "${D}/usr/sbin" > conf-bin
+ echo "${D}/usr/share/man" > conf-man
+ echo "$(tc-getCC) ${CFLAGS} -I${ROOT}/usr/include/bglibs" > conf-cc
+ echo "$(tc-getCC) -s -L${ROOT}/usr/lib/bglibs" > conf-ld
+ make || die "make failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ dodir /usr/share/man/man1
+
+ make install || die "install failed"
+
+ dodoc ANNOUNCEMENT COPYING ChangeLog NEWS README TODO VERSION
+ dodoc twoftpd.run twoftpd-log.run
+}
+