summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorParag Mehta <pm@gentoo.org>2001-07-04 11:04:29 +0000
committerParag Mehta <pm@gentoo.org>2001-07-04 11:04:29 +0000
commite9ad50562e7eb890dcf5415a23ea3c72aff1f417 (patch)
treefa7b657978b00a9bc79e58ffe4c20cb8bd8fc57b /net-ftp/pure-ftpd
parentModified that startup files to have bind running when installed. (diff)
downloadgentoo-2-e9ad50562e7eb890dcf5415a23ea3c72aff1f417.tar.gz
gentoo-2-e9ad50562e7eb890dcf5415a23ea3c72aff1f417.tar.bz2
gentoo-2-e9ad50562e7eb890dcf5415a23ea3c72aff1f417.zip
Modified to start pure-ftpd post config from inetd.conf so that /etc/xinetd file is generated properly.
Diffstat (limited to 'net-ftp/pure-ftpd')
-rw-r--r--net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7-r21
-rw-r--r--net-ftp/pure-ftpd/files/pftpd.inetd6
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-0.98.7-r2.ebuild44
3 files changed, 51 insertions, 0 deletions
diff --git a/net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7-r2 b/net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7-r2
new file mode 100644
index 000000000000..f6c4a53075df
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7-r2
@@ -0,0 +1 @@
+MD5 381169cc31fdebfa2d414cd264d8485b pure-ftpd-0.98.7.tar.gz
diff --git a/net-ftp/pure-ftpd/files/pftpd.inetd b/net-ftp/pure-ftpd/files/pftpd.inetd
new file mode 100644
index 000000000000..2dab05417e27
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/pftpd.inetd
@@ -0,0 +1,6 @@
+# ----------------
+# Pure-FTPd Server
+# ----------------
+#ftp stream tcp nowait root /usr/sbin/pure-ftpd
+#
+
diff --git a/net-ftp/pure-ftpd/pure-ftpd-0.98.7-r2.ebuild b/net-ftp/pure-ftpd/pure-ftpd-0.98.7-r2.ebuild
new file mode 100644
index 000000000000..3e396e852864
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-0.98.7-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Prakash Shetty (Crux) <ps@gnuos.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Fast Production Quality FTP Server"
+SRC_URI="http://prdownloads.sourceforge.net/pureftpd/${A}"
+HOMEPAGE="http://pureftpd.sourceforge.net"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.75"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --with-throttling --with-virtualhosts\
+ --with-ratios --with-largefile
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc COPYING ChangeLog README README.Configuration-File
+ dodoc README.Contrib README.LDAP README.Netfilter
+ dodir /etc/pure-ftpd
+}
+
+pkg_config() {
+ echo "This config script will add pftpd lines to your /etc/xinetd.conf."
+ echo "Press control-C to abort, hit Enter to continue."
+ echo
+ read
+ cat ${FILESDIR}/pftpd.inetd >> ${ROOT}etc/inetd.conf
+ ln -s /dev/null /etc/pure-ftpd/127.0.0.1
+ /etc/rc.d/init.d/svc-xinetd restart
+ echo "Modifications applied."
+}
+
+
+