summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-08-13 14:57:45 +0000
committerJeroen Roovers <jer@gentoo.org>2009-08-13 14:57:45 +0000
commitfdb08e86faf502951ac0bb2990921bf29be0563f (patch)
treebf7f0382991546a49c795ca7cec3b0013738b9f5 /net-ftp/lftp
parentRequire ALSA_PCM_PLUGIN ioplug on alsa-lib, bug 185362 (diff)
downloadgentoo-2-fdb08e86faf502951ac0bb2990921bf29be0563f.tar.gz
gentoo-2-fdb08e86faf502951ac0bb2990921bf29be0563f.tar.bz2
gentoo-2-fdb08e86faf502951ac0bb2990921bf29be0563f.zip
Version bump.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-3.99.12.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 344d9af2bb98..6dc12b2e1e80 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.215 2009/08/12 02:00:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.216 2009/08/13 14:57:45 jer Exp $
+
+*lftp-3.99.12 (13 Aug 2009)
+
+ 13 Aug 2009; Jeroen Roovers <jer@gentoo.org> +lftp-3.99.12.ebuild:
+ Version bump.
*lftp-3.99.10 (12 Aug 2009)
diff --git a/net-ftp/lftp/lftp-3.99.12.ebuild b/net-ftp/lftp/lftp-3.99.12.ebuild
new file mode 100644
index 000000000000..b096ac0cf153
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.99.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.99.12.ebuild,v 1.1 2009/08/13 14:57:45 jer Exp $
+
+EAPI="2"
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="ftp://ftp.yar.ru/lftp/devel/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ >=sys-libs/readline-5.1"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}