summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-08-12 02:00:38 +0000
committerJeroen Roovers <jer@gentoo.org>2009-08-12 02:00:38 +0000
commit7e802c121a6693691d24631f68e3aa2621c374e7 (patch)
tree1d7829daea1a2610f5217521051f4c1fada6463d /net-ftp/lftp
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-7e802c121a6693691d24631f68e3aa2621c374e7.tar.gz
gentoo-2-7e802c121a6693691d24631f68e3aa2621c374e7.tar.bz2
gentoo-2-7e802c121a6693691d24631f68e3aa2621c374e7.zip
Version bump.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-3.99.10.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index a9f07e1e02c2..344d9af2bb98 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.214 2009/08/10 15:56:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.215 2009/08/12 02:00:38 jer Exp $
+
+*lftp-3.99.10 (12 Aug 2009)
+
+ 12 Aug 2009; Jeroen Roovers <jer@gentoo.org> +lftp-3.99.10.ebuild:
+ Version bump.
*lftp-3.99.9 (10 Aug 2009)
diff --git a/net-ftp/lftp/lftp-3.99.10.ebuild b/net-ftp/lftp/lftp-3.99.10.ebuild
new file mode 100644
index 000000000000..0d83da3b7f0f
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.99.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.99.10.ebuild,v 1.1 2009/08/12 02:00:38 jer Exp $
+
+EAPI="2"
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="ftp://ftp.yar.ru/lftp/devel/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ >=sys-libs/readline-5.1"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}