summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2002-05-28 00:04:31 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2002-05-28 00:04:31 +0000
commit74b0f30173739db0f54f1436d2b69c96d847e591 (patch)
tree14b22c4813ea62acb32db6fbe7f15269e89a742a /net-ftp/ftpcube
parentximian, redhat/mdk patches (diff)
downloadgentoo-2-74b0f30173739db0f54f1436d2b69c96d847e591.tar.gz
gentoo-2-74b0f30173739db0f54f1436d2b69c96d847e591.tar.bz2
gentoo-2-74b0f30173739db0f54f1436d2b69c96d847e591.zip
first relase
Diffstat (limited to 'net-ftp/ftpcube')
-rw-r--r--net-ftp/ftpcube/Changelog9
-rw-r--r--net-ftp/ftpcube/files/digest-ftpcube-0.3.11
-rw-r--r--net-ftp/ftpcube/files/setup.cfg.patch8
-rw-r--r--net-ftp/ftpcube/ftpcube-0.3.1.ebuild27
4 files changed, 45 insertions, 0 deletions
diff --git a/net-ftp/ftpcube/Changelog b/net-ftp/ftpcube/Changelog
new file mode 100644
index 000000000000..fe19c55b71ad
--- /dev/null
+++ b/net-ftp/ftpcube/Changelog
@@ -0,0 +1,9 @@
+# ChangeLog for net-ftp/ftpcube
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# Author: José Alberto Suárez López <bass@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/Changelog,v 1.1 2002/05/28 00:04:31 bass Exp $
+
+*ftpcube-0.3.1 (28 May 2002)
+
+ 28 May 2002; J.Alberto S.L. <bass@gentoo.org> ftpcube-0.3.1.ebuild:
+ First relase.
diff --git a/net-ftp/ftpcube/files/digest-ftpcube-0.3.1 b/net-ftp/ftpcube/files/digest-ftpcube-0.3.1
new file mode 100644
index 000000000000..bf8873f6cf97
--- /dev/null
+++ b/net-ftp/ftpcube/files/digest-ftpcube-0.3.1
@@ -0,0 +1 @@
+MD5 e23f1f59a3c65773dfc17e3454cf4fd0 ftpcube-0.3.1.tar.gz 64935
diff --git a/net-ftp/ftpcube/files/setup.cfg.patch b/net-ftp/ftpcube/files/setup.cfg.patch
new file mode 100644
index 000000000000..580f09d0abc8
--- /dev/null
+++ b/net-ftp/ftpcube/files/setup.cfg.patch
@@ -0,0 +1,8 @@
+
++++ setup.cfg.new 2002-05-28 01:47:29.000000000 +0200
+@@ -1,3 +1,3 @@
+ [install]
+-install_data=/usr/local/share/ftpcube
+-install_scripts=/usr/local/bin
++install_data=${D}/usr/share/ftpcube
++install_scripts=${D}/usr/bin
diff --git a/net-ftp/ftpcube/ftpcube-0.3.1.ebuild b/net-ftp/ftpcube/ftpcube-0.3.1.ebuild
new file mode 100644
index 000000000000..b7839dba9265
--- /dev/null
+++ b/net-ftp/ftpcube/ftpcube-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.3.1.ebuild,v 1.1 2002/05/28 00:04:31 bass Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A graphical FTP client written in Python with GTK bindings."
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/ftpcube/${P}.tar.gz"
+HOMEPAGE="http://ftpcube.sourceforge.net/"
+LICENSE="Artistic"
+DEPEND="dev-python/pygtk"
+RDEPEND="${DEPEND}"
+SLOT="0"
+
+src_unpack() {
+ unpack ftpcube-0.3.1.tar.gz
+ cd ${WORKDIR}/ftpcube-0.3.1
+ patch setup.cfg < ${FILESDIR}/setup.cfg.patch || die "config patch failed"
+}
+
+src_compile() {
+ python setup.py build || die "make failed"
+}
+
+src_install () {
+ python setup.py install || die "install failed"
+}
+